LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   32-bit Firefox on x86_64 (FC5)... (http://www.linuxquestions.org/questions/fedora-35/32-bit-firefox-on-x86_64-fc5-428135/)

sancho 03-24-2006 03:57 PM

32-bit Firefox on x86_64 (FC5)...
 
Hi all.

I just installed FC5 (x86_64) on my Turion64 laptop. So far, so good; however, as everybody has probably noticed, you don't get far on the Internet these days without a Macromedia Flash plugin. As Macromedia hasn't gotten on the schtick yet and released a 64-bit plugin, I will be forced to run the 32-bit Firefox, which is not included by default in 64-bit FC5.

On my old FC4 install, I achieved this simply by downloading the "stock" 32-bit Firefox from http://www.getfirefox.com/ (the main reason being that I wanted to use Firefox 1.5 but there were no FC4 RPMS available at the time). That got the job done, but lacked some integration with GNOME that the Fedora-provided RPMS had.

Thus, I would like to use the Fedora-supplied 32-bit Firefox for FC5. I followed the suggestion on this post in order to setup a Yum repository, replacing the "4" with a "5" obviously where necessary. I then executed
Code:

yum --enablerepo=base-i386 install firefox.i386
. It looks like it will go through; however, it also wants to install some other i386 libs along with it...

Code:

Dependencies Resolved

=============================================================================
 Package                Arch      Version          Repository        Size
=============================================================================
Installing:
 firefox                i386      1.5.0.1-9        base-i386          17 M
Installing for dependencies:
 esound                  i386      1:0.2.36-2.2.1  core              130 k
 gnome-keyring          i386      0.4.9-1          core              140 k
 libbonoboui            i386      2.14.0-1        base-i386        384 k
 libgnome                i386      2.14.0-1        base-i386        843 k
 libgnomeui              i386      2.14.0-1        base-i386        974 k

Transaction Summary
=============================================================================
Install      6 Package(s)
Update      0 Package(s)
Remove      0 Package(s)
Total download size: 19 M
Is this ok [y/N]:

So, my questions are...

1a. This didn't say anything about removing the existing (64-bit) Firefox. So, when I click my Firefox icon in GNOME, how is it going to know which version to run?

1b. Should I just simplify things and remove the 64-bit Firefox?

2. It wants to install i386 versions of libs which undoubtedly already exist on my machine in x86_64 variants. Can these libs coexist with the 64-bit libs? In other words, will the applications that are already happy using the 64-bit libs continue to use the 64-bit libs, or will they prefer the 32-bit libs?

Thanks!

Lenard 03-24-2006 04:34 PM

Answers 1a; the i386 version will run, see answer 1b
Answer 1b; that's a good idea, see answer 1a

Answer 2;
This is normal nothing to fret about, many of us are running mixed mode environments (both 32-bit and 64-bit applications) with out a problem. Yes, the 32-bit libs can and do coexist with the 64-bit counterparts. The 64-bit applications will use the 64-bit libs, the 32-bit applications will use the 32-bit libs, cannot run 64-bit or 32-bit applications without the required libs.

sancho 03-24-2006 05:34 PM

Quote:

Answers 1a; the i386 version will run, see answer 1b
Answer 1b; that's a good idea, see answer 1a
My head almost crashed after reading that. ;)

Thanks for the responses; I'll go ahead and go through with the original plan and remove the 64-bit Firefox.

Lenard 03-24-2006 06:33 PM

Glad you enjoyed it......

I just had to do it!!!!!!

FYI: when you get around to installing mplayer install the 32-bit version, some (OK most of) the codec plugins do not work with the 64-bit version (wma comes to mind).

croco 08-06-2006 05:09 PM

hey guys! ive been trying to install 32-bit firefox on my 64-bit system, and i can get as far as downloading the packages, but then i get loads of errors:

Code:

Transaction Check Error:  package libgnome-2.14.1-1.fc5.1 (which is newer than libgnome-2.10.0-3) is already installed
  package libgnomeui-2.14.1-1.fc5.1 (which is newer than libgnomeui-2.10.0-1) is already installed
  package libbonoboui-2.14.0-1 (which is newer than libbonoboui-2.8.1-4) is already installed
  file /etc/gconf/schemas/desktop_gnome_accessibility_keyboard.schemas from install of libgnome-2.10.0-3 conflicts with file from package libgnome-2.14.1-1.fc5.1
  file /etc/gconf/schemas/desktop_gnome_accessibility_startup.schemas from install of libgnome-2.10.0-3 conflicts with file from package libgnome-2.14.1-1.fc5.1
  file /etc/gconf/schemas/desktop_gnome_applications_browser.schemas from install of libgnome-2.10.0-3 conflicts with file from package libgnome-2.14.1-1.fc5.1
  file /etc/gconf/schemas/desktop_gnome_applications_help_viewer.schemas from install of libgnome-2.10.0-3 conflicts with file from package libgnome-2.14.1-1.fc5.1
  file /etc/gconf/schemas/desktop_gnome_applications_terminal.schemas from install of libgnome-2.10.0-3 conflicts with file from package libgnome-2.14.1-1.fc5.1
  file /etc/gconf/schemas/desktop_gnome_applications_window_manager.schemas from install of libgnome-2.10.0-3 conflicts with file from package libgnome-2.14.1-1.fc5.1
  file /etc/gconf/schemas/desktop_gnome_background.schemas from install of libgnome-2.10.0-3 conflicts with file from package libgnome-2.14.1-1.fc5.1
  file /etc/gconf/schemas/desktop_gnome_file_views.schemas from install of libgnome-2.10.0-3 conflicts with file from package libgnome-2.14.1-1.fc5.1
  file /etc/gconf/schemas/desktop_gnome_interface.schemas from install of libgnome-2.10.0-3 conflicts with file from package libgnome-2.14.1-1.fc5.1
  file /etc/gconf/schemas/desktop_gnome_lockdown.schemas from install of libgnome-2.10.0-3 conflicts with file from package libgnome-2.14.1-1.fc5.1
  file /etc/gconf/schemas/desktop_gnome_peripherals_keyboard.schemas from install of libgnome-2.10.0-3 conflicts with file from package libgnome-2.14.1-1.fc5.1
  file /etc/gconf/schemas/desktop_gnome_peripherals_mouse.schemas from install of libgnome-2.10.0-3 conflicts with file from package libgnome-2.14.1-1.fc5.1
  file /etc/gconf/schemas/desktop_gnome_sound.schemas from install of libgnome-2.10.0-3 conflicts with file from package libgnome-2.14.1-1.fc5.1
  file /etc/gconf/schemas/desktop_gnome_thumbnailers.schemas from install of libgnome-2.10.0-3 conflicts with file from package libgnome-2.14.1-1.fc5.1
  file /etc/gconf/schemas/desktop_gnome_typing_break.schemas from install of libgnome-2.10.0-3 conflicts with file from package libgnome-2.14.1-1.fc5.1
  file /etc/sound/events/gnome-2.soundlist from install of libgnome-2.10.0-3 conflicts with file from package libgnome-2.14.1-1.fc5.1
  file /etc/sound/events/gtk-events-2.soundlist from install of libgnome-2.10.0-3 conflicts with file from package libgnome-2.14.1-1.fc5.1

im a linux newbie, so any help you can give would be much appreciated

oh and if your interested heres the packages it tried to install:
Code:

=============================================================================
 Package                Arch      Version          Repository        Size
=============================================================================
Installing:
 firefox                i386      1.0.4-4          base-i386          18 M
Installing for dependencies:
 gnome-keyring          i386      0.4.9-1          core              140 k
 libbonoboui            i386      2.8.1-4          base-i386        356 k
 libgnome                i386      2.10.0-3        base-i386        705 k
 libgnomeui              i386      2.10.0-1        base-i386        848 k
 xorg-x11-libs          i386      6.8.2-31        base-i386        2.5 M

Transaction Summary
=============================================================================
Install      6 Package(s)
Update      0 Package(s)
Remove      0 Package(s)
Total download size: 23 M
Is this ok [y/N]: y


Lenard 08-06-2006 08:11 PM

Quote:

Originally Posted by croco
hey guys! ive been trying to install 32-bit firefox on my 64-bit system, and i can get as far as downloading the packages, but then i get loads of errors:

Code:

Transaction Check Error:  package libgnome-2.14.1-1.fc5.1 (which is newer than libgnome-2.10.0-3) is already installed
  package libgnomeui-2.14.1-1.fc5.1 (which is newer than libgnomeui-2.10.0-1) is already installed


Hmmmmm......... it seems that some FC5 rpms are installed...........

Quote:

oh and if your interested heres the packages it tried to install:
Code:

=============================================================================
 Package                Arch      Version          Repository        Size
=============================================================================
Installing:
 firefox                i386      1.0.4-4          base-i386          18 M
Installing for dependencies:
 gnome-keyring          i386      0.4.9-1          core              140 k
 libbonoboui            i386      2.8.1-4          base-i386        356 k
 libgnome                i386      2.10.0-3        base-i386        705 k
 libgnomeui              i386      2.10.0-1        base-i386        848 k
 xorg-x11-libs          i386      6.8.2-31        base-i386        2.5 M

Transaction Summary
=============================================================================
Install      6 Package(s)
Update      0 Package(s)
Remove      0 Package(s)
Total download size: 23 M
Is this ok [y/N]: y


And the firefox version your trying to install is for FC4 just like the gnome and xorg-xll-libs packages listed above.

So I suspect that you have FC4 installed correct???

Check; cat /etc/*release

First thing first, please bring your installation current follow the instructions here;

http://www.fedorafaq.org/fc4/#installsoftware

When done with the yum update plase do

yum update

Next you need to get the matching 32-bit versions of the gnome-keyring, libbonoboui, libgnome and libgnomeui rpm packages from FC5 and install them along with any required dependencies. Install the updated xorg-x11-libs rpm by typing something like;

yum install xorg-x11-libs-6.8.2-37.FC4.49.2.1.i386

Then if you want;

yum install firefox-1.0.8-1.1.fc4.i386

If possible build the latest firefox-1.5.0.6 32-bit rpm package (maybe a friend can help???), I posted info on how to do this here;

http://www.linuxquestions.org/questi...d.php?t=469137

croco 08-08-2006 04:14 AM

kk thanks for the help, id be lost without these forums ^^

GATTACA 08-24-2006 10:36 PM

I've got the same problem as croco, and I'm running FC5 on an x86_64 machine.

I've followed this tutorial and all the others I can find on-line. None of them have sucessfully allowed me to install i386 Firefox.

Can it be installed by just downloading the binary *.tar.gz from Mozilla's site?

Thanks,

Lenard 08-25-2006 05:45 AM

Yes but it is not quite that simple, a little extra work is required....

The libstdc++.so.5 32-bit lib file is needed for the 32-bit version to work, it is part of the compat-libstdc++-33-3.2.3-55.fc5.i386.rpm package and this needs the 64-bit counterpart in order to be used properly on a 64-bit OS. Both of these packages can be installed at the same time by typing something like; rpm -Uvh compat*.rpm

Then you can extract firefox tar.qz file into your home directory. You will have to create/edit your own link for this to be present on the GUI menu.

For additional insite see; http://stanton-finley.net/mediawiki/...allation_Notes

webranger 10-22-2006 06:08 PM

Works pretty good
 
I run the site at retrovision.tv and I'm using a couple of athlon x2 computers to do encoding, so I didn't want to kill mplayer by installing it in 32 bit, also the vlc plugin has a hemmorage unless it's 32 bit too.

Running 32-bit apps gets to be a hassle and that you might as well have installed 32-bit linux by the time you screw things up by dual librarying everything. I think Stanton Finley sorta says this less forcefully too.

So, because I'm running a TV site, and wanted to take advantage of the 64 bit OS, I figured out something that works pretty slick. I just use windows firefox and wine. This gives you windows java and flash the MediaPlayerConnectivity plugin will launch vlc or mplayer (also wine installed).

This is kind of a screwy solution, but on athlon 64 computers, you won't notice the emulation, and it keeps your libraries from getting weird.

After all, it's just a browser.

One way is "yum install wine" and the other is messing around for a couple hours and wishing you hadn't.

Lenard 10-22-2006 06:40 PM

It is not hard to get the 32-bit version firefox working on a a 64-bit system, most Red Hat based distro's load the 32 libs needed along with 64-bit libs. I have the RHEL5beta1 installed (with updates) on both 32 and 64 bit systems. Both have the latest 32-bit versions of firefox, mplayer along with the mplayerplug-in, Adobe, flashplayer (the new flash 9 beta which is not quite right yet), the latest jre and other plugins installed and working without any problems. In fact while the jre is 32-bit it is installed along with the latest 64-bit jdk.

webranger 10-23-2006 09:50 AM

Red Hat isn't free software. It is nice to know that if you pay, they made it happy. I found out (and I have gotten it working) that so little of the 64 bit OS remained to make the browser work, that I should have installed 32 bit.

DyingMuppet 10-23-2006 10:19 AM

Hey Guys I just got the same error as of you but then I remembered I madde the base-i386.repo file in /etc/yum.repos.d/.. and there was the problem because in the file theres something like:
Code:

[base-i386]
name=base-i386
baseurl=http://download.fedora.redhat.com/pub/fedora/linux/core/4/i386/os/
gpgcheck=1
enabled=0

so it will install the FC4 programīs..
now just type
Code:

gedit /etc/yum.repos.d/base-i386.repo
in root and edit 4 to 5 and youre done.. I hope...

..I haven tried it yet because FF1.5 x86_64 still working while typing this :P
so Lets try:)

DyingMuppet 10-23-2006 10:33 AM

no succes
 
Quote:

Originally Posted by DyingMuppet
Hey Guys I just got the same error as of you but then I remembered I madde the base-i386.repo file in /etc/yum.repos.d/.. and there was the problem because in the file theres something like:
Code:

[base-i386]
name=base-i386
baseurl=http://download.fedora.redhat.com/pub/fedora/linux/core/4/i386/os/
gpgcheck=1
enabled=0

so it will install the FC4 programīs..
now just type
Code:

gedit /etc/yum.repos.d/base-i386.repo
in root and edit 4 to 5 and youre done.. I hope...

..I haven tried it yet because FF1.5 x86_64 still working while typing this :P
so Lets try:)

getting back on my own post:

still getting some transaction check errors, here it is..
Code:

=============================================================================
 Package                Arch      Version          Repository        Size
=============================================================================
Installing:
 firefox                i386      1.5.0.1-9        base-i386          17 M
Installing for dependencies:
 gnome-keyring          i386      0.4.9-1          core              140 k
 libbonoboui            i386      2.14.0-1        base-i386        384 k
 libgnome                i386      2.14.0-1        base-i386        843 k
 libgnomeui              i386      2.14.0-1        base-i386        974 k

Transaction Summary
=============================================================================
Install      5 Package(s)
Update      0 Package(s)
Remove      0 Package(s)
Total download size: 19 M
Is this ok [y/N]: y
Downloading Packages:
(1/5): firefox-1.5.0.1-9. 100% |=========================|  17 MB    02:10
(2/5): libgnome-2.14.0-1. 100% |=========================| 843 kB    00:07
(3/5): libgnomeui-2.14.0- 100% |=========================| 974 kB    00:06
(4/5): libbonoboui-2.14.0 100% |=========================| 384 kB    00:01
(5/5): gnome-keyring-0.4. 100% |=========================| 140 kB    00:01
Running Transaction Test
Finished Transaction Test

there everything looked fine for a moment but then...
Code:

Transaction Check Error:  package libgnome-2.14.1-1.fc5.1 (which is newer than libgnome-2.14.0-1) is already installed
  package libgnomeui-2.14.1-1.fc5.1 (which is newer than libgnomeui-2.14.0-1) is already installed
  file /etc/gconf/schemas/desktop_gnome_accessibility_keyboard.schemas from install of libgnome-2.14.0-1 conflicts with file from package libgnome-2.14.1-1.fc5.1
  file /etc/gconf/schemas/desktop_gnome_accessibility_startup.schemas from install of libgnome-2.14.0-1 conflicts with file from package libgnome-2.14.1-1.fc5.1
  file /etc/gconf/schemas/desktop_gnome_applications_browser.schemas from install of libgnome-2.14.0-1 conflicts with file from package libgnome-2.14.1-1.fc5.1
  file /etc/gconf/schemas/desktop_gnome_applications_help_viewer.schemas from install of libgnome-2.14.0-1 conflicts with file from package libgnome-2.14.1-1.fc5.1
  file /etc/gconf/schemas/desktop_gnome_applications_terminal.schemas from install of libgnome-2.14.0-1 conflicts with file from package libgnome-2.14.1-1.fc5.1
  file /etc/gconf/schemas/desktop_gnome_applications_window_manager.schemas from install of libgnome-2.14.0-1 conflicts with file from package libgnome-2.14.1-1.fc5.1
  file /etc/gconf/schemas/desktop_gnome_background.schemas from install of libgnome-2.14.0-1 conflicts with file from package libgnome-2.14.1-1.fc5.1
  file /etc/gconf/schemas/desktop_gnome_file_views.schemas from install of libgnome-2.14.0-1 conflicts with file from package libgnome-2.14.1-1.fc5.1
  file /etc/gconf/schemas/desktop_gnome_interface.schemas from install of libgnome-2.14.0-1 conflicts with file from package libgnome-2.14.1-1.fc5.1
  file /etc/gconf/schemas/desktop_gnome_lockdown.schemas from install of libgnome-2.14.0-1 conflicts with file from package libgnome-2.14.1-1.fc5.1
  file /etc/gconf/schemas/desktop_gnome_peripherals_keyboard.schemas from install of libgnome-2.14.0-1 conflicts with file from package libgnome-2.14.1-1.fc5.1
  file /etc/gconf/schemas/desktop_gnome_peripherals_mouse.schemas from install of libgnome-2.14.0-1 conflicts with file from package libgnome-2.14.1-1.fc5.1
  file /etc/gconf/schemas/desktop_gnome_sound.schemas from install of libgnome-2.14.0-1 conflicts with file from package libgnome-2.14.1-1.fc5.1
  file /etc/gconf/schemas/desktop_gnome_thumbnailers.schemas from install of libgnome-2.14.0-1 conflicts with file from package libgnome-2.14.1-1.fc5.1
  file /etc/gconf/schemas/desktop_gnome_typing_break.schemas from install of libgnome-2.14.0-1 conflicts with file from package libgnome-2.14.1-1.fc5.1
  file /etc/sound/events/gnome-2.soundlist from install of libgnome-2.14.0-1 conflicts with file from package libgnome-2.14.1-1.fc5.1
  file /etc/sound/events/gtk-events-2.soundlist from install of libgnome-2.14.0-1 conflicts with file from package libgnome-2.14.1-1.fc5.1

looks like some are already installed half?

or is it because i'm still in gnome? hmm... I will come back on that..

Grtzz DM

DyingMuppet 10-23-2006 10:50 AM

I still get the error and can't find anything to work I will try the wine emulation maybe then I get some success;)

Grtzz DM


All times are GMT -5. The time now is 08:20 AM.