LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 06-01-2007, 06:34 PM   #1
AJuice
LQ Newbie
 
Registered: Dec 2006
Posts: 2

Rep: Reputation: 0
XSessions won't start at login


Hi, I've been running sarge and gnome till the other day, when I decided to upgrade to etch, so following an article, I changed the apt sources and updated debian, which works and boots ok, except for gnome.

The X server starts up ok, and load to the login screen, but whenever you try to log in, whether it be KDE or gnome, failsafe or terminal, this error window comes up...

"Your session only lasted less than 10 seconds. If you have not logged out yourself, this could mean that there is some installation problem, or that you may be out of disk space.
Try logging in with on of the failsafe sessions to see if you can fix this problem."

There is a checkbox to display the contents of the ~/.xsession-errors file. This says

/etc/gdm/PreSession/Default: Registering your session with wtmp and utmp
/etc/gdm/PreSession/Default: /Default: Running /usr/bin/sesreg -a -w /var/log/wtmp -u /var/run/utmp -x "/var/lib/gdm/:0.xservers -h "" -l ":0" "<myusername>"
/etc/gdm/xsession: Beginning session setup...
xlib: Connection to ":0.0" refused by server
xlib: Protocol not supported by server

<myusername> is obviously my user name...

I've spent a couple days trying to suss it out with no avail. Any help would be greatly appreciated.

Thanks,

AJuice

/edit
I just found a person with the exact same problem here...
http://ubuntuforums.org/showthread.php?p=92344

Last edited by AJuice; 06-01-2007 at 06:37 PM.
 
Old 06-01-2007, 06:59 PM   #2
Dutch Master
Senior Member
 
Registered: Dec 2005
Posts: 1,682

Rep: Reputation: 124Reputation: 124
I presume you're thrown back to a terminal after the failed session. Can you start an X-session manually then? If not, check if the X-server is actually installed. Use aptitude in a rootterminal, press the / key, enter "xserver-xorg" as searchstring (w/o the ") and use the n key to step through the results. Install the package with the + key on the numerical pad. Press g twice to install. The package is installed if an i is shown in front of the package.
 
Old 06-01-2007, 11:15 PM   #3
AJuice
LQ Newbie
 
Registered: Dec 2006
Posts: 2

Original Poster
Rep: Reputation: 0
No, sorry I should've mentioned. After it fails to open a session, it goes back to the login screen. xserver is installed and appears to be configured and working (at least up till the login screen) correctly. I dpkg-reconfigure'd it just to make sure the settings we all ok, and that it starts fine..

AJuice

Last edited by AJuice; 06-01-2007 at 11:17 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
remote xsessions tsunami_imcool Linux - Newbie 1 01-26-2007 11:38 AM
killing Xsessions GUIPenguin Linux - General 3 03-25-2005 07:24 PM
running multiple xsessions TheOneAndOnlySM Slackware 9 08-19-2004 11:19 PM
Pam refuses regular user's access to Xsessions vexer Linux - Security 1 02-12-2004 01:11 PM
just a heads up about remote Xsessions and disk space antken Linux - General 0 11-26-2003 03:40 PM


All times are GMT -5. The time now is 11:59 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration