LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices



Reply
 
Search this Thread
Old 09-01-2009, 09:25 AM   #1
matal0
LQ Newbie
 
Registered: Jan 2007
Location: france
Distribution: Debian
Posts: 1

Rep: Reputation: 0
xorg radeonhd driver & 'unable to open display' with glxinfo


######################
Please don't laugh...

I run glxinfo as root (instead of running it as a user) so that's why i get the message 'unable to open display'.... :/
Sorry...
Everything is ok !

Thanks
######################
Hi all,

I installed the xorg radeonhd driver on my Debian Sid for an ATI X1950 PRO.

And when I do glxinfo , I get this :

No protocol specified
Error: unable to open display :0.0


So I think dri is not enabled.
But, as you will see, in my Xorg.0.log, there is Direct rendering enabled...
So I don't know. Maybe I did something wrong.

I got no (EE) in my Xorg.0.log

I made a list of all the infos that I think it can be usefull for you to help me.
But tell me if you need other infos (maybe strace glxinfo).

Code:
--------------------------------------------------

Debian GNU/Linux squeeze/sid 
Linux 2.6.30-1-686 GNU/Linux

--------------------------------------------------

lspci -v | grep -i radeon

01:00.0 VGA compatible controller: ATI Technologies Inc RV570 [Radeon X1950 Pro] (prog-if 00 [VGA controller])
01:00.1 Display controller: ATI Technologies Inc RV570 [Radeon X1950 Pro] (secondary)

--------------------------------------------------

dpkg -l | grep -i xorg

ii  xorg                                 1:7.4+4                        X.Org X Window System
ii  xorg-docs                            1:1.4-5                        Miscellaneous documentation for the X.org X 
ii  xorg-docs-core                       1:1.4-5                        Core documentation for the X.org X Window Sy
ii  xserver-xorg                         1:7.4+4                        the X.Org X server
ii  xserver-xorg-core                    2:1.6.3-1+b1                   Xorg X server - core server
ii  xserver-xorg-input-all               1:7.4+4                        the X.Org X server -- input driver metapacka
ii  xserver-xorg-input-evdev             1:2.2.5-1                      X.Org X server -- evdev input driver
ii  xserver-xorg-input-kbd               1:1.3.2-4                      X.Org X server -- keyboard input driver
ii  xserver-xorg-input-mouse             1:1.4.0-4                      X.Org X server -- mouse input driver
ii  xserver-xorg-input-synaptics         1.1.2-1                        Synaptics TouchPad driver for X.Org server
ii  xserver-xorg-input-wacom             0.8.3.2-1                      X.Org X server -- Wacom input driver
ii  xserver-xorg-video-all               1:7.4+4                        the X.Org X server -- output driver metapack
ii  xserver-xorg-video-apm               1:1.2.1-2                      X.Org X server -- APM display driver
ii  xserver-xorg-video-ark               1:0.7.1-2                      X.Org X server -- ark display driver
ii  xserver-xorg-video-ati               1:6.12.2-3                     X.Org X server -- ATI display driver wrapper
ii  xserver-xorg-video-chips             1:1.2.1-3                      X.Org X server -- Chips display driver
ii  xserver-xorg-video-cirrus            1:1.3.1-1                      X.Org X server -- Cirrus display driver
ii  xserver-xorg-video-dummy             1:0.3.1-2                      X.Org X server -- dummy display driver
ii  xserver-xorg-video-fbdev             1:0.4.0-4                      X.Org X server -- fbdev display driver
ii  xserver-xorg-video-glint             1:1.2.3-1                      X.Org X server -- Glint display driver
ii  xserver-xorg-video-i128              1:1.3.2-1                      X.Org X server -- i128 display driver
ii  xserver-xorg-video-i740              1:1.3.0-1                      X.Org X server -- i740 display driver
ii  xserver-xorg-video-intel             2:2.8.1-1                      X.Org X server -- Intel i8xx, i9xx display d
ii  xserver-xorg-video-mach64            6.8.2-1                        X.Org X server -- ATI Mach64 display driver
ii  xserver-xorg-video-mga               1:1.4.11.dfsg-1                X.Org X server -- MGA display driver
ii  xserver-xorg-video-neomagic          1:1.2.3-1                      X.Org X server -- Neomagic display driver
ii  xserver-xorg-video-nv                1:2.1.14-2                     X.Org X server -- NV display driver
ii  xserver-xorg-video-openchrome        1:0.2.903+svn741-1+b1          X.Org X server -- VIA display driver
ii  xserver-xorg-video-r128              6.8.1-1                        X.Org X server -- ATI r128 display driver
ii  xserver-xorg-video-radeon            1:6.12.2-3                     X.Org X server -- ATI Radeon display driver
ii  xserver-xorg-video-radeonhd          1.2.5-1                        X.Org X server -- AMD/ATI r5xx, r6xx display
ii  xserver-xorg-video-rendition         1:4.2.1-1                      X.Org X server -- Rendition display driver
ii  xserver-xorg-video-s3                1:0.6.2-1                      X.Org X server -- legacy S3 display driver
ii  xserver-xorg-video-s3virge           1:1.10.2-2                     X.Org X server -- S3 ViRGE display driver
ii  xserver-xorg-video-savage            1:2.3.0-1                      X.Org X server -- Savage display driver
ii  xserver-xorg-video-siliconmotion     1:1.7.2-1                      X.Org X server -- SiliconMotion display driv
ii  xserver-xorg-video-sis               1:0.10.1-2                     X.Org X server -- SiS display driver
ii  xserver-xorg-video-sisusb            1:0.9.1-1                      X.Org X server -- SiS USB display driver
ii  xserver-xorg-video-tdfx              1:1.4.1-1                      X.Org X server -- tdfx display driver
ii  xserver-xorg-video-tga               1:1.2.0-1                      X.Org X server -- TGA display driver
ii  xserver-xorg-video-trident           1:1.3.1-1                      X.Org X server -- Trident display driver
ii  xserver-xorg-video-tseng             1:1.2.1-1                      X.Org X server -- Tseng display driver
ii  xserver-xorg-video-v4l               0.2.0-3                        X.Org X server -- Video 4 Linux display driv
ii  xserver-xorg-video-vesa              1:2.2.1-1                      X.Org X server -- VESA display driver
ii  xserver-xorg-video-vmware            1:10.16.7-1                    X.Org X server -- VMware display driver
ii  xserver-xorg-video-voodoo            1:1.2.2-1                      X.Org X server -- Voodoo display driver

--------------------------------------------------

modprobe -l | grep -i drm

kernel/drivers/gpu/drm/drm.ko
kernel/drivers/gpu/drm/i915/i915.ko
kernel/drivers/gpu/drm/r128/r128.ko
kernel/drivers/gpu/drm/mga/mga.ko
kernel/drivers/gpu/drm/i810/i810.ko
kernel/drivers/gpu/drm/tdfx/tdfx.ko
kernel/drivers/gpu/drm/sis/sis.ko
kernel/drivers/gpu/drm/savage/savage.ko
kernel/drivers/gpu/drm/radeon/radeon.ko
kernel/drivers/gpu/drm/via/via.ko
kernel/drivers/gpu/drm/i830/i830.ko

--------------------------------------------------

modprobe -l | grep -i radeon

kernel/drivers/gpu/drm/radeon/radeon.ko
kernel/drivers/video/aty/radeonfb.ko

--------------------------------------------------
glxinfo 2>&1

No protocol specified
Error: unable to open display :0.0

--------------------------------------------------

cat /var/log/Xorg.0.log | grep "Direct rendering enabled"

(II) RADEONHD(0): Direct rendering enabled

--------------------------------------------------
### I didn't put everything for radeon. only those i thought important###
cat /var/log/Xorg.0.log | grep -i radeon

(**) |   |-->Device "Radeon_x1950_Pro[0]"                 
(--) PCI:*(0:1:0:0) 1002:7280:1462:0762 ATI Technologies Inc RV570 [Radeon X1950 Pro] rev 0, Mem @ 0xd0000000/268435456, 0xfbce0000/65536, I/O @ 0x0000c000/256, BIOS @ 0x????????/131072                                                                                                                                                                     
(II) LoadModule: "radeonhd"                                                                                                                                                    
(II) Loading /usr/lib/xorg/modules/drivers//radeonhd_drv.so                                                                                                                    
(II) Module radeonhd: vendor="AMD GPG"                                                                                                                                         

[...]

(II) RADEONHD(0): Unknown card detected: 0x7280:0x1462:0x0762.                                                                                                                 
        please contact radeonhd@opensuse.org to help rectify this.                                                                                                             
(--) RADEONHD(0): Detected an RV570 on an unidentified card                                                                                                                    
(II) RADEONHD(0): Mapped IO @ 0xfbce0000 to 0xb7b04000 (size 0x00010000)                                                                                                       
(II) RADEONHD(0): PCIE Card Detected                                                                                                                                           

[...]
--------------------------------------------------

cat /etc/X11/xorg.conf

Section "ServerLayout"
	Identifier     "Default Layout"
	Screen      0  "Samsung-Screen[0]" 0 0
	InputDevice    "Generic Keyboard"
	InputDevice    "Configured Mouse"
#	Option "AIGLX" "on" #->Enables Xorg's AIGLX rendering technic
EndSection

[...]

Section "Module"
	Load  "dbe"
	Load  "i2c"
	Load  "bitmap"
	Load  "ddc"
	Load  "dri"
	Load  "extmod"
	Load  "freetype"
	Load  "glx"
	Load  "int10"
	Load  "vbe"
EndSection

#*************************************************
#                   Monitor(s)                   *
#*************************************************
### MAIN MONITOR ###
Section "Monitor"
        Identifier   "Samsung-Monitor[0]"
        Option      "VendorName" "ATI Proprietary Driver"
        Option      "ModelName" "Generic Autodetecting Monitor"
        Option      "DPMS" "true"
EndSection

### MONITOR 2 ###
#Section "Monitor"
#        Identifier   "NFREN"
#        Option      "DPMS"
#EndSection

#*************************************************
#               Device Sections                  *
#*************************************************

### MAIN GC #
Section "Device"
        Identifier  "Radeon_x1950_Pro[0]"
#	Driver      "vesa"
        Driver      "radeonhd"
        Option      "XAANoOffscreenPixmaps" "true"
#       Option "HPD" "off"
#	BusID       "PCI:1:0:1"
#	BusID       "PCI:1:0:0"
EndSection

#*************************************************
#                   Screen(s)                    *
#*************************************************

Section "Screen"
        Identifier "Samsung-Screen[0]"
        Device     "Radeon_x1950_Pro[0]"
        Monitor    "Samsung-Monitor[0]"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection

Section "DRI"
        Mode         0666
EndSection

Section "Extensions"
        Option  "Composite" "Enable"
EndSection
Thanks for help. And please pardon me for my english. I try to do my best.

Last edited by matal0; 09-01-2009 at 09:45 AM. Reason: I have found my error...
 
Old 09-02-2009, 09:42 AM   #2
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,232
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
Thanks for posting that you solved the issue, but it would be nice if you posted HOW you solved it. that way someone else may be able to benefit from your success..


Thanks !!
 
Old 09-02-2009, 09:51 AM   #3
the trooper
Senior Member
 
Registered: Jun 2006
Location: England
Distribution: Debian Testing/Unstable Amd64
Posts: 1,476

Rep: Reputation: Disabled
Erm...

Quote:
Please don't laugh...

I run glxinfo as root (instead of running it as a user) so that's why i get the message 'unable to open display'.... :/
Sorry...
Everything is ok !
I think op already has.........
 
Old 09-02-2009, 06:39 PM   #4
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,232
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
Gah I guess I missed it at the top of the post... :/
 
Old 09-04-2009, 08:45 PM   #5
milomak
Member
 
Registered: May 2009
Posts: 91

Rep: Reputation: 17
interestingly, there was a xserver where there was an ability to run x programs as root.
 
  


Reply

Tags
display, dri, glxinfo, radeonhd, xorg


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
glxinfo/glxgears can't open display jrtayloriv Linux - Newbie 2 08-06-2009 01:43 PM
Radeon 2600 & RadeonHD driver & two monitors i92guboj Linux - Hardware 2 03-06-2009 03:28 AM
UniChrome XORG 40072d display driver ahaslam Linux - Hardware 1 01-05-2008 06:36 PM
beryl or glxinfo kills the display... LarryDoliver Fedora 1 01-26-2007 08:54 AM
Direct rendering enabled in Xorg log, disabled in glxinfo alexbaretta Linux - Software 1 06-23-2006 12:04 PM


All times are GMT -5. The time now is 12:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration