Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Debian This forum is for the discussion of Debian Linux.


  Search this Thread
Old 10-22-2009, 10:50 AM   #1
Registered: May 2006
Location: Chisinau, Moldova
Distribution: Gentoo, Debian sid
Posts: 151

Rep: Reputation: 29
xorg.conf configuration bug

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
    Option         "XkbModel" "pc105"
    Option         "XkbLayout" "us,ro(academic),ru"
    Option         "XkbOptions" "grp:caps_toggle"
Help me please to solve a bug with my keyboard layouts. The idea is that when I press caps lock for the first time, it switches the language to Romanian. But when I press it for the second time, it doesn't switch to Russian, but instead it works as caps lock. On Google I couldn't find any ways to solve this thing, the single thing I could find are such kind of tutorials, but they didn't really help a thing:
In the beginning of the thread, I have included my xorg.conf. Thank you for your help

Last edited by dracuss; 10-22-2009 at 12:51 PM.
Old 10-22-2009, 01:08 PM   #2
Senior Member
Registered: May 2004
Location: Leipzig/Germany
Distribution: Arch
Posts: 1,687

Rep: Reputation: 54
Not that I really know...but:
I have never seen a valid layout code like "ro(academic)".
"ro" and "ro_microsoft" are the only ones I can spot right now.

Maybe you could switch "ro" and "ru" to see if you can toggle to the third.

no more ideas - no more experience!

Old 10-23-2009, 05:00 AM   #3
Registered: May 2006
Location: Chisinau, Moldova
Distribution: Gentoo, Debian sid
Posts: 151

Original Poster
Rep: Reputation: 29
jomen, thanks!
I changed the layout with ro(winkeys), and it worked. I thought initially that it's a bug with the russian layout, because it couldn't switch to russian. Well, anyway, problem solved


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
xorg.conf configuration questions don_wombat_73 Linux - Newbie 2 01-30-2009 07:59 AM
Need help with xorg.conf and Synaptic configuration greengrocer Linux - Newbie 2 10-25-2008 06:08 AM
nvidia driver configuration not possible: my xorg.conf riccisit Linux - Hardware 5 01-22-2008 05:05 PM
dexconf:error: cannot generate configuration for generating xorg.conf deepclutch Debian 7 11-04-2007 05:13 AM
Sid Users - Beware of Xorg 7.3 (xserver-xorg-input-evdev) bug rickh Debian 4 10-24-2007 03:30 AM

All times are GMT -5. The time now is 07:29 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration