LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 07-20-2004, 02:00 PM   #1
mtb
Member
 
Registered: Nov 2002
Location: Italy
Distribution: Linux Mint 14
Posts: 273

Rep: Reputation: 30
xfree86 upgraded: problems


Hello,

i have recently upgraded xfree as follows, from version 4.3ds4 iirc ( i don't have it anymore ).

xfree86-common, xlibmesa-gl, xlibmesa-glu, xlibs-pic, xserver-xfree86, xlibs-data, xlibs-dev, xlibs-pic , xlibs-static-dev, xlibs-static-pic to version 4.3.0.dfsg.1-6 ( and before to 1-5 ).

The problem ( also present with 1-5 ) is that now direct rendering doesn't work anymore .

Some more info:

1) when i launch X with startx i obtain errors:

Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_clip.o": No symbols found
Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_norm.o": No symbols found
Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_xform.o": No symbols found
Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_vertex.o": No symbols found
Skipping "/usr/X11R6/lib/modules/fonts/libspeedo.a:spencode.o": No symbols found

2) the XF86Config-4 is always the same, some parts:

Section "Module"
Load "ddc" # ddc probing of monitor
Load "GLcore"
Load "dbe"
Load "dri"
Load "extmod"
Load "glx"
Load "bitmap" # bitmap-fonts
Load "speedo"
Load "type1"
Load "freetype"
Load "record"
EndSection

Section "Device"
Driver "radeon"
Option "AGPMode" "4"
Option "AGPFastWrite" "on"
Option "EnablePageFlip" "on" # Faster
EndSection

Section "DRI"
Mode 0666
EndSection

3) Glxinfo reports:

name of display: :0.0
display: :0 screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
client glx vendor string: SGI
client glx version string: 1.2
client glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
GLX extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.3 Mesa 4.0.4
OpenGL extensions:
GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_border_clamp,
GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,
GL_ARB_transpose_matrix, GL_EXT_abgr, GL_EXT_blend_color,
GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_texture_env_add,
GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
GL_EXT_texture_lod_bias
glu version: 1.3
glu extensions:
GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
0x23 16 tc 0 16 0 r . . 5 6 5 0 0 16 0 0 0 0 0 0 0 None
0x24 16 tc 0 16 0 r . . 5 6 5 0 0 16 8 0 0 0 0 0 0 None
0x25 16 tc 0 16 0 r . . 5 6 5 0 0 16 0 16 16 16 0 0 0 Slow
0x26 16 tc 0 16 0 r . . 5 6 5 0 0 16 8 16 16 16 0 0 0 Slow
0x27 16 tc 0 16 0 r y . 5 6 5 0 0 16 0 0 0 0 0 0 0 None
0x28 16 tc 0 16 0 r y . 5 6 5 0 0 16 8 0 0 0 0 0 0 None
0x29 16 tc 0 16 0 r y . 5 6 5 0 0 16 0 16 16 16 0 0 0 Slow
0x2a 16 tc 0 16 0 r y . 5 6 5 0 0 16 8 16 16 16 0 0 0 Slow
0x2b 16 dc 0 16 0 r . . 5 6 5 0 0 16 0 0 0 0 0 0 0 None
0x2c 16 dc 0 16 0 r . . 5 6 5 0 0 16 8 0 0 0 0 0 0 None
0x2d 16 dc 0 16 0 r . . 5 6 5 0 0 16 0 16 16 16 0 0 0 Slow
0x2e 16 dc 0 16 0 r . . 5 6 5 0 0 16 8 16 16 16 0 0 0 Slow
0x2f 16 dc 0 16 0 r y . 5 6 5 0 0 16 0 0 0 0 0 0 0 None
0x30 16 dc 0 16 0 r y . 5 6 5 0 0 16 8 0 0 0 0 0 0 None
0x31 16 dc 0 16 0 r y . 5 6 5 0 0 16 0 16 16 16 0 0 0 Slow
0x32 16 dc 0 16 0 r y . 5 6 5 0 0 16 8 16 16 16 0 0 0 Slow

-----------------------------------

The second problem is that former i used to use the key between ctrl and alt to switch desktop when pressed together with arrows, now it doesn't work anymore and i have to use instead of it the combination ctrl - alt, and i don't know how to restore that imo useful behaviour.

Thanks in advance.
 
Old 07-20-2004, 02:55 PM   #2
macondo
Senior Member
 
Registered: Jul 2003
Posts: 1,016

Rep: Reputation: 49
what version of debian?
what kernel version?
what wm are you using?

what happens when you do a 'dpkg-reconfigure xserver-xfree86',
and reboot?

Last edited by macondo; 07-20-2004 at 03:01 PM.
 
Old 07-21-2004, 04:02 AM   #3
mtb
Member
 
Registered: Nov 2002
Location: Italy
Distribution: Linux Mint 14
Posts: 273

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by macondo
what version of debian?
what kernel version?
what wm are you using?

what happens when you do a 'dpkg-reconfigure xserver-xfree86',
and reboot?
Debian ( mostly ) unstable.

Kernel 2.4.22-xfs ( tried also with 2.6.6 )

Dpkg-reconfigure: i have tried it, it recreates a config ( worser than mine ) but always without dri enabled.

Wm: every wm i have tried so far ( window maker, icewm, openbox ).
 
Old 07-21-2004, 07:20 AM   #4
macondo
Senior Member
 
Registered: Jul 2003
Posts: 1,016

Rep: Reputation: 49
"Debian ( mostly ) unstable."

you haven't answered the question. Are you on Sid, or do you have severral different sources from DIFFERENT versions (woody, sarge, sid)

What installer did you use? CD1, Beta installer Sarge, are you using Knoppix?

"Kernel 2.4.22-xfs ( tried also with 2.6.6 )"

so you are using kernel 2.4.22 right now?


"Dpkg-reconfigure: i have tried it, it recreates a config ( worser than mine ) but always without dri enabled."

what do you mean worse than yours? dpkg-reconfigure creates configurations according to whaterver information YOU PROVIDE IT WITH.

"Wm: every wm i have tried so far ( window maker, icewm, openbox )."

That is not what i'm asking you. What wm are you using NOW?

Different wms have different key combinations, and some can be arranged with keybindings you create.

Last edited by macondo; 07-21-2004 at 07:22 AM.
 
Old 07-21-2004, 08:12 AM   #5
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
Quote:
The second problem is that former i used to use the key between ctrl and alt to switch desktop when pressed together with arrows, now it doesn't work anymore and i have to use instead of it the combination ctrl - alt, and i don't know how to restore that imo useful behaviour.
By the "key between ctrl and alt" you probably mean the key with the Windows flag. In wmaker you can try defining the desktop switch shortcut keys in WPrefs.

If that doesn't work, you need to check that you've configured "XkbRules", "XkbModel", and "XkbLayout" in /etc/X11/XF86Config-4 to support your keyboard. Running "dpkg-reconfigure xserver-xfree86" is the best way to change keyboard settings (and X settings in general) so that they stay the same when you upgrade the X server.

You can try running "dpkg-reconfigure debconf" and setting the priority level to "low" before running "dpkg-reconfigure xserver-xfree86" so that you get to configure all the possible options.

Last edited by Dead Parrot; 07-21-2004 at 08:20 AM.
 
Old 07-22-2004, 02:54 PM   #6
mtb
Member
 
Registered: Nov 2002
Location: Italy
Distribution: Linux Mint 14
Posts: 273

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by macondo
"Debian ( mostly ) unstable."

you haven't answered the question. Are you on Sid, or do you have severral different sources from DIFFERENT versions (woody, sarge, sid)

What installer did you use? CD1, Beta installer Sarge, are you using Knoppix?

i installed knopils 0.4 ( the italian version of knoppix, similar to knoppix 3.2 ) then upgraded in the last months a discrete number of packages using apt selecting unstable debian packages.

I did this because 3.0 was too old, and upgrading it to unstable would have costed me a lot of money ( 56kb ).

Quote:

"Kernel 2.4.22-xfs ( tried also with 2.6.6 )"

so you are using kernel 2.4.22 right now?
Yes.

Quote:
"Dpkg-reconfigure: i have tried it, it recreates a config ( worser than mine ) but always without dri enabled."

what do you mean worse than yours? dpkg-reconfigure creates configurations according to whaterver information YOU PROVIDE IT WITH.
here i have to specify a thing: i tried it with the previous xserver-xfree86 packages ( 4.3.0.dfsg.1.5 ) and it created a config that worked but without dri ( also it didn't let me select radeon in the list of modules, but only ati ( the same thing happens with xf86cfg ) ).

Worser than mine: in fact some extended video modes are not automatically usable, even if they are dcc probed by monitor.

I have just tried with 4.3.0.dfsg.1.6 and it doesn't write a XF86Config-4 . In fact i reselect all the options ( they are cached ), but it doesn't write the config in /etc/X11/XF86Config-4 .

Quote:
"Wm: every wm i have tried so far ( window maker, icewm, openbox )."

That is not what i'm asking you. What wm are you using NOW?

Different wms have different key combinations, and some can be arranged with keybindings you create.
Now i'm using wmaker , but the fact is that before upgrading i used in every wm the windows key in order to switch desktop, now i have to use, in every wm, ctrl + alt.

Last edited by mtb; 07-22-2004 at 02:58 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
XFree86 Upgraded hanxuerui Linux - Newbie 4 12-09-2003 04:13 PM
Problems with upgraded XFree86 packages pmehta1613 Linux - Software 1 11-18-2003 08:51 AM
upgraded to xfree86 4.3 and lost my GUI!! kinghari Linux - Newbie 5 10-25-2003 10:35 AM
Upgraded XFree86 and now no gnome etc plisken Linux - General 5 05-23-2003 12:48 PM
Upgraded kernel and XFree86 emanners Linux - General 1 09-04-2001 02:33 PM


All times are GMT -5. The time now is 01:05 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration