LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices



Reply
 
Search this Thread
Old 05-03-2004, 12:49 AM   #1
velan
Member
 
Registered: Apr 2004
Posts: 89

Rep: Reputation: 15
XFree86 Log. Help me


I have Woody 3.0r2 and XFree86 4.4.0 with kernel 2.4.bf. I have a Samsung 753s(17" inch) monitor and Intel 845GVSR motherboard with 2.8 Ghz Processor. Iam using RH 9 and Windows XP / ME and 2000 under 1024 x 768 mode. But in debian I set the default mode to be 1024 x 768, but Iam getting only 640 x 480 mode. When I opened the log file, it says "(I810) 1024 x 768, no mode of this name." what does this mean? Help me out.
 
Old 05-03-2004, 01:51 AM   #2
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
Here are three methods to configure X, starting from the easiest:

Method 1.
# aptitude --with-recommends install discover mdetect read-edid
# dpkg-reconfigure xserver-xfree86

Method 2.
a) download Knoppix ISO and burn it to cd
b) boot computer to Knoppix
c) mount Debian partition and copy /etc/X11/XF86Config-4 from Knoppix to Debian (or copy it to floppy and move it to Debian)

Method 3.
a) # XFree86 -configure
b) edit the XF86Config file that this command produced
c) rename the new XF86Config file XF86Config-4 and move it to /etc/X11/

Hope one of these methods works for you.
 
Old 05-03-2004, 03:53 AM   #3
velan
Member
 
Registered: Apr 2004
Posts: 89

Original Poster
Rep: Reputation: 15
No change

I did all the three methods, which u specified but no change. . No one in helping me here.
 
Old 05-03-2004, 04:26 AM   #4
mrcheeks
Senior Member
 
Registered: Mar 2004
Location: far enough
Distribution: OS X 10.6.7
Posts: 1,690

Rep: Reputation: 50
just edit the XFree file and compile the kernel with driver for your video card,agp,etc...
as i suggest in you previous post
no help, no guidance.... , you have google, debian online manuals,..., you have the man commands too...

go for fedora or something easier, rtfm'ing would help you a lot
 
Old 05-03-2004, 04:41 AM   #5
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
What, did you also get 640x480 from Knoppix, so method 2 didn't work either? Wow, that doesn't usually happen.

Did you set the Horizontal and Vertical refresh rates of your monitor correctly? If you don't have your monitor manual, you can often check this information on the manufacturer's website. This problem can often be caused by incorrect scan ranges being set.

Please post the contents of /etc/X11/XF86Config (if it exists) or /etc/X11/XF86Config-4 here.
 
Old 05-03-2004, 05:19 AM   #6
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
There are 2 threads running on velan's problem. See other thread here .
 
Old 05-03-2004, 07:36 AM   #7
velan
Member
 
Registered: Apr 2004
Posts: 89

Original Poster
Rep: Reputation: 15
Knoppix is fine.

No, in Knoppix Iam getting 1024 x 768 mode. But not in Debian. I copied the XFConfig-4 and XFconfig file from Knoppix to Debian /etc/X11/ directory, but still the same problem.
 
Old 05-03-2004, 02:53 PM   #8
mrcheeks
Senior Member
 
Registered: Mar 2004
Location: far enough
Distribution: OS X 10.6.7
Posts: 1,690

Rep: Reputation: 50
I use i810 driver too, included in a custom kernel 2.6.5 with agp support and drm support for i810.

from my xfree config file
...............
Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "NoAccel" # [<bool>]
#Option "SWcursor" # [<bool>]
#Option "ColorKey" # <i>
#Option "CacheLines" # <i>
#Option "Dac6Bit" # [<bool>]
#Option "DRI" # [<bool>]
#Option "NoDDC" # [<bool>]
#Option "ShowCache" # [<bool>]
#Option "XvMCSurfaces" # <i>
Identifier "Card0"
Driver "i810"
VendorName "Intel Corp."
BoardName "82810 CGC [Chipset Graphics Controller]"
BusID "PCI:0:1:0"
EndSection
...............
DefaultDepth 16
SubSection "Display"
Depth 1
EndSubSection
SubSection "Display"
Depth 4
EndSubSection
SubSection "Display"
Depth 8
EndSubSection
SubSection "Display"
Depth 15
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 24
EndSubSection
EndSection

Last edited by mrcheeks; 05-04-2004 at 03:42 PM.
 
Old 05-04-2004, 01:56 AM   #9
velan
Member
 
Registered: Apr 2004
Posts: 89

Original Poster
Rep: Reputation: 15
how to add AGB support?

how to add the AGP support for my i810 driver. I copied the XFConfg86-4 file from RedHat directory and tried kdm, xdm, gdm. But same 600x480 mode. When I opened /var/log/XF86config.log, it says "1024x768 no mode of this name." what to do? How can I get 1024x768 mode. I tried all the methods, like, kernel 2.4.20, kernel 2.6.5, XFree86 4.1.0 and XFree86 4.3.0 i810 driver, Knoppix config file, RedHat config file. But same problem. How to configure XServer to work in 1024x 768 mode.
 
Old 05-04-2004, 10:22 AM   #10
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
Changing your Display Manager from KDM to XDM is not going to have any effect, because all of the DMs are going to read the same XFree86 configuration file to start X. Changing versions of XFree is not going to help if the problem is in the configuration file and they're all using the same basic settings, or if the problem is a kernel configuration issue. Changing the kernel is not going to help if you haven't reconfigured it to include some needed support, or if the kernel is not the problem (but the monitor is).

The problem may be located in 4 areas:

1. The kernel. If, as you say, you don't have AGP support enabled (which seems incredibly unlikely), or some other support that is necessary (such as specific support for your motherboard, or the i810 drivers themselves), then you would have to recompile the kernel to add that support.

2. The XFree86 configuration file. It's very well and good to have copied the one from another distro, but if you haven't read the file, I can see at least one way that it would be of no help: if the other distro which worked had VESA modes enabled in the kernel, but your current distro did not, and the working XF86Config file was using the "vesa" driver rather than the "i810" driver. But until you post the contents of your XFree86 configuration files, and your kernel's .config file, we'll never know. The modeline for 1024x768 might also be wrong, which would also explain why the driver can't use it.

3. The monitor. XFree86 uses the modelines in conjunction with the monitor specs (the horizontal and vertical refresh rates specified in the configuration file) to determine what resolutions can be displayed, and then takes the first one that works. So it's possible that your monitor is specified in the configuration file in such a way that XFree 86 believes that it is incapable of displaying 1024x768, therefore it skips that mode and goes to the first one it believes will work, which apparently is 640x480. This happens to me all the time as the default specs for my monitor do not recommend using 1280x1024 (although the monitor can in fact do this resolution), and so unless I actually specify the horizontal and vertical rates of my monitor, I am limited to 1024x768. So I would also suggest comparing the monitor specifications in the XFree86 configuration file with the specifications listed in your monitor manual or on the monitor manufacturers website, and if they are not the same, adjusting your configuration file.

4. The driver. Are you using the driver modules in your kernel, or some other drivers? The fact that XFree86 keeps saying that the driver doesn't accept the mode seems to indicate that something is up with the driver itself. Never having had an i810, I know nothing about them, but I find it odd that the regular kernel driver would not accept a particular mode which seems otherwise quite normal (surely the i810 does 1024x768 under normal circumstances). So I'm thinking that perhaps this is not a regular kernel driver in some way. Is that the case?

Hope this helps.
 
Old 05-04-2004, 03:38 PM   #11
mrcheeks
Senior Member
 
Registered: Mar 2004
Location: far enough
Distribution: OS X 10.6.7
Posts: 1,690

Rep: Reputation: 50
to add agp support you have to compile the kernel (graphics,character devices) : make menuconfig. It doesn't matter if it is a kernel 2.4 or 2.6 to make it work.
you also need to apt-get xlibmesa-dri. For the resolution look at my previous post and use vim/emacs/nano or the editor of your choice and replace my line PCI:ETC... with the result of lspci -v|less for you. If you don't want to edit it : dpkg-reconfigure xserver-xfree86
The line DefaultDepth is primordial.

Last edited by mrcheeks; 05-04-2004 at 03:41 PM.
 
Old 05-08-2004, 03:29 AM   #12
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
velan - I don't know whether you have managed to solve your problem yet but I came across the same problem with someone else and it appears to relate to specifying the memory size under the video device section in XF86Config-4 which is covered in the end of this thread.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
/var/log/XFree86.0.log gone!!! OC_eobard Linux - Newbie 13 09-07-2004 12:16 PM
IGP320 Xfree86 log and GLXinfo adamis Linux - Laptop and Netbook 4 06-17-2004 09:13 AM
XFree86.0.log question shanenin Linux - Software 6 04-14-2004 01:49 PM
XFree86.0.log vladilinsky Linux - Newbie 5 03-26-2004 01:52 PM
xstart: Cannot move old "/var/log/XFree86.0.log.old" linuxgamer09483 Linux - Newbie 2 02-18-2004 08:52 PM


All times are GMT -5. The time now is 06:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration