LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 06-01-2005, 02:58 PM   #1
Ipolit
Member
 
Registered: Nov 2003
Location: Bulgaria
Distribution: Vector Linux, Morphix
Posts: 293

Rep: Reputation: 31
xfce to gnome


How can I choose GNOME to strart when I type startx
My default environment is xfce, I copied /etc/X11/xinitrc in my home dir and named it to .xinitrc and changed startxfce4 to gnome-session, but again xfce. I installed gdm, but I don't want to use it.
 
Old 06-01-2005, 03:07 PM   #2
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
$ rm .xinitrc
$ echo "exec gnome-session" > .xinitrc
$ startx
 
Old 06-01-2005, 03:25 PM   #3
Ipolit
Member
 
Registered: Nov 2003
Location: Bulgaria
Distribution: Vector Linux, Morphix
Posts: 293

Original Poster
Rep: Reputation: 31
thanks
It works, but could you tell me which is exactly the file which shows to run xfce before me to create this .xinitrc
 
Old 06-01-2005, 03:47 PM   #4
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
I'm not quite sure I understood your question correctly but if you ask how to tell "startx" to choose between gnome and xfce when you want to change from one to the other, then you can do (as normal user) "nano .xinitrc" and make it look like this (and then exit nano saving changes: Ctrl-x, y, Enter):
Code:
#exec startxfce4
exec gnome-session
This will tell "startx" to start gnome. When you want to start xfce, do "nano .xinitrc" again and make it look like this:
Code:
exec startxfce4
#exec gnome-session
 
Old 06-01-2005, 03:55 PM   #5
Ipolit
Member
 
Registered: Nov 2003
Location: Bulgaria
Distribution: Vector Linux, Morphix
Posts: 293

Original Poster
Rep: Reputation: 31
this way I'm loosing my locale settings and some cyrillic fonts. I can't type cyrillic letters in terminal windows.
with the xfce it works perfect for me, so I just want to change startxfce4 to gnome-session and to keep all other stuff.
with gdm happens the same thing.
All these things are happening because I'm using non-debian package, but it's the easyest way to setup bulgarian environment
 
Old 06-01-2005, 04:08 PM   #6
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
Hmm... I don't know what non-debian package you're talking about. Why don't you use the usual Debian way to set locales: "dpkg-reconfigure console-data" and "dpkg-reconfigure locales"?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE and Gnome applications in XFCE Fritz_Monroe Linux - Newbie 1 07-27-2005 01:26 PM
Gnome keeps stealing my desktop from xfce + icewm eduardo451 Ubuntu 5 03-28-2005 12:38 PM
Starting Gnome, XFCE, etc... dustin_wielenga Slackware 10 02-06-2005 01:25 PM
xfce desktop is acting like gnome???!!! triet Linux - Software 6 12-06-2004 10:36 AM
using xfce window decoration is gnome xslf Linux - General 0 11-04-2003 02:24 AM


All times are GMT -5. The time now is 06:29 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration