LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 04-01-2005, 07:21 AM   #1
mehlkelm
Member
 
Registered: Apr 2003
Location: Basel, Switzerland
Distribution: Ubuntu, OS X
Posts: 77

Rep: Reputation: 15
xdm, xfce4 & xscreensaver


Hello,

I have made a small debian setup on an older machine, without GNOME/KDE, just with xdm and xfce4.2

I dont know where to put the command that starts xscreensaver on user login. I have no ~/.Xsession or ~/.xinitrc? (But xdm knows that it sould start xfce somehow. how?)
When I go to the xfce4.2 settings manager and to screensaver, it says, that "The XScreenSaver daemon doesn't seem to be running on display :0.0. Launch it now?"

Thats the way I start the xscreensaver daemon at the moment. :-)

I am confused by all various places of all the possible X startup scripts..

Any help appreciated

Stefan
 
Old 04-01-2005, 08:29 AM   #2
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 47
usually, xfce4.2 should have installed ~/.config/xfce4/xinitrc which is the startup script for xfce4. If it's not there, the original should be in the directory PREFIX/etc/xdg/xfce4/ where PREFIX is whereever xfce4 is installed. This script should start the screensaver.

Also, you ca create a directory
~/Desktop/Autostart
and place scripts in here which will be run during the startup of xfce. It would be a possibility to start xscreensaver (don't forget the make the script executable).
 
Old 04-01-2005, 12:41 PM   #3
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
If you continue to have problems with autostarting xscreensaver, you can quite easily create the .xsession file into your home directory. It should contain something like this:
Code:
#!/bin/sh
xscreensaver -no-splash &
exec startxfce4
XDM will read this .xsession file and it's also customary to make it executable with "chmod +x ~/.xsession".
Quote:
xdm knows that it sould start xfce somehow. how?
The Debian configuration system, debconf, keeps track of installed WM's/DE's and the one installed last will become the default. For instance, if you now install fluxbox, xdm will start fluxbox instead of xfce -- unless you "su" to root and run "update-alternatives --config x-window-manager" to change the debconf default. But this is a difficult command to remember, so it might be easier to create ~/.xsession and define the default window manager there because the settings in ~/.xsession will override the debconf defaults.
 
Old 04-01-2005, 02:02 PM   #4
mehlkelm
Member
 
Registered: Apr 2003
Location: Basel, Switzerland
Distribution: Ubuntu, OS X
Posts: 77

Original Poster
Rep: Reputation: 15
Thanks for the answers.

I have no xinitrc in .config/xfce4/ but I do have one in /etc/xdg/xfce4/. But in the latter is already this:

Code:
# Launch xscreensaver (if available), but only as non-root user
test $UID -gt 0 -a -z "$VNCSESSION" && xscreensaver -no-splash &
It seems it doesnt get executed.

By the way I installed the xfce4.2 packages from www.os-works.com.

Stef

edit: I just tried to find out what VNCSESSION is. "echo $VNCSESSION" as user prints nothing (I dont understand what "test" tests in the above line).

Last edited by mehlkelm; 04-01-2005 at 02:05 PM.
 
Old 04-01-2005, 03:25 PM   #5
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 47
can you launch the xscreensaver manually once xfce is up? If you can, you should try the autostart option by placing a little script in
~/Desktop/Autostart/
the script should simply start the xcreensaver and nothing more.
 
Old 04-01-2005, 04:03 PM   #6
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
Check out this post for a simply script to that you can use to manually start xscreensaver.
http://www.linuxquestions.org/questi...69#post1520669

Brian1
" Google the Linux way @ http://www.google.com/linux "
 
Old 04-01-2005, 04:38 PM   #7
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
In general, everything that you specifically define in your home directory overrides any system-wide settings. I'd still insist that creating a ~/.xsession file (like described in my earlier post) would be the easiest solution to your problem.
 
Old 04-01-2005, 05:59 PM   #8
mehlkelm
Member
 
Registered: Apr 2003
Location: Basel, Switzerland
Distribution: Ubuntu, OS X
Posts: 77

Original Poster
Rep: Reputation: 15
Thumbs up

Yes of course, sorry. Your solutions all work, thanks.
I just asked myself why it didnt work with the /etc/xdg/xfce4/xinitrc script in the first place.

Stefan
 
Old 04-01-2005, 06:30 PM   #9
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
I don't have xfce currently installed on my system but I'd expect that if you study the system-wide startup scripts for xfce, you'll find that they first check out if there's any local startup scripts under the user's home directory (like ~/.xinitrc or ~/.xsession).


The point I'm trying to make is: Any system-wide startup scripts usually check first if there's some local scripts under the user's home directory, and these local scripts usually override any system-wide settings.

Last edited by Dead Parrot; 04-02-2005 at 11:07 AM.
 
Old 03-27-2009, 03:19 PM   #10
jis
LQ Newbie
 
Registered: Jan 2009
Distribution: Xubuntu
Posts: 13

Rep: Reputation: 0
Quote:
Originally Posted by mehlkelm View Post
I just asked myself why it didnt work with the /etc/xdg/xfce4/xinitrc script in the first place.

Stefan
Maybe it didn't work because /etc/xdg/xfce4/xinitrc was not executed at all. If you launch Xfce session by running startxfce4 script, it will execute some xinitrc. It may be that Xfce was not started that way, because you did not choose Xfce session explicitly in display manager.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Add xfce4 to xdm aeruzcar Linux - General 3 02-17-2005 03:39 PM
How do I start programs on x startup? xscreensaver & gkrellm darkleaf Linux - Software 3 10-08-2004 04:15 PM
xscreensaver installed, but no xscreensaver-demo command? dalesan Linux - Software 7 09-01-2004 01:06 PM
Xscreensaver & Glmatrix randrake Linux - Software 5 05-29-2004 01:35 PM
XDM opens XDM after login jpbarto Linux - Software 1 01-26-2004 10:23 PM


All times are GMT -5. The time now is 12:28 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration