LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 07-14-2004, 04:40 AM   #1
chrsitophermann
LQ Newbie
 
Registered: Jul 2004
Posts: 7

Rep: Reputation: 0
Question X11 / UTF-8 locale seems missing 'fr_FR.UTF-8'


Hi,

In my /usr/XF86R6/lib/X11/locales directory I don't have fr_FR.UTF-8, nor do I have it in my alias file. This is however my C locale. I'm having a hell of a headache because I can't configure my X11 locale to fr_FR.UTF8, but don't know what to do.

Should I generate or download the locale from someplace ? Should I re-use the C locale (is that possible ?) ? Once I get a fr_FR.UTF-8 locale, how do I configure it by default in X11 ? Or am I missing something ?

Please help

Chris
 
Old 07-14-2004, 05:47 AM   #2
mrcheeks
Senior Member
 
Registered: Mar 2004
Location: far enough
Distribution: OS X 10.6.7
Posts: 1,690

Rep: Reputation: 50
#apt-get install locales
##dpkg-reconfigure locales
#LANG user environment variable(fr_FR.UTF8)
 
Old 07-15-2004, 02:14 AM   #3
chrsitophermann
LQ Newbie
 
Registered: Jul 2004
Posts: 7

Original Poster
Rep: Reputation: 0
The above post reffers to configuring the C locales, which seem straightforward.
The problem occurs when the X11 locale does not exist.
The prodcedure above only works for me on console logins, but not on my X11/KDE configuration.
I believe it to be a X11 question because the configuration problem concerns
/usr/XF86R6/lib/X11/locales
If I'm missing something, please inform me.

Chris
 
Old 07-15-2004, 02:22 AM   #4
chrsitophermann
LQ Newbie
 
Registered: Jul 2004
Posts: 7

Original Poster
Rep: Reputation: 0
Question X11 fr_FR.UTF-8 locale unavailable

Hi,

I use KDE on X11. Some applications support UTF-8, others seem to rely on the system 'locale'. My language environnement is French and Latin-15 (iso-8...-15).

The problem is that the X11 environnement does not have fr_FR.UTF-8 as an available option. There is pl_PL.UTF-8 and english I think. I'm talking about my /usr/XF86R6/lib/X11/locales directory and /usr/XF86R6/lib/X11/locales/aliases... file.

Does X11 use C locales (I don't think so for some reason) ? How can I get fr_FR.UTF-8 support for X11 and KDE and, emacs which relies on the previous two ?

Should I generate or download the locale from someplace ? Should I re-use the C locale (is that possible ?) ? Once I get a fr_FR.UTF-8 locale, how do I configure it by default in X11 ? Or am I missing something ?

Please help

Chris

P.S. I posted this to the debian list, but here may be a better location. It doesn't seem to be Debian-specific.
Otherwise, th Linux general forum may be appropriate.
 
Old 07-15-2004, 03:31 AM   #5
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
Perhaps "apt-get install kde-i18n-fr" would fix your problem?
 
Old 07-15-2004, 04:36 AM   #6
chrsitophermann
LQ Newbie
 
Registered: Jul 2004
Posts: 7

Original Poster
Rep: Reputation: 0
apt-get install kde-i18n-fr
is already installed.
I think it may be a wierd X11 configuration problem.

The UTF-8 problems only occur in emacs (stuff downloaded with zopeedit) and in mozilla (email sent in UTF-8). They may be partially encoded in UTF-8 ?

The problems occur in blackbox as well as kde.

Please continue thinking.

Here is another interesting symptom. When I use konsole and type ls --help, I get this ::
Afficher les informations au sujet des FICHIERS (du répertoire
courant par défaut). Trier les entrées alphabétiquement si aucune
des options -cftuSUX ou --sort n'est utilisée.

Les arguments obligatoires pour les options de formes longues le sont aussi
pour les options de formes courtes.
-a, --all ne pas cacher les entrées débutant par .

I shouldn't have gotton that like that. The é stuff should have been .
Again, Mozilla will be able to read Web pages in UTF 8.

Would anyone know where these problems are coming from ?
 
Old 07-15-2004, 05:01 AM   #7
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
The symptoms you describe make me suspect that there's a bug in the fr_FR.UTF-8 locale. You might want to check if this bug has already been reported ( http://bugs.debian.org/cgi-bin/pkgre...les&archive=no ), and if this is not the case, then you should report the problems you're having so that the bug can be fixed as soon as possible. You should report this possible bug against the "locales" package.

http://www.debian.org/Bugs/


Edit:

An additional thought came to me -- since you tell that you don't get correct French characters in konsole (or in xterm under blackbox, I assume?), you might want to do "dpkg-reconfigure console-data" before making a bug report. In your posts you don't mention if you have already (re)configured the console-common or console-data packages.

Last edited by Dead Parrot; 07-15-2004 at 05:33 AM.
 
Old 07-15-2004, 06:12 AM   #8
chrsitophermann
LQ Newbie
 
Registered: Jul 2004
Posts: 7

Original Poster
Rep: Reputation: 0
OK, debian bug posted.
Console reconfigured, but didn't solve the problem.
Can I recompile X11 locales with my gcc ?
 
Old 07-15-2004, 07:06 AM   #9
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
Quote:
Can I recompile X11 locales with my gcc ?
I have no experience on recompiling locales so I cannot really say if it will fix anything. However, there's a Debian specific HOWTO on using UTF-8 coded locales. If you haven't seen this before, you might want to check it out:

http://melkor.dnp.fmph.uniba.sk/~gar...WTO/howto.html
 
Old 07-17-2004, 03:17 AM   #10
chrsitophermann
LQ Newbie
 
Registered: Jul 2004
Posts: 7

Original Poster
Rep: Reputation: 0
The Unicode HOW-TO, the advice about unicode_start and LatArCyrHeb in the /~.bash_profile file, the mule-ucs package together did the trick.

Many thanks.

I do not know, what you want, but read the UNICODE-HOWTO.

and write in your

____ ( '/home/michifr/.bash_profile' ) _______________________________
/
| export LANG=fr_FR.UTF-8
| export LANGUAGE=fr_FR.UTF-8
| export LC_MESSAGES=fr_FR.UTF-8
|
| echo "Starte Unicode..."
| unicode_start
| echo "Lade UNICODE Console Font und Tastaturlayout..."
| consolechars -v --font=LatArCyrHeb-16
| loadkeys -s de-latin1
\______________________________________________________________________

and in your

____ ( '/home/michifr/.bash_logout' ) ________________________________
/
| ########################################################################
| # Do not edit this lines.
| #
| unicode_stop
| loadkeys -s de-latin1
| consolechars -v --font=lat0-16
| #
| # Do not edit the lines above
| ########################################################################
\______________________________________________________________________
 
Old 07-17-2004, 03:19 AM   #11
chrsitophermann
LQ Newbie
 
Registered: Jul 2004
Posts: 7

Original Poster
Rep: Reputation: 0
The Unicode HOW-TO, the advice about unicode_start and LatArCyrHeb in the /~.bash_profile file, the mule-ucs package together did the trick.

Many thanks.

I do not know, what you want, but read the UNICODE-HOWTO.

and write in your

____ ( '/home/michifr/.bash_profile' ) _______________________________
/
| export LANG=fr_FR.UTF-8
| export LANGUAGE=fr_FR.UTF-8
| export LC_MESSAGES=fr_FR.UTF-8
|
| echo "Starte Unicode..."
| unicode_start
| echo "Lade UNICODE Console Font und Tastaturlayout..."
| consolechars -v --font=LatArCyrHeb-16
| loadkeys -s de-latin1
\______________________________________________________________________

and in your

____ ( '/home/michifr/.bash_logout' ) ________________________________
/
| ########################################################################
| # Do not edit this lines.
| #
| unicode_stop
| loadkeys -s de-latin1
| consolechars -v --font=lat0-16
| #
| # Do not edit the lines above
| ########################################################################
\______________________________________________________________________
 
Old 07-17-2004, 02:04 PM   #12
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 64
If you had wanted to use the locales system wide then you should have installed the package localeconf and choose the locale you wanted during the setup. The settings are then saved in the file /etc/environment.

Code:
>$ cat /etc/environment
### BEGIN DEBCONF SECTION FOR localeconf
# Do not edit within this region if you want your changes to be preserved
# by debconf.  Instead, make changes before the "### BEGIN DEBCONF SECTION
# FOR localeconf" line, and/or after the "### END DEBCONF SECTION FOR
# localeconf" line.
LANG=en_CA.UTF-8
LC_COLLATE=C
### END DEBCONF SECTION FOR localeconf
You may also want to install the package localepurge to rid the system of the excess locales and if you want man pages in the languages/locales you do not need. Not only will this save time during upgrades when you have to regenerate locales it will save you the errors that seem to happen in some of the locales that are on the system thus killing off your upgrade. If you install localepurge you will want to check in the file /etc/locale.gen to make sure that only the locales you selected to keep are present in the file or they will be re-generated in spite of the settings you choose during the setup of localepurge.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Disabling UTF winterhunter Linux - Newbie 2 10-18-2005 08:40 AM
locale is en_US.UTF-8, but gnome turns out to chinese envirement donkey301 Debian 1 03-02-2005 10:50 AM
locale utf iso Xris718 Linux - General 0 01-13-2005 09:22 AM
How do I know how a file is encoded? UTF-8, UTF-16, etc.. ?? brynjarh Linux - General 1 12-03-2004 11:11 AM
[Enter] in text documents diffrent on Windows and Linux? UTF-8/UTF-16 problem or? brynjarh Linux - General 1 11-24-2004 05:20 AM


All times are GMT -5. The time now is 01:50 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration