LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   (x)emacs doesn't start (http://www.linuxquestions.org/questions/debian-26/x-emacs-doesnt-start-466229/)

thelonius 07-21-2006 08:33 AM

(x)emacs doesn't start
 
Hello,

with the following message:

Code:

localhost:/home/user# emacs
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

emacs: Cannot connect to X server :0.0

Since the system is freshly installed, I think one of configuration features is missing. Which one ?

Thank you.

raskin 07-21-2006 09:10 AM

Do you have running X at the moment?

thelonius 07-21-2006 09:21 AM

I'm in GNOME when I do it

raskin 07-21-2006 10:06 AM

Just in case: you do it on local machine from a terminal started from gnome?
And $DISPLAY is ":0.0" . Try ":0" , by the way.. And 'xhost +' doesn't help.

thelonius 07-21-2006 10:14 AM

yes, i open terminal in gnome and run emacs or xemacs in it

i will check if i have $DISPLAY variable. after installation what i did was aptitude several packages and none configuration at all.

thank you

Nylex 07-21-2006 10:20 AM

I also have had this problem and it seems "xhost local:" works. Not sure if this is the best solution, though.

raskin 07-21-2006 10:31 AM

Shell variables are case-sensitive..

thelonius 07-21-2006 10:42 AM

Quote:

Originally Posted by raskin
Shell variables are case-sensitive..

i know :) ;) :D

raskin 07-21-2006 12:30 PM

Good. I just remembered a thread where somebody - being asked about $PATH - said that $path is empty.. And, by the way, maybe someone will find the thread without the knowledge about case.


All times are GMT -5. The time now is 03:49 AM.