LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 02-17-2005, 01:26 AM   #1
urzumph
Member
 
Registered: Jan 2004
Location: Australia
Distribution: Debian
Posts: 168

Rep: Reputation: 30
Windows Apps freeze when printing to network samba + cups printer


Basically what I am trying to achieve is a shared printer. It's an Old HP Officejet V40 set up with CUPS (which I won't go into, because it prints test pages from cups admin fine.) Then I have samba set up to share the printer, like so :

[printers]
comment = All Printers
browseable = yes
path = /var/spool/samba
printable = yes
public = yes
guest ok = yes
writable = no
create mode = 0700
printer admin = root

The strange part is, it was working this morning. Then I tripped over the power cable, and it hasn't worked since. Now, when it happened, my first thought was, maybe it was the last line I changed, which was 'use client driver = yes' however, I still see the effect with it both on and off. One interesting thing is, without this, the printer in windows reports 'access denied' (which is what it was doing this moring, when it was printing fine) but with it, the printer in windows reports 'ready'

Now, every time I try and print, the application trying to print just hangs. It doesn't matter what it is (Seen it so far with OO.o 1.1 for windows, Adobe PDF reader 5, notepad and the Print test page in the printer properties)

Any ideas on what is doing this? It's really annoying now.
 
Old 02-17-2005, 06:38 PM   #2
urzumph
Member
 
Registered: Jan 2004
Location: Australia
Distribution: Debian
Posts: 168

Original Poster
Rep: Reputation: 30
I'm going to post the solution to this (Which I found with the help of 'TheBonsai' in the samba IRC Channel)

After checking my samba logs (/var/log/samba/<machine_name>.log) I saw these lines :
[2005/02/18 09:52:40, 1] smbd/service.c:make_connection_snum(648)
new (192.168.0.4) connect to service HP initially as user nobody (uid=65534, gid=65534) (pid 9672)
[2005/02/18 09:52:40, 0] tdb/tdbutil.c:tdb_log(725)
tdb(/var/cache/samba/printing/HP.tdb): rec_free_read bad magic 0x42424242 at offset=25564
[2005/02/18 09:53:35, 1] smbd/service.c:close_cnum(836)

That means your /var/cache/samba/printing/HP.tdb file is corrupt, and you need to remove it (delete or move) and restart samba. That will fix the issue. (Please note that HP isn't just 2 random letters, it's the name of the printer)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help with printing to Windows printer with cups and samba. Royle Linux - Networking 3 01-23-2005 12:16 PM
suse 9.1 printing to cups ipp network printer sichen Linux - General 0 08-09-2004 06:30 PM
Network Printing, CUPS, Slackware 9.1, Xante Printer Conpen2000 Linux - Newbie 0 01-12-2004 09:36 PM
help cups printing to network printer sledgexiv Linux - Newbie 0 09-23-2003 06:39 PM
Samba printing to CUPS printer kris.kj.jacobs Linux - Networking 1 11-02-2001 03:42 PM


All times are GMT -5. The time now is 08:50 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration