LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 10-18-2010, 02:51 AM   #1
*CiScO*
LQ Newbie
 
Registered: Oct 2010
Location: France
Distribution: debian-free BSD
Posts: 5

Rep: Reputation: 0
winbind error after reboot on proxy squid with ntlm_auth


Hy, i'm running a squid server on debian lenny with ntlm_auth.

Everything is working good after following those two tutorials :

http://doc.ubuntu-fr.org/tutoriel/co...tive_directory


and

http://irp.nain-t.net/doku.php/220squid:040_ntlm


As all was working perfectly i decided to rebbot my server, and after reboot the ntlm-auth was not working anymore.

When i tried to run the command "wbinfo" with many options i had this error message "error looking up domain users" or"error looking up domain group" so i think that the problem deals with winbind module.

I know that proxy user needs rights and that after reboot the rights are reseted, so this problem doesn't come from here.

And when i try to open IE with a client i have this "cache accesss denied" because the ntlm_auth wasn't done.

I tried to restart all services (samba,winbind,squid) without any success, only the "kinit" command is still working...


Does someone have an idea of what is going on with winbind when the server is rebooted ?

Thanks by advance.
 
Old 10-18-2010, 08:29 AM   #2
New2Linux2
Member
 
Registered: Jan 2004
Location: Arizona
Distribution: Debian
Posts: 147

Rep: Reputation: 43
My first suggestion would be to check the logs to see what errors are reported during system boot.
 
Old 10-18-2010, 11:55 AM   #3
*CiScO*
LQ Newbie
 
Registered: Oct 2010
Location: France
Distribution: debian-free BSD
Posts: 5

Original Poster
Rep: Reputation: 0
Talking

i had begon by this but in a wrong way, i wasn't looking for the good log file...how stupid i am !
according to your advice i found the winbind log file and i understood that it was a problem of rights on "/var/run/samba/winbindd_privileged" .
instead of setting "chown proxy:root" like said in the tutos, i set "chown root:root" and modified also the "cache_effective _group" from "root" to "winbindd_priv" in my squid.conf and all works again, even after reboot !!!!!!

Thanks for your advice .

Last edited by *CiScO*; 10-18-2010 at 11:58 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
squid proxy error salimshahzad Linux - Server 1 03-07-2010 11:04 AM
Squid, Winbindd NTLM_AUTH failover when PDC down razza Linux - Server 0 11-16-2008 05:52 PM
Proxy Squid Authentication error message alexjordan02 Linux - Software 0 01-23-2004 01:42 PM
Running Squid Proxy Resulted with an error rhonneil Linux - Networking 2 09-24-2003 05:24 AM


All times are GMT -5. The time now is 12:59 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration