LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 01-10-2012, 05:04 PM   #1
*Dark Dragon*
Member
 
Registered: Apr 2005
Distribution: Debian Testing + KDE
Posts: 42

Rep: Reputation: 15
Question Why root is remounted with commit=0 (=600 specified in fstab) at the end of start-up?


My problem is that in fstab I have specified commit=600 but during start-up
something remounts root with commit=0 option. Here is the log:
Code:
% dmesg | grep sdd1 | grep re-
[   14.918717] EXT4-fs (sdd1): re-mounted. Opts: (null)
[   15.036666] EXT4-fs (sdd1): re-mounted. Opts: user_xattr,errors=remount-
ro,commit=600
[   38.425387] EXT4-fs (sdd1): re-mounted. Opts: user_xattr,errors=remount-
ro,commit=600,commit=0
Last line is the last in dmesg, so this happens at the end of the start-up.

If somebody have an idea why this is happening and how can I stop this, please help me. If not, at least some clues how to find what script/program is doing this would be appreciated.

I'm using fresh (less than 2 weeks old) installation of Debian GNU/Linux Testing and KDE. I know I can remount it manually or write startup script that remounts it one more time, but I want to find the source of the problem and fix it.
 
Old 01-10-2012, 09:28 PM   #2
*Dark Dragon*
Member
 
Registered: Apr 2005
Distribution: Debian Testing + KDE
Posts: 42

Original Poster
Rep: Reputation: 15
Found it: /usr/lib/pm-utils/power.d/journal-commit

This script is responsible for the problem. To solve, I removed "commit=600" from fstab and changed variable for "commit" option when on AC power in the script.

I do not need it on my workstation (working 24/7) but KDE requires pm-utils so I cannot purge it. I'm really surprised by the fact that everywhere everybody says to put "commit" option in fstab where it does have ZERO effect if you have KDE (and therefore pm-utils) installed. And I did not find anything in any manual about necessity to edit "journal-commit" script if I'm not happy with default "commit=0".

Hopefully information in this topic will be useful to somebody.
 
Old 01-11-2012, 10:06 AM   #3
*Dark Dragon*
Member
 
Registered: Apr 2005
Distribution: Debian Testing + KDE
Posts: 42

Original Poster
Rep: Reputation: 15
Editing /usr/lib/pm-utils/power.d/journal-commit is not necessary (and bad idea because upgrade can overwrite it with new version). Using "commit" option in /etc/fstab is bad idea too. So how to do it properly? After some research I think that putting these lines in /etc/sysctl.d/local.conf is the solution:
Code:
vm.dirty_writeback_centisecs = 60000
vm.dirty_expire_centisecs = 120000
I set dirty_expire_centisecs twice the value of dirty_writeback_centisecs. Please note that with these settings it is possible to lose up to 20 minutes of work. So if you are not on UPS-protected Xeon workstation with RDIMM memory like I am, you probably want to use smaller values, for typical UPS-protected desktop PC or laptop 6000 and 12000 (1 and 2 minutes respectively) are good values (IMO).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
cvs [commit aborted]: 'root' is not allowed to commit files rakesh@linuxforum Linux - Newbie 7 09-26-2013 03:53 PM
cvs [commit aborted]: 'root' is not allowed to commit files r_ramya06 Linux - Newbie 5 07-08-2008 09:04 AM
ext3 commit interval on root device clvic Linux - General 4 05-22-2008 04:07 AM
warning: no final newline at the end of /etc/fstab Jeebizz Slackware 2 10-12-2004 02:19 PM
fstab file format - numbers at the end jjisnow Linux - Newbie 3 03-23-2004 06:54 PM


All times are GMT -5. The time now is 08:00 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration