LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 11-20-2004, 11:10 PM   #1
HoreC
LQ Newbie
 
Registered: Nov 2004
Posts: 7

Rep: Reputation: 0
why i can't install gcc or any other C compiler?


when i apt-get install gcc, it shows:
The following packages have unmet dependencies:
gcc: Depends: gcc-3.3 (>= 1:3.3.4-1) but it is not going to be installed
E: Broken packages

when i install gcc-3.4, instead,
still can't find gcc:
bash:gcc:command not found
 
Old 11-20-2004, 11:20 PM   #2
The_JinJ
Member
 
Registered: Apr 2004
Location: Scotland
Distribution: Suse, OpenWRT
Posts: 299

Rep: Reputation: 30
Re: why i can't install gcc or any other C compiler?

Quote:
Originally posted by HoreC
when i apt-get install gcc, it shows:
The following packages have unmet dependencies:
gcc: Depends: gcc-3.3 (>= 1:3.3.4-1) but it is not going to be installed
E: Broken packages

when i install gcc-3.4, instead,
still can't find gcc:
bash:gcc:command not found
You say you installed 3.4 - did that work ok and no dependancy problems?
Just install the packages it lists as dependencies (can go round in circles a bit sometimes) - the last error suggests it never installed.
 
Old 11-20-2004, 11:31 PM   #3
HoreC
LQ Newbie
 
Registered: Nov 2004
Posts: 7

Original Poster
Rep: Reputation: 0
Re: Re: why i can't install gcc or any other C compiler?

Quote:
Originally posted by The_JinJ
You say you installed 3.4 - did that work ok and no dependancy problems?
Just install the packages it lists as dependencies (can go round in circles a bit sometimes) - the last error suggests it never installed.
yes, i do install gcc-3.3,
but it still has an error as below:

The following packages have unmet dependencies:
gcc-3.3: Depends: cpp-3.3 (< 1:3.3.5) but 1:3.3.5-2 is to be installed
E: Broken packages

and while i install cpp-3.3, the system tell me it's a already the newest version,
and my cpp-3.3's version is :
cpp (GCC) 3.3.5 (Debian 1:3.3.5-2)
now
 
Old 11-21-2004, 11:51 AM   #4
ernobe
Member
 
Registered: Nov 2004
Location: Costa Rica
Distribution: Debian SID
Posts: 33

Rep: Reputation: 15
It appears that you have a distribution conflict. Are you trying to install packages from the unstable distribution over stable? Run dselect, choose the right apt source, ( either stable, unstable, or testing ) and update available packages.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
no gcc in suse 9.1...how do i install a compiler? set235 Linux - Newbie 2 07-28-2005 11:34 PM
Can't install GCC compiler!??!?! MickBurke Linux - Newbie 3 03-07-2005 02:53 PM
GCC Compiler Install Alpha-01 Linux - Newbie 6 10-03-2004 09:48 AM
Install GCC compiler on Mandrake 9.2 p4priya Linux - Software 1 02-19-2004 01:34 AM
gcc compiler install problem mla Linux - Software 4 10-11-2003 07:03 AM


All times are GMT -5. The time now is 08:01 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration