LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 04-07-2011, 07:39 AM   #1
radiodee1
Member
 
Registered: Oct 2006
Location: New York
Distribution: Debian
Posts: 669
Blog Entries: 11

Rep: Reputation: 36
wheezy nfs upgrade


I safe-upgrade'd a wheezy machine today. Now my nfs doesn't work. Anyone know why?

Here's some of 'cat /var/log/aptitude'
Code:
[UPGRADE] nfs-common 1:1.2.2-5 -> 1:1.2.3-1
[UPGRADE] nfs-kernel-server 1:1.2.2-5 -> 1:1.2.3-1
Here's some output from init.d
Code:
# /etc/init.d/nfs-common restart
Stopping NFS common utilities: idmapd statd.
Starting NFS common utilities: statd failed!
# /etc/init.d/nfs-kernel-server restart
Stopping NFS kernel daemon: mountd nfsd.
Unexporting directories for NFS kernel daemon....
Exporting directories for NFS kernel daemon....
Starting NFS kernel daemon: nfsd mountd failed!
#
everything worked yesterday.
 
Old 04-07-2011, 07:48 AM   #2
j1alu
Member
 
Registered: Apr 2009
Distribution: debian gnu/linux
Posts: 798

Rep: Reputation: Disabled
Bit of feedback, but not much.
I had the same error-message on 2 Sid-installations, and could solve them by installing nfs-common from testing (aka Wheezy).
I can't find anything about that problem at the bug-reports:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=551821
but as i don't use nfs my interest is small to search.
 
Old 04-07-2011, 08:19 AM   #3
cynwulf
Senior Member
 
Registered: Apr 2005
Distribution: OpenBSD, FreeBSD
Posts: 1,265

Rep: Reputation: Disabled
Noticed the same problem a few days ago, I don't use nfs either so didn't bother looking into it...
 
Old 04-07-2011, 08:29 AM   #4
radiodee1
Member
 
Registered: Oct 2006
Location: New York
Distribution: Debian
Posts: 669
Blog Entries: 11

Original Poster
Rep: Reputation: 36
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=562737

is this the right bug? I'm going to try rpcbind .
 
Old 04-07-2011, 08:58 AM   #5
radiodee1
Member
 
Registered: Oct 2006
Location: New York
Distribution: Debian
Posts: 669
Blog Entries: 11

Original Poster
Rep: Reputation: 36
after installing rpcbind I get this:
(I think I don't know enough about rpcbind to get it to work)

Code:
# /etc/init.d/nfs-kernel-server restart
Stopping NFS kernel daemon: mountd nfsd.
Unexporting directories for NFS kernel daemon....
Exporting directories for NFS kernel daemon....
Starting NFS kernel daemon: nfsdrpc.nfsd: Setting version failed: errno 16 (Device or resource busy)
rpc.nfsd: writing fd to kernel failed: errno 13 (Permission denied)
rpc.nfsd: writing fd to kernel failed: errno 13 (Permission denied)
rpc.nfsd: unable to set any sockets for nfsd
 failed!
 
Old 04-07-2011, 12:58 PM   #6
radiodee1
Member
 
Registered: Oct 2006
Location: New York
Distribution: Debian
Posts: 669
Blog Entries: 11

Original Poster
Rep: Reputation: 36
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=615642

here's another bug report that might be relevant.
 
Old 04-10-2011, 07:32 AM   #7
j1alu
Member
 
Registered: Apr 2009
Distribution: debian gnu/linux
Posts: 798

Rep: Reputation: Disabled
I set ntf-common on hold for two Sid installations.
Now i got the problem on my testing laptop too. Uff.
You found a fast solution in the meantime?
 
Old 04-10-2011, 07:36 AM   #8
radiodee1
Member
 
Registered: Oct 2006
Location: New York
Distribution: Debian
Posts: 669
Blog Entries: 11

Original Poster
Rep: Reputation: 36
Quote:
Originally Posted by j1alu View Post
I set ntf-common on hold for two Sid installations.
Now i got the problem on my testing laptop too. Uff.
You found a fast solution in the meantime?
nope. I was wondering about using samba, as my needs are minimal and I only use nfs to back things up (from a laptop). Can you specify for samba the same directory as you serve up with nfs, or do you have to dismantle nfs for samba to serve the same directory? Just wondering.
 
Old 04-10-2011, 10:11 AM   #9
cynwulf
Senior Member
 
Registered: Apr 2005
Distribution: OpenBSD, FreeBSD
Posts: 1,265

Rep: Reputation: Disabled
It looks like it's been patched and is now in Sid.

Code:
nfs-common:
  Installed: (none)
  Candidate: 1:1.2.3-2
  Version table:
     1:1.2.3-2 0
        500 http://ftp.uk.debian.org/debian/ unstable/main i386 Packages

nfs-kernel-server:
  Installed: (none)
  Candidate: 1:1.2.3-2
  Version table:
     1:1.2.3-2 0
        500 http://ftp.uk.debian.org/debian/ unstable/main i386 Packages
 
Old 04-10-2011, 10:28 AM   #10
radiodee1
Member
 
Registered: Oct 2006
Location: New York
Distribution: Debian
Posts: 669
Blog Entries: 11

Original Poster
Rep: Reputation: 36
Code:
# aptitude  -t unstable install nfs-common nfs-kernel-server
this just seems to switch from portmap to rpcbind. here's part of the upgrade. nfs won't start.

Code:
...
Setting up nfs-common (1:1.2.3-2) ...
Stopping NFS common utilities: idmapd statd.
Starting NFS common utilities: statd idmapd.
Setting up nfs-kernel-server (1:1.2.3-2) ...
Stopping NFS kernel daemon: mountd nfsd.
Unexporting directories for NFS kernel daemon....
Exporting directories for NFS kernel daemon....
Starting NFS kernel daemon: nfsdrpc.nfsd: writing fd to kernel failed: errno 13 (Permission denied)
rpc.nfsd: unable to set any sockets for nfsd
 failed!
this doesn't seem to do it for me. maybe I'm doing something wrong? can someone tell me if 1.2.3-2 works for them?
 
Old 04-10-2011, 10:53 AM   #11
j1alu
Member
 
Registered: Apr 2009
Distribution: debian gnu/linux
Posts: 798

Rep: Reputation: Disabled
It did work for me, on Testing, i unhold nfs-common and installed it from Sid, and the error is gone.
Now i will try the same on Sid. Strange.
(Btw: i don't use nfs, so for me it is rather an annoynace, and i ain't got nfs-kernel-server installed).

See here:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=562737

Whatever i run across i will post.
good luck.
 
Old 04-11-2011, 03:49 AM   #12
radiodee1
Member
 
Registered: Oct 2006
Location: New York
Distribution: Debian
Posts: 669
Blog Entries: 11

Original Poster
Rep: Reputation: 36
This ultimately works for me (finally). I had to edit my '/etc/hosts.deny' file, taking out a rule that read 'ALL: ALL'. I have a rule in '/etc/hosts.allow' that allows the share that I'm most interested in. The rule in 'hosts.deny' worked fine before though, but like I say, I may not know enough about these things to get it to work now. If I were on a big network I suspect this would not be good for security, but I'm not, I'm just trying to backup my laptop.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Downgrading From Wheezy to Squeeze Bradj47 Debian 9 07-17-2013 05:18 PM
Iceweasel randomly crashes in wheezy eveningsky339 Debian 26 05-14-2011 10:11 AM
[SOLVED] wheezy kernel panic (2.6.32) kaz2100 Debian 3 04-05-2011 08:06 PM
Good Morning Wheezy jdkaye Debian 1 02-07-2011 08:31 AM
Info: Debian Wheezy on the way jdkaye Debian 14 09-17-2010 09:36 PM


All times are GMT -5. The time now is 07:57 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration