LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   Web Admin and Cups logon failure (http://www.linuxquestions.org/questions/debian-26/web-admin-and-cups-logon-failure-771773/)

addux 11-26-2009 02:52 PM

Web Admin and Cups logon failure
 
I'm using Gnome w/ Debain 5.0 and an epson printer. I installed the printer using the gnome tool in System>Administrator>Printing without any problem...the printer is operating properly and so is the scanner function. I prefer the interface from cups via my web browser @ localhost:631, but I am unable use either root or 'me' username and password. I have read around and found that this function is disabled by default, but I cannot find a way to enable the function. I have added 'me' to the group lpadmin and also tried the command lppassword -a 'me'; no joy. I have also used the gnome admin tool to manage users to give printer and scanner access to 'me'.

Any assistance will be greatly appreciated.

r0z

addux 11-26-2009 05:51 PM

As an update, I'm not sure why it wasn't working earlier, but I restarted my computer and I have access to my scanner/printer via my user account now. As an addition to my original post, before I restarted I did try restarting just the cups daemon with /etc/init.d/cups restart and had no luck. The setting I believe changed my ability to use the web admin function was using the tool located in the Gnome menu System>Administrator>Users and Groups and adding my local user (non-root) to the group lpadmin. I apologize for taking up another thread.


All times are GMT -5. The time now is 03:49 PM.