LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 03-06-2006, 05:40 PM   #1
mnotgninnep
LQ Newbie
 
Registered: Jan 2005
Posts: 23

Rep: Reputation: 15
vsftpd and wput


I'm trying to use wput and vsftpd to upload files to a small server, but wput bails out saying

--23:26:39-- `i.txt'
=> ftp://ftploader:xxxxx@192.168.0.4:21/ut-server/i.txt
Connecting to 192.168.0.4:21... connected!
==> AUTH TLS ... failed (Please login with USER and PASS.).
Logging in as ftploader ... Logged in!
==> CWD ut-server
==> SIZE i.txt ... failed.
Skipping this file due to resume/upload/skip rules.
-- Skipping file: i.txt
FINISHED --23:26:40--
Skipped 1 file.[/CODE]

What have I missd in vsftpd.conf?

Last edited by mnotgninnep; 03-06-2006 at 05:42 PM.
 
Old 03-06-2006, 09:09 PM   #2
dracae
Member
 
Registered: Feb 2006
Location: Oklahoma
Distribution: Debian Sid and Etch
Posts: 423

Rep: Reputation: 30
I suspect you do not have overwrite/modify permissions.
 
Old 03-07-2006, 01:38 AM   #3
mnotgninnep
LQ Newbie
 
Registered: Jan 2005
Posts: 23

Original Poster
Rep: Reputation: 15
all the driectory permissions are set to rwxrwxr--

but the ftp is logging on as the owner, so I don't see a problem there...
 
Old 03-07-2006, 08:55 AM   #4
dracae
Member
 
Registered: Feb 2006
Location: Oklahoma
Distribution: Debian Sid and Etch
Posts: 423

Rep: Reputation: 30
vsftp has internal permissioning to allow write/overwrite/delete operations.
 
Old 03-07-2006, 12:11 PM   #5
mnotgninnep
LQ Newbie
 
Registered: Jan 2005
Posts: 23

Original Poster
Rep: Reputation: 15
ok, well I've just looked right through vsftpd.conf.5 and haven't found a lot, so here's my vsftpd.conf file...

can someone please tell me what I'm doing wrong?

listen=YES
anonymous_enable=NO
local_enable=YES
write_enable=YES
local_umask=077
file_open_mode=0777
dirmessage_enable=YES
xferlog_enable=YES
connect_from_port_20=YES
chown_uploads=YES
chown_username=michael
ftpd_banner=Welcome to the ftp server.
secure_chroot_dir=/var/run/vsftpd
pam_service_name=vsftpd
rsa_cert_file=/etc/ssl/certs/vsftpd.pem
dirlist_enable=YES

Last edited by mnotgninnep; 03-07-2006 at 12:14 PM.
 
Old 03-07-2006, 12:50 PM   #6
dracae
Member
 
Registered: Feb 2006
Location: Oklahoma
Distribution: Debian Sid and Etch
Posts: 423

Rep: Reputation: 30
Actually it looks like that message is coming from wput.
from the manpage
−−dont−continue


If this flag is specified, resuming will be turned off, meaning that a remote file being smaller than the local one will be overwritten. To skip this file, you have to enable −−skip−existing. See also USAGE.resumehandling
−−reupload


If this flag is specified, a remote file having the same size as the local one is to be uploaded. Skipping is default.


−−skip−larger


If this flag is specified, a remote file being larger than the local one will be skipped. Default is reuploading it.


−−skip−existing


If this flag is specified, the upload of a file will be skipped if the remote file already exists.
 
Old 03-07-2006, 03:08 PM   #7
mnotgninnep
LQ Newbie
 
Registered: Jan 2005
Posts: 23

Original Poster
Rep: Reputation: 15
ok, using the --reupload seems to work, though that's only 1 small file... I was kind of hoping not to have to reupload 5/6 GB of data every time...

I just found the debug command for wput, and got this
so it would appear that the SIZE command is failing...

wput -d i.txt ftp://ftploader:xxxxx@
192.168.0.4/
Added file `i.txt' to queue.
Added URL `ftp://ftploader:xxxxx@192.168.0.4/' to queue.
processing queue:
File: `i.txt'
URL : `ftp://ftploader:xxxxx@192.168.0.4/'
PRE_GUESS: local_file: i.txt
remote_path: remote_file: (0)
POST_GUESS: local_file: i.txt
remote_path: remote_file: i.txt
Searching for skip_entry ftp://ftploader:xxxxx@192.168.0.4:21/
--21:01:28-- `i.txt'
=> ftp://michael:xxxxx@192.168.0.4:21/i.txt
starting again
Connecting to 192.168.0.4:21... c_sock: 7a4
initiating timeout connect (300)
Checking whether 1956 is writable... 1 (0:No error)
connected[220] 'Welcome to Fireball-M.'
!
==> AUTH TLS ... ---->AUTH TLS
[530] 'Please login with USER and PASS.'
failed (Please login with USER and PASS.).
Logging in as michael ... ---->USER michael
[331] 'Please specify the password.'
[230] 'Login successful.'
Logged in!
==> SIZE i.txt ... ---->SIZE i.txt
[550] 'Could not get file size.'
failed.
local_fsize: 0
target_fsize: 0
resume_table: 1,0,2
Skipping this file due to resume/upload/skip rules.
-- Skipping file: i.txt
processing queue:
Connection ended. (420490)
Checking whether 1956 is writable... 1 (0:No error)
---->QUIT
[221] 'Goodbye.'
Closing socket 420490
FINISHED --21:01:28--
Skipped 1 file.
 
Old 03-07-2006, 03:54 PM   #8
dracae
Member
 
Registered: Feb 2006
Location: Oklahoma
Distribution: Debian Sid and Etch
Posts: 423

Rep: Reputation: 30
Try adding this option to your vsftpd.conf
cmds_allowed=PASV,RETR,LIST,SIZE,QUIT
 
Old 03-07-2006, 05:06 PM   #9
mnotgninnep
LQ Newbie
 
Registered: Jan 2005
Posts: 23

Original Poster
Rep: Reputation: 15
ah, excellent, thankyou so so much for you help

had to modify that slightly...
cmds_allowed=PASV,SIZE,CWD,PWD,MKD,RMD,STOR,DELE,TYPE,RETR,LIST,QUIT

and thankyou again
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
vsftpd settingd and VSFTPD DEAD BUT SUBSYS LOCKED pc_copat Linux - Newbie 15 11-05-2009 10:31 PM
vsftpd.conf/chroot/vsftpd.chroot_list issue Jerman Linux - Security 2 06-01-2007 07:24 PM
vsftpd, web uploads, vsftpd virtual users, apache virtual hosts, home directories jerryasher Linux - Software 7 02-18-2007 06:29 AM
VSFTPD with 500 oops :vsftpd: missing argv[0] mole_13 Linux - Newbie 0 05-04-2005 01:05 AM
VSFTPD Debian VSFTPD "unrecognised variable in config file" DCT Linux - Software 0 05-29-2004 11:59 PM


All times are GMT -5. The time now is 09:39 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration