LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   virtualbox 4.0 won't compile it's vboxdrv module (http://www.linuxquestions.org/questions/debian-26/virtualbox-4-0-wont-compile-its-vboxdrv-module-892047/)

radiodee1 07-16-2011 11:33 AM

virtualbox 4.0 won't compile it's vboxdrv module
 
With the kernel updates in wheezy my vboxdrv module won't compile. This is the output from the command 'dpkg-reconfigure':

Code:

# dpkg-reconfigure virtualbox-4.0
Stopping VirtualBox kernel modules:.
addgroup: The group `vboxusers' already exists and is not a system group. Exiting.
update-rc.d: warning: vboxdrv stop runlevel arguments (0 1 6) do not match LSB Default-Stop values (1)
insserv: warning: current start runlevel(s) (3 4 5) of script `vboxdrv' overwrites defaults (2 3 4 5).
insserv: warning: current stop runlevel(s) (0 1 2 6) of script `vboxdrv' overwrites defaults (1).
Stopping VirtualBox kernel modules:.
Uninstalling old VirtualBox DKMS kernel modules:.
Trying to register the VirtualBox kernel modules using DKMS:
Failed, trying without DKMS ... failed!
Recompiling VirtualBox kernel modules:
Look at /var/log/vbox-install.log to find out what went wrong ... failed!
insserv: warning: current start runlevel(s) (3 4 5) of script `vboxweb-service' overwrites defaults (2 3 4 5).
insserv: warning: current stop runlevel(s) (0 1 2 6) of script `vboxweb-service' overwrites defaults (0 1 6).

Here's the 'vbox-install.log' mentioned above:

Code:

Makefile:178: *** Error: /usr/src/linux (version 2.6.39) does not match the current kernel (version 2.6.39-3.dmz.2-liquorix-686).  Stop.
I thought maybe I had done something funny to uname, so I reinstalled 'coreutils' (does coreutils contain uname?). This didn't help. What should I do? You can see from the output I tried the liquorix kernel thinking that that might solve the issue. I get mostly the same problem. Has anyone else had this sort of problem?

craigevil 07-16-2011 12:09 PM

Install virtualbox-source and virtualbox-dkms

Or you can use svmi, from the smxi maintainer.

radiodee1 07-16-2011 01:01 PM

thanks. I installed the ose versions as you suggested and then after some messing with module-assistant I got it to work. I did have to install virtualbox-qt... without which there was no qt based vm management tool. Thanks again.


All times are GMT -5. The time now is 06:22 PM.