LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 07-16-2007, 09:31 AM   #1
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
Various problems with xorg 7.2 under debian (Lenny/Sid) with i810 driver.


Hello,

I'm experiencing several problems with xorg under debian and I have a feeling they're all related. Also, I can't seem to find anyone else who is have such problems which is a little worrying. The problems are:

  1. Very often, I just get a black screen when starting X (with GDM). Other times I'll get a cursor for a few seconds and then a garbage screen and then black. CTRL+ALT+F1 and/or DELETE do nothing. I'll reboot a couple of times and it will finally work but needless to say this is annoying. I do not get this problem on Ubuntu or DesktopBSD (on the same computer). I've come across people with similar problems but they all seem to say that their problems go away with xorg 7.2. I'm running 7.2 and I cannot get it to work reliably.

  2. When X finally decides to start up it will ignore my modes (I don't have any modelines, though) as set in xorg.conf. I've specified 1280x1024, 1024x768, 800x600 and 640x480 but X will invariably start up in 1280x960 which is not listed anywhere in my xorg.conf. Once X has started, I can switch to 1280x1024 with gnome-display-properties (I don't run GNOME, though, I run Fluxbox) so this version of xorg is clearly able to handle that mode. This problem, also, does not occur on Ubuntu. I've tried copying over the Ubuntu xorg.conf file but that makes matters worse. X then starts in 1440x900 mode which is totally ridiculous and makes all the colours look completely off (not to mention the aspect ratio).

  3. Further to the last problem, the CTRL+ALT+PLUS and CTRL+ALT+MINUS key combos don't work. I've tried specifying "DontZoom" "False" in my ServerFlags section but to no avail. I've come across others with this problem and they were able to work around the problem by binding some key combo to xvidtune -next and -prev but strangely that command does absolutely nothing for me. Just to restate, running the command xvidtune -next or xvidtune -prev does absolutely nothing and spits out no error. Same for running xvidtune with no arguments and clicking the "next" or "prev" buttons. However, gnome-display-properties is able to change modes without problems (as stated above). Once again, no problems with any of this in Ubuntu.

This all started recently when I reinstalled Debian from scratch. I installed a minimal instance of version 4.0 "Etch" and dist-upgraded to "Lenny".

Output of lspci |grep VGA is:
Code:
00:02.0 VGA compatible controller: Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 01)
01:00.0 VGA compatible controller: nVidia Corporation NV18 [GeForce4 MX 440 AGP 8x] (rev c1)
Yes, I have both an onboard Intel and a separate NVidia but the latter does not work and is disabled anyway in the BIOS.

My xorg.conf file is as follows:
Code:
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
	FontPath	"/usr/share/fonts/X11/misc"
	FontPath	"/usr/X11R6/lib/X11/fonts/misc"
	FontPath	"/usr/share/fonts/X11/cyrillic"
	FontPath	"/usr/X11R6/lib/X11/fonts/cyrillic"
	FontPath	"/usr/share/fonts/X11/100dpi/:unscaled"
	FontPath	"/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/share/fonts/X11/75dpi/:unscaled"
	FontPath	"/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/share/fonts/X11/Type1"
	FontPath	"/usr/X11R6/lib/X11/fonts/Type1"
	FontPath	"/usr/share/fonts/X11/100dpi"
	FontPath	"/usr/X11R6/lib/X11/fonts/100dpi"
	FontPath	"/usr/share/fonts/X11/75dpi"
	FontPath	"/usr/X11R6/lib/X11/fonts/75dpi"
	# path to defoma fonts
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
	Load	"i2c"
	Load	"bitmap"
	Load	"ddc"
	Load	"dri"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"type1"
	Load	"vbe"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc104"
	Option		"XkbLayout"	"us"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"			"/dev/input/mice"
	Option		"Protocol"			"ExplorerPS/2"
#	Option		"Emulate3Buttons"	"true"
EndSection

Section "Device"
	Identifier	"Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device"
	Driver		"i810"
#	VideoRam	65536
	Option		"XVideo"	"On"
	Option		"NoAccel"	"false"
	Option		"DRI"		"true"
#	Option		"DevicePresence "On"
EndSection

Section "Monitor"
	Identifier		"Generic Monitor"
	Option		"DPMS"
	HorizSync	28-65
	VertRefresh	43-60
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device"
	Monitor		"Generic Monitor"
	DefaultDepth	24
	SubSection "Display"
		Depth		1
		Modes		"1280x1024" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		4
		Modes		"1280x1024" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		8
		Modes		"1280x1024" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		15
		Modes		"1280x1024" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		16
		Modes		"1280x1024" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		24
		Modes		"1280x1024" "1024x768" "800x600" "640x480"
	EndSubSection
EndSection

Section "ServerFlags"
	Option	"DontZoom"			"False"
	Option	"DisableVidModeExtension"	"False"
	Option	"HandleSpecialKeys"		"Always"
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
EndSection

Section "DRI"
       Group	0
       Mode	0666
EndSection
I cannot think of anything else to do and I've searched until my fingers bled and found people with a subset of my problems but not the whole thing, nor did any advice dispensed help me in any way. I look forward to your input.

Thanks in advance.

adz
 
Old 07-16-2007, 08:02 PM   #2
Telemachos
Member
 
Registered: May 2007
Distribution: Debian
Posts: 754

Rep: Reputation: 59
Have you checked out xserver-xorg-intel instead of i810? I ask because I think that the 810 driver is being phased out, but that may only be for newer (900 series) Intel cards. Don't try it unless you check that your card is supported, but it's something to look at.
 
Old 07-17-2007, 02:53 AM   #3
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Original Poster
Rep: Reputation: 53
Unfortunately I've already tried that. I simply changed "i810" to "intel" and absolutely no change came about. If there's something else I'm meant to do I'm all ears.
 
Old 07-22-2007, 02:45 AM   #4
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Original Poster
Rep: Reputation: 53
I have a minor update with a workaround from problem 2 above (X starting in wrong modes):

It appears that this is all because the new default driver for intel chips is now "intel" and not "i810". It has many improvements but clearly some bugs as well. I've added the line:
Code:
xrandr -s 1280x1024
to the very beginning of my WM startup script (fluxbox, in my case). GDM still sometimes fails to start and when it does so, it still uses the wrong mode but at least once fluxbox starts the mode is correct. It's a hack, I know, but a reasonably good temporary solution. This has also allowed me to simplify my xorg.conf file to:

Code:
Section "Files"
	FontPath	"/usr/share/fonts/X11/misc"
	FontPath	"/usr/X11R6/lib/X11/fonts/misc"
	FontPath	"/usr/share/fonts/X11/cyrillic"
	FontPath	"/usr/X11R6/lib/X11/fonts/cyrillic"
	FontPath	"/usr/share/fonts/X11/100dpi/:unscaled"
	FontPath	"/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/share/fonts/X11/75dpi/:unscaled"
	FontPath	"/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/share/fonts/X11/Type1"
	FontPath	"/usr/X11R6/lib/X11/fonts/Type1"
	FontPath	"/usr/share/fonts/X11/100dpi"
	FontPath	"/usr/X11R6/lib/X11/fonts/100dpi"
	FontPath	"/usr/share/fonts/X11/75dpi"
	FontPath	"/usr/X11R6/lib/X11/fonts/75dpi"
	# path to defoma fonts
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
	Load	"i2c"
	Load	"bitmap"
	Load	"ddc"
	Load	"dri"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"type1"
	Load	"vbe"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc104"
	Option		"XkbLayout"	"us"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"			"/dev/input/mice"
	Option		"Protocol"			"ExplorerPS/2"
EndSection

Section "Device"
	Identifier	"Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device"
	Driver		"intel"
EndSection

Section "Monitor"
	Identifier		"Generic Monitor"
	Option		"DPMS"
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device"
	Monitor		"Generic Monitor"
	DefaultDepth	24
	SubSection "Display"
		Depth		1
	EndSubSection
	SubSection "Display"
		Depth		4
	EndSubSection
	SubSection "Display"
		Depth		8
	EndSubSection
	SubSection "Display"
		Depth		15
	EndSubSection
	SubSection "Display"
		Depth		16
	EndSubSection
	SubSection "Display"
		Depth		24
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
EndSection
Which is the recommended xorg.conf file for the new intel driver. Note the lack of "Mode" lines in the "Screen" section and the lack of "HorizSync" and "VertRefresh" lines in the "Monitor" section. All these are auto-detected now. Th "Mode 0666" line in the "DRI" section is also now the default and that section can be removed.

Last edited by adz; 07-22-2007 at 02:46 AM.
 
Old 07-22-2007, 07:56 AM   #5
Telemachos
Member
 
Registered: May 2007
Distribution: Debian
Posts: 754

Rep: Reputation: 59
Quote:
Originally Posted by adz
Unfortunately I've already tried that. I simply changed "i810" to "intel" and absolutely no change came about. If there's something else I'm meant to do I'm all ears.
Sorry, but I'm confused: did you only change the line in your xorg.conf file or did you actually install the package xserver-xorg-intel? I don't think that changing the line would help unless you had already installed the intel driver. Again though this may or may not apply to older intel cards, so it may not help. Still it is something to try.
 
Old 07-22-2007, 08:55 AM   #6
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Original Poster
Rep: Reputation: 53
My apologies, I think I was not clear enough. I actually meant that I think this all came about BECAUSE of the intel driver. You see, it looks as if the xserver-xorg-video-i810 is just a dummy package for the new intel driver which is now the default in Debian unstable. Therefore, it doesn't matter if you specify "i810" or "intel" (for the time being, anyway) in your xorg.conf file because they are the SAME. All of this started, I'm sure, when I dist-upgraded to the new driver.

So all I did was simplify my xorg.conf as recommended by the debian wiki (which didn't do a lot - just cosmetic, really) and put the xrandr line in my fluxbox startup script. The cosmetic changes to my xorg.conf are mainly to simplify and remove unnecessary lines but also whn the new driver stabilises I wont have any deprecated options in there that may cause problems in the future.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Enabling direct rendering for beryl on an nvidia card? (Debian Lenny/Sid) odiseo77 Debian 7 07-08-2007 01:24 PM
Possible xorg I810 driver issue cuco76 Fedora 1 03-21-2007 01:13 PM
Modeline Voodoo xorg.conf - Intel driver i810 to blame? rewtedesco Linux - Hardware 43 01-27-2007 08:28 PM
Problems with Xorg on an ASUS A6U, with Debian sid MasterOfTheWind Linux - Laptop and Netbook 1 04-06-2006 02:34 PM
xorg in debian sid? greythorne Debian 0 11-22-2004 08:56 PM


All times are GMT -5. The time now is 02:03 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration