LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 08-22-2007, 05:52 PM   #1
carlosinfl
Senior Member
 
Registered: May 2004
Location: Orlando, FL
Distribution: Arch
Posts: 2,905

Rep: Reputation: 73
USB Drive Does Not Automount (GNOME)


I installed Lenny today and well...for some strange reason in Gnome my external USB hard drive is not auto mounting as it normally would in Debian in the past.

After I plug it in and wait ample time for Nautilus to pop up, I decide to check "dmesg"

Code:
SCSI device sdd: 234441648 512-byte hdwr sectors (120034 MB)
sdd: Write Protect is off
sdd: Mode Sense: 00 14 00 00
sdd: assuming drive cache: write through
SCSI device sdd: 234441648 512-byte hdwr sectors (120034 MB)
sdd: Write Protect is off
sdd: Mode Sense: 00 14 00 00
sdd: assuming drive cache: write through
 sdd: sdd1
sd 7:0:0:0: Attached scsi disk sdd
So it recognizes the USB drive and I also checked Gnome > System > Preferences > Removable Drives & Media.

It is set to auto mount this when detected so I am clueless as to why it is not doing it now. Just for fun I decided to see if I can manually mount this drive which is formated as EXT3.

Code:
tunafish:/media# ls -l
total 8
lrwxrwxrwx 1 root root    6 2007-08-21 19:41 cdrom -> cdrom0
drwxr-xr-x 2 root root 4096 2007-08-21 19:41 cdrom0
drwxr-xr-x 2 root root 4096 2007-08-22 17:44 usb
tunafish:/media# mount /dev/sdd1 /media/usb/
mount: you must specify the filesystem type
What am I doing wrong?

Code:
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/sda2       /               ext3    defaults,errors=remount-ro 0       1
/dev/md0        /home           ext3    defaults        0       2
/dev/sda1       none            swap    sw              0       0
/dev/hda        /media/cdrom0   udf,iso9660 user,noauto     0       0
 
Old 08-22-2007, 06:13 PM   #2
cgjones
Member
 
Registered: Nov 2005
Location: Central New York
Distribution: Ubuntu
Posts: 405

Rep: Reputation: 30
With the drive plugged in, run the following command and post the output.
Code:
mount
 
Old 08-22-2007, 07:04 PM   #3
carlosinfl
Senior Member
 
Registered: May 2004
Location: Orlando, FL
Distribution: Arch
Posts: 2,905

Original Poster
Rep: Reputation: 73
Quote:
Originally Posted by cgjones View Post
With the drive plugged in, run the following command and post the output.
Code:
mount
Code:
carlos@tunafish:~$ mount
/dev/sda2 on / type ext3 (rw,errors=remount-ro)
tmpfs on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
procbususb on /proc/bus/usb type usbfs (rw)
udev on /dev type tmpfs (rw,mode=0755)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=620)
/dev/md0 on /home type ext3 (rw)
 
Old 08-22-2007, 07:10 PM   #4
cgjones
Member
 
Registered: Nov 2005
Location: Central New York
Distribution: Ubuntu
Posts: 405

Rep: Reputation: 30
I may be missing something, but if you have gnome-volume-manager installed, everything else needed for automounting should be installed.

Try mounting the drive manually with the following command.
Code:
mount -t auto /dev/sdd1 /mnt
 
Old 08-22-2007, 07:13 PM   #5
carlosinfl
Senior Member
 
Registered: May 2004
Location: Orlando, FL
Distribution: Arch
Posts: 2,905

Original Poster
Rep: Reputation: 73
Code:
tunafish:~# mount -t auto /dev/sdd1 /mnt
mount: you must specify the filesystem type
 
Old 08-22-2007, 07:16 PM   #6
cgjones
Member
 
Registered: Nov 2005
Location: Central New York
Distribution: Ubuntu
Posts: 405

Rep: Reputation: 30
How about this?
Code:
mount -t ext3 /dev/sdd1 /mnt
 
Old 08-23-2007, 10:57 AM   #7
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 53
Try: mount -t ext3 /dev/sdd1 /media/usb/
 
Old 08-24-2007, 05:45 AM   #8
knobby67
Member
 
Registered: Mar 2006
Posts: 546

Rep: Reputation: 42
have you used
apt-get install pmount gnome-volume-manager ?

Then reboot and all usb stuff should be detected?
 
Old 08-25-2007, 03:51 AM   #9
amishtechie
Member
 
Registered: Apr 2004
Location: Oberlin, OH
Distribution: Slackware
Posts: 119

Rep: Reputation: 16
Do you have the usbmount package installed?
 
Old 02-10-2009, 04:12 PM   #10
bezdomny
Member
 
Registered: May 2006
Location: North-Central California
Distribution: Debian Lenny
Posts: 154

Rep: Reputation: 30
*solved* Debian Lenny Gnome hotplug USB devices successful

Thanks to cgjones and amishtechie, my USB devices, including my Palm Z22, are successfully auto-mounting following one of the following commands (I'm not sure which one!), or all of them in concert:
Code:
apt-get install hal
apt-get install usbmount
apt-get install gnome-volume-manager
Again, thanks for the help, folks!
 
Old 02-11-2009, 04:24 PM   #11
bezdomny
Member
 
Registered: May 2006
Location: North-Central California
Distribution: Debian Lenny
Posts: 154

Rep: Reputation: 30
spoke too soon

Looks like I spoke too soon. The USB devices (plus my Windows partition, which is written into fstab) are recognized by the system (confirmed by dmesg) and appear in "Computer", but are not mounted until I open System>Preferences>Removable Drives and Media. I don't have to adjust anything in the applet, just open it. Every session. Isn't that strange? I'm going to start a new thread to try to find the answer to this.
 
Old 02-12-2009, 09:22 PM   #12
Saptech
Member
 
Registered: Nov 2000
Location: Third Stone from the Sun
Distribution: Sourcemage
Posts: 132

Rep: Reputation: 19
I don't have nothing but /, swap & dvd drive listed in my fstab and everytime I load my usb external hard drive, I see it using a filemanager. If I click on it, it opens a window to display the contents.

I'm using openbox wm, so I guess that is why no icon pops up on the desktop, there aren't any icons on desktop.

I believe gnome-volume-manager is giving it access.
 
Old 02-12-2009, 10:21 PM   #13
bezdomny
Member
 
Registered: May 2006
Location: North-Central California
Distribution: Debian Lenny
Posts: 154

Rep: Reputation: 30
automount

Saptech, thanks. I found the solution and to avoid a duplicate posting which I know the admins hate, I'll simply place a link to it here.

Thanks again, Saptech.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
automount external USB drive unknownmosquito Linux - Hardware 5 06-08-2007 06:39 PM
USB Flash Drive will not automount drlinux VectorLinux 6 04-19-2007 05:47 PM
automount of usb drive konramesh Linux - Hardware 1 12-02-2006 11:16 PM
Automount 2nd Drive in Gnome CooManChu Linux - Newbie 4 01-09-2005 11:58 AM
automount cd and usb memory in gnome 2.8 testing sarge with gnome-volume-manager gvm pevelius Debian 0 12-20-2004 03:15 AM


All times are GMT -5. The time now is 01:49 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration