LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 09-15-2005, 10:07 PM   #1
salahuddin_66
Member
 
Registered: Jan 2004
Location: Dhaka, Bangladesh
Distribution: Debian, Gentoo
Posts: 283

Rep: Reputation: 30
Question upgrade probem


apt-get upgrade

or

apt-get dist-upgrade

do not working for me.

it shows
Code:
Need to get 0B/302MB of archives.
After unpacking 17.7MB of additional disk space will be used.
E: This installation run will require temporarily removing the essential package e2fsprogs due to a Conflicts/Pre-Depends loop. This is often bad, but if you really want to do it, activate the APT::Force-LoopBreak option.
E: Internal Error, Could not early remove e2fsprogs
many days ago i hav moved to debian sid.

and yesterday i install debian from my testing installation cd (fresh install) (when sarge was testing). and i can't install any softwares for it.

need help.
 
Old 09-16-2005, 04:43 AM   #2
doc.nice
Member
 
Registered: Oct 2004
Location: Germany
Distribution: Debian
Posts: 274

Rep: Reputation: 34
This means, there is a cyclic dependency in your packages, I had this problem too,
the apt manual says you have to set/add
Code:
APT::Force-LoopBreak "On";
in your /etc/apt/apt.conf and then run apt-get install.

Don't forget to delete the entry afterwards (or set to "Off"), to re-enable this safety check.
Normally, those dependency problems must not occur (read man apt-get)

BTW:
If you get this Error while using any apt-related program:

Code:
EE: Dynamic MMap ran out of Room
EE: ....
you have to raise the value of APT::Cache-Limit in /etc/apt/apt.conf

HTH,
Flo
 
Old 09-16-2005, 10:07 PM   #3
salahuddin_66
Member
 
Registered: Jan 2004
Location: Dhaka, Bangladesh
Distribution: Debian, Gentoo
Posts: 283

Original Poster
Rep: Reputation: 30
Lightbulb

solved

thanx a lot.
 
Old 09-17-2005, 05:55 AM   #4
powadha
Member
 
Registered: Nov 2003
Distribution: Debian SID
Posts: 649

Rep: Reputation: 31
I had the same problem. Downloading and using a newer version of the installer (net-install) solved it. I guess some parts of the installer where outdated.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
dial-up probem | will not connect mkIIIman089 Linux - Networking 7 02-07-2006 08:57 PM
NTL broadband probem still!! djskywalker Linux - Networking 16 07-17-2005 06:50 PM
bash probem slackware 10 sethgeekx86 Slackware 6 07-01-2004 01:04 PM
Library probem toolshed Linux - Software 0 06-14-2004 08:29 AM
group permissions probem wedgeworth Linux - Software 1 09-25-2003 05:01 PM


All times are GMT -5. The time now is 09:15 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration