LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 05-12-2012, 04:41 AM   #1
anunix
LQ Newbie
 
Registered: Jul 2010
Posts: 6

Rep: Reputation: 0
Upgrade and dist-upgrade problem reinstall aMule end packare libupnp6


Ciao. Sorry for my English.

I have Debian Testing amd64, Kernel:3.1.0-1-amd64
Yesterday I updated Debian testing, since I had left the package on hold I forced the upgrade with: "Dist-upgrade" but I will be following error:
Code:
- Upgrade del 11-05-2012- ore:12:10 -

Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
I seguenti pacchetti sono stati mantenuti alla versione attuale:
  amule amule-common exiv2 geeqie geeqie-common gthumb mencoder mplayer
  ufraw-batch
I seguenti pacchetti saranno aggiornati:
  libcrystalhd3 libfaac0 libjack-jackd2-0 libjtidy-java libmp4v2-1 libphonon4
  libpulse-mainloop-glib0 libpulse0 libqt4-dbus libqt4-declarative
  libqt4-designer libqt4-help libqt4-network libqt4-opengl libqt4-qt3support
  libqt4-script libqt4-scripttools libqt4-sql libqt4-sql-mysql libqt4-svg
  libqt4-test libqt4-xml libqt4-xmlpatterns libqtcore4 libqtgui4 libslang2
  libsqlite3-0 libupower-glib1 libxxf86vm1 mpg321 mplayer2 phonon python-qt4
  python-qt4-dbus qdbus qt4-qtconfig upower x11-apps x11-utils x11-xfs-utils
  x11-xkb-utils
41 aggiornati, 0 installati, 0 da rimuovere e 9 non aggiornati.
 necessario scaricare 36,0 MB di archivi.
Dopo quest'operazione, verranno occupati 1282 kB di spazio su disco.
#apt-get dist-upgrade
Code:
Lettura informazioni sullo stato... Fatto
Calcolo dell'aggiornamento... Eseguito
I seguenti pacchetti saranno RIMOSSI:
  amule
I seguenti pacchetti NUOVI saranno installati:
  libexiv2-12 libx264-124
I seguenti pacchetti saranno aggiornati:
  amule-common exiv2 geeqie geeqie-common gthumb mencoder mplayer ufraw-batch
8 aggiornati, 2 installati, 1 da rimuovere e 0 non aggiornati.
 necessario scaricare 19,8 MB di archivi.
Dopo quest'operazione, verranno liberati 854 kB di spazio su disco.
If I try to reinstall amule me:
Code:
apt-get install amule
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Alcuni pacchetti non possono essere installati. Questo pu voler dire
che  stata richiesta una situazione impossibile oppure, se si sta
usando una distribuzione in sviluppo, che alcuni pacchetti richiesti
non sono ancora stati creati o sono stati rimossi da Incoming.
Le seguenti informazioni possono aiutare a risolvere la situazione:

I seguenti pacchetti hanno dipendenze non soddisfatte:
 amule : Dipende: libupnp6 (>= 1:1.6.13) ma non sta per essere installato
E: Pacchetti danneggiati
I can not install the package manually with dpkg "libupnp6 (> = 1:1.6.13)" nor with aptitude.

Put my sources.list:
Code:
# deb cdrom:[Debian GNU/Linux testing _Wheezy_ - Official Snapshot amd64 CD Binary-1 20111128-04:47]/ wheezy main

#deb cdrom:[Debian GNU/Linux testing _Wheezy_ - Official Snapshot amd64 CD Binary-1 20111128-04:47]/ wheezy main

deb http://ftp.ch.debian.org/debian/ wheezy main contrib non-free
deb-src http://ftp.ch.debian.org/debian/ wheezy main contrib non-free

##Aggiornamenti della sicurezza
deb http://security.debian.org/ wheezy/updates main contrib
deb-src http://security.debian.org/ wheezy/updates main contrib

## Binari per wheezy (testing) Architetture: amd64, i386, sparc
deb http://www.debian-multimedia.org wheezy main non-free

#experimental
#deb http://ftp.it.debian.org/debian/ experimental main contrib non-free
The question is:
How can I do reinstall amule?

Thanks

Last edited by anunix; 05-12-2012 at 04:42 AM.
 
Old 05-12-2012, 09:06 AM   #2
odiseo77
Member
 
Registered: Dec 2004
Location: London, UK
Distribution: Debian Sid, OpenSUSE 13.1
Posts: 992

Rep: Reputation: 294Reputation: 294Reputation: 294
Package libupnp6-1:1.6.17-1.1 seems to be in Wheezy, judging from this. Have you tried running apt-get update and then attempting to install libupnp6?:

Code:
apt-get update
apt-get install libupnp6
If it does get installed, I guess amule will install fine afterwards.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Upgrade and dist-upgrade problem reinstall aMule end packare libupnp6 anunix Debian 2 05-12-2012 01:36 PM
Wireless switch doesn't work after upgrade/dist-upgrade angelofhope Debian 10 01-02-2008 04:46 AM
Will 'aptitude upgrade or dist-upgrade' downgrade manually installed deb package? Akhran Debian 3 03-14-2006 02:40 PM


All times are GMT -5. The time now is 11:27 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration