LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   updating libc6 w/o upgrading (http://www.linuxquestions.org/questions/debian-26/updating-libc6-w-o-upgrading-808459/)

Dutch Master 05-17-2010 07:10 PM

updating libc6 w/o upgrading
 
I run Etch. Yes, it's oldstable, but Lenny and Squeeze annoy the heck out of me. However, I'm trying to install the latest version (5.1) of Google Earth, but it requires >=glibc-2.4. Etch only offers 2.3.something. The earlier version of GE I have (4.3) does work, but is apparently no longer supported by Google as it fails to connect every time I fire it up. I found Lenny does have the required libc6 version. Can I update the libc6 packages by installing them directly (separately downloaded packages) or do I get the dependency hell that I want to avoid? Pointers are welcome! :)

AlucardZero 05-17-2010 08:00 PM

You get hell.

craigevil 05-17-2010 08:02 PM

You get worse than hell. libc6 is a required package, damn near every other package depends on it in one way or another.

Come play in the pool with the big kids, install Sid. :)

Dutch Master 05-17-2010 08:57 PM

Just as I thought... Thx chaps, much appreciated warning :)

@craigevil: if I dislike Lenny and Squeeze, what's the odds for me liking Sid ;) Major reasons for my disliking said releases is the rubbish that is Grub2 and the ever increasing dependencies of basic core-apps to completely irrelevant auxiliary features.... One of my pet-hates is the dependency-chain of gnome-core to the 'energy-saving' stuff, shutting off the screen while watching a DVD not in full screen mode. I just can't remove the lib that makes this happen, it chain-depends gnome-core with it... It's so bad I even contemplated re-compiling Gnome from scratch, just to get it out! Frankly, I suspect the present Sid will be even worse in that respect, once released...

Anyway, thanks again chaps!

Dutch Master 05-17-2010 09:25 PM

Just to re-itterate about the dependency stuff going over the top: I decided to have a look at the control files of the libc6 package in Lenny. After following several dependencies I found that the libmpfr1ldbl package is listed as a dependency by cpp-4.3, but in the control file for the libmpfr1ldbl package it's listed as optional! Same goes for the libgmp3c2 package, equally required by cpp-4.3, but marked optional in it's control file... But I might be missing something?


All times are GMT -5. The time now is 11:18 AM.