LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 09-04-2007, 02:08 PM   #1
maikie
LQ Newbie
 
Registered: Sep 2007
Posts: 3

Rep: Reputation: 0
Unmet dependencies.


no matter what i try and do i always get Unmet dependencies.

I am trying to install xorg on my system. But when i try i am getting this.

Code:
debian:~# apt-get install xorg
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
  binutils: Depends: libc6 (>= 2.6-1) but 2.3.2.ds1-22sarge6 is to be installed
  libc6-dev: Depends: libc6 (= 2.6.1-1+b1) but 2.3.2.ds1-22sarge6 is to be installed
  locales: Depends: glibc-2.6-1
  xorg: Depends: xserver-xorg
        Depends: libglu1-mesa but it is not going to be installed
        Depends: xfonts-base (>= 1:1.0.0-1) but it is not going to be installed
        Depends: xfonts-100dpi (>= 1:1.0.0-1) but it is not going to be installed
        Depends: xfonts-75dpi (>= 1:1.0.0-1) but it is not going to be installed
        Depends: xfonts-scalable (>= 1:1.0.0-1) but it is not going to be installed
        Depends: xbase-clients (>= 1:1.0.1-1) but 4.3.0.dfsg.1-14sarge4 is to be installed
        Depends: xutils (>= 1:1.0.1-1) but it is not going to be installed
        Depends: xkb-data but it is not going to be installed
        Depends: sparc-utils but it is not installable or
                 not+sparc
        Depends: xorg-docs but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
So, i try what it says and....

Code:
debian:~# apt-get -f install
Reading Package Lists... Done
Building Dependency Tree... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libc6
Suggested packages:
  glibc-doc
The following packages will be upgraded:
  libc6
1 upgraded, 0 newly installed, 0 to remove and 681 not upgraded.
3 not fully installed or removed.
Need to get 0B/4405kB of archives.
After unpacking 4985kB disk space will be freed.
Do you want to continue? [Y/n] y
debconf: unable to initialize frontend: Gnome
debconf: (Unable to load Gnome -- is libgnome2-perl installed?)
debconf: falling back to frontend: Dialog
(Reading database ... 78329 files and directories currently installed.)
Preparing to replace libc6 2.3.2.ds1-22sarge6 (using .../libc6_2.6.1-1+b1_i386.deb) ...

Name Service Switch update in the C Library: pre-installation question.

Running services and programs that are using NSS need to be restarted,
otherwise they might not be able to do lookup or authentication any more.
The installation process is able to restart some services (such as ssh or
telnetd), but other programs cannot be restarted automatically.  One such
program that needs manual stopping and restart after the glibc upgrade by
yourself is xdm - because automatic restart might disconnect your active
X11 sessions.

Known packages that need to be stopped before the glibc upgrade are:
        xdm kdm gdm postgresql xscreensaver

This script detected the following installed services which must be
stopped before the upgrade:
        gdm

If you want to interrupt the upgrade now and continue later, please
answer No to the question below.

Do you want to upgrade glibc now? [Y/n] y

readlink: invalid option -- e
Try `readlink --help' for more information.
readlink: invalid option -- e
Try `readlink --help' for more information.
readlink: invalid option -- e
Try `readlink --help' for more information.
readlink: invalid option -- e
Try `readlink --help' for more information.
readlink: invalid option -- e
Try `readlink --help' for more information.
readlink: invalid option -- e
Try `readlink --help' for more information.
readlink: invalid option -- e
Try `readlink --help' for more information.
readlink: invalid option -- e
Try `readlink --help' for more information.
readlink: invalid option -- e
Try `readlink --help' for more information.
WARNING: POSIX threads library NPTL requires kernel version
2.6.8 or later. If you use a kernel 2.4, please upgrade it
before installing glibc.

The installation of a 2.6 kernel _could_ ask you to install a new libc
first, this is NOT a bug, and should *NOT* be reported. In that case,
please add etch sources to your /etc/apt/sources.list and run:
  apt-get install -t etch linux-image-2.6
Then reboot into this new kernel, and proceed with your upgrade
dpkg: error processing /var/cache/apt/archives/libc6_2.6.1-1+b1_i386.deb (--unpack):
 subprocess pre-installation script returned error exit status 1
Errors were encountered while processing:
 /var/cache/apt/archives/libc6_2.6.1-1+b1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
I am unable to install xorg. I have tried all that i know and looking around turned up nothing. I have tried like apt-get update, upgrade and aptitude update etc.

Thank you
 
Old 09-04-2007, 02:57 PM   #2
Junior Hacker
Senior Member
 
Registered: Jan 2005
Location: North America
Distribution: Debian testing Mandriva Ubuntu
Posts: 2,687

Rep: Reputation: 59
Which version of Debian are you running? What does your /etc/apt/sources.list look like?
I usually install a naked Debian testing by deselecting everything in tasksel except for "standard system", then I install the x-window-system and KDE etc., all off the DVD as I'm on dial up and the modem drivers get built after I've got a desktop. Below are the steps I take:
Code:
apt-get install x-window-system (press enter)
apt-get install alsa alsa-utils (press enter)
apt-get install kde-core synaptic libgnome2-perl mozilla-firefox gnome-system-tools kdm (press enter)
apt-get install pmount hal usbmount (press enter)
/etc/init.d/kdm start

Last edited by Junior Hacker; 09-04-2007 at 03:05 PM.
 
Old 09-04-2007, 03:19 PM   #3
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,231
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
Are you forgetting to run apt-get update before trying to install new packages ?
 
Old 09-04-2007, 03:25 PM   #4
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 52
Could it be that you try to install xorg on Sarge?
 
Old 09-04-2007, 04:46 PM   #5
maikie
LQ Newbie
 
Registered: Sep 2007
Posts: 3

Original Poster
Rep: Reputation: 0
None of that above worked junior hacker, i was gettin this.

Code:
debian:~# apt-get install x-window-system
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
  binutils: Depends: libc6 (>= 2.6-1) but 2.3.2.ds1-22sarge6 is to be installed
  libc6-dev: Depends: libc6 (= 2.6.1-1+b1) but 2.3.2.ds1-22sarge6 is to be installed
  locales: Depends: glibc-2.6-1
  x-window-system: Depends: xorg but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
farslayer, yes i have been running apt-get update.

nx5000, yes it is sarge.

But i think its a little past that now. No matter what i try and do ie the apt-get.
I ALWAYS get that Unmet dependencies.
 
Old 09-04-2007, 04:53 PM   #6
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 63
Quote:
Originally Posted by maikie View Post
None of that above worked junior hacker, i was gettin this.

Code:
debian:~# apt-get install x-window-system
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
  binutils: Depends: libc6 (>= 2.6-1) but 2.3.2.ds1-22sarge6 is to be installed
  libc6-dev: Depends: libc6 (= 2.6.1-1+b1) but 2.3.2.ds1-22sarge6 is to be installed
  locales: Depends: glibc-2.6-1
  x-window-system: Depends: xorg but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
farslayer, yes i have been running apt-get update.

nx5000, yes it is sarge.

But i think its a little past that now. No matter what i try and do ie the apt-get.
I ALWAYS get that Unmet dependencies.
Of course you get them your trying to install a package that is not intended for your system by having a mixed branch setup in your sources.list. If you want to use Xorg then comment out the line(s) for Sarge in your sources.list then update and apt-get dist-upgrade to move to the new distribution now try to install Xorg on the system it was intended for.

Edit: And if I remember correctly you should purge the xserver-xfree86 package(s) before attempting the dist-upgrade as it will cause problems then install Xorg once the upgrade is completed.

Last edited by HappyTux; 09-04-2007 at 04:56 PM.
 
Old 09-04-2007, 05:11 PM   #7
maikie
LQ Newbie
 
Registered: Sep 2007
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks tux. Well, i updated the source.list i done what you said. I am still getting the same errors.

Code:
debian:~# apt-get dist-upgrade
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
  binutils: Depends: libc6 (>= 2.6-1) but 2.3.2.ds1-22sarge6 is installed
  libc6-dev: Depends: libc6 (= 2.6.1-2) but 2.3.2.ds1-22sarge6 is installed
  locales: Depends: glibc-2.6-1
E: Unmet dependencies. Try using -f.
When i run apt-get -f install it does more, like it is downloading the software but, i get to the part when it says:

Code:
 This script detected the following installed services which must be
stopped before the upgrade:
        gdm

If you want to interrupt the upgrade now and continue later, please
answer No to the question below.

Do you want to upgrade glibc now? [Y/n] y
I say yes and it then says:

Code:
The installation of a 2.6 kernel _could_ ask you to install a new libc
first, this is NOT a bug, and should *NOT* be reported. In that case,
please add etch sources to your /etc/apt/sources.list and run:
  apt-get install -t etch linux-image-2.6
Then reboot into this new kernel, and proceed with your upgrade
dpkg: error processing /var/cache/apt/archives/libc6_2.6.1-2_i386.deb (--unpack):
 subprocess pre-installation script returned error exit status 1
Errors were encountered while processing:
 /var/cache/apt/archives/libc6_2.6.1-2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Thank you all.
 
Old 09-04-2007, 05:30 PM   #8
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 63
Quote:
Originally Posted by maikie View Post
Thanks tux. Well, i updated the source.list i done what you said. I am still getting the same errors.

Code:
debian:~# apt-get dist-upgrade
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
  binutils: Depends: libc6 (>= 2.6-1) but 2.3.2.ds1-22sarge6 is installed
  libc6-dev: Depends: libc6 (= 2.6.1-2) but 2.3.2.ds1-22sarge6 is installed
  locales: Depends: glibc-2.6-1
E: Unmet dependencies. Try using -f.
When i run apt-get -f install it does more, like it is downloading the software but, i get to the part when it says:

Code:
 This script detected the following installed services which must be
stopped before the upgrade:
        gdm

If you want to interrupt the upgrade now and continue later, please
answer No to the question below.

Do you want to upgrade glibc now? [Y/n] y
I say yes and it then says:

Code:
The installation of a 2.6 kernel _could_ ask you to install a new libc
first, this is NOT a bug, and should *NOT* be reported. In that case,
please add etch sources to your /etc/apt/sources.list and run:
  apt-get install -t etch linux-image-2.6
Then reboot into this new kernel, and proceed with your upgrade
dpkg: error processing /var/cache/apt/archives/libc6_2.6.1-2_i386.deb (--unpack):
 subprocess pre-installation script returned error exit status 1
Errors were encountered while processing:
 /var/cache/apt/archives/libc6_2.6.1-2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Thank you all.
Usually that error (1) is an overwrite problem was that all the message? Try dpkg -i --force-overwrite /var/cache/apt/archives/libc6_2.6.1-2_i386.deb to fix the overwrite then install/reboot into the linux-image-2.6.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
unmet dependencies Josephus Ross Linux - General 10 08-21-2007 12:49 PM
Amarok unmet dependencies erpe Debian 4 04-25-2006 02:23 AM
apt-get unmet dependencies, etc. knappster Linux - Software 13 12-14-2005 10:06 PM
unmet dependencies kpachopoulos Debian 3 11-23-2005 10:35 AM
apt-get unmet dependencies jeffbarish Debian 9 10-27-2005 12:19 AM


All times are GMT -5. The time now is 08:43 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration