View the Most Wanted LQ Wiki articles.
Go Back > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Debian This forum is for the discussion of Debian Linux.


  Search this Thread
Old 10-01-2006, 09:01 PM   #1
Registered: Feb 2006
Distribution: CentOS
Posts: 114

Rep: Reputation: 15
uninstalling glib-2.0

how would i go about uninstalling glib-2.0? i installed the newer version of glib and have the following error now:

checking for GLIB - version >= 2.12.0...
*** 'pkg-config --modversion glib-2.0' returned 2.12.0, but GLIB (2.12.3)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
configure: error:
*** GLIB 2.12.0 or better is required. The latest version of
*** GLIB is always available from
Old 10-02-2006, 02:10 AM   #2
LQ Newbie
Registered: Oct 2003
Location: south africa
Distribution: ubuntu (Dapper Drake)
Posts: 12

Rep: Reputation: 0
That depends on where your "other" version of glib came from. I see that this is a forum for discussing Debian -- so if you have this problem from packages, that's just wierd. If you have this problem from compiling up glib from source, without cleaning out prior versions, well, that's where your problem is.

The debian route would be to use dpkg --purge to totally remove the offending package. But then dpkg will also want to remove other things in addition. Try checking out the --force options: there is a way that apt can force a package removal irrespective of dependencies: it has to in some circumstances.

If your older version of glib comes from a source package, you could either "make uninstall" from that package's source directory, or you will have to hunt down the issue manually. A tool that will help you with the latter (but will require a lot of reading and patience) is strace. If you can place a trace on the command that produces the error you see below, you will be able to check on all files that are touched by the script, and hence, perhaps find your problem and kill it.
Old 10-02-2006, 04:51 AM   #3
Registered: Dec 2004
Location: Malta
Distribution: Debian Sid
Posts: 790

Rep: Reputation: 43
This is probably deliberate. Some packages need a particular version of glib to compile.

There's an environment variable to set if you bump into this problem -it's documented in the error message.

If you installed using Debian packages then you can just uninstall the old version. It will be listed separately in the list of installed packages.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Uninstalling glib BeaverusIV Linux - Software 3 03-08-2006 08:44 PM
pkg-config and glib: Uninstalling Old and Installing New CooManChu Linux - Software 6 09-06-2005 04:35 PM
Uninstalling glib 2.6.0 tommygoober Linux - Software 3 02-28-2005 12:43 AM
Uninstalling glib warkrime Linux - Newbie 4 07-16-2003 01:29 AM

All times are GMT -5. The time now is 01:42 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration