LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 09-11-2007, 10:36 PM   #16
indienick
Senior Member
 
Registered: Dec 2005
Location: London, ON, Canada
Distribution: Arch, Ubuntu, Slackware, OpenBSD, FreeBSD
Posts: 1,853

Rep: Reputation: 65

When it worked initially, were you running Etch or Lenny/Sid?

I "updated" to Lenny/Sid a while ago, and I've been getting a little ticked with some of the "fine-tuning" (e.g. forceful downgrading) I've had to do, due to package conflicts, and some things just plain not working.

farslayer:
You've given me an idea - two of my friends have MacBooks (which come standard with firewire - Apple actually recommends it to USB). I should score a firewire cable somewhere and see if I can network two or three laptops together via firewire. It would be fast, but I don't see a long-term, pragmatic use for it.
 
Old 09-11-2007, 11:57 PM   #17
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,231
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
Well Etch can have a way of assigning the ethernet interfaces different names on reboot... shuffling them back and forth or having the interface name increase in number on each reboot. I wonder if yours are switching back and forth as you reboot your machine.

If the problem turns out to be the interface name switching you can write a udev rule to tie the eth1 interface to the MAC address of your NIC card so it will stick..

so if you do the basic checks again does your NIC still show up definaed as eth1 ?

Quote:
cat /var/log/messages | grep eth
Sep 9 18:01:10 debianetch kernel: e100: eth0: e100_probe: addr 0xfeafe000, irq 201, MAC addr 00:0C:F1:F5:1A:E2
Sep 9 18:01:10 debianetch kernel: eth1394: eth0: IEEE-1394 IPv4 over 1394 Ethernet (fw-host0)
Sep 9 18:01:10 debianetch kernel: e100: eth1: e100_watchdog: link up, 100Mbps, full-duplex

cat /var/log/dmesg | grep eth

e100: eth0: e100_probe: addr 0xfeafe000, irq 201, MAC addr 00:0C:F1:F5:1A:E2
eth1394: eth0: IEEE-1394 IPv4 over 1394 Ethernet (fw-host0)
e100: eth1: e100_watchdog: link up, 100Mbps, full-duplex
Isn't it special how it sees both interfaces as eth0 then brings the NIC up as eth1 ?
I really should just blacklist that eth1394 driver

Last edited by farslayer; 09-12-2007 at 12:06 AM.
 
Old 09-12-2007, 05:50 AM   #18
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 52
Quote:
Originally Posted by farslayer View Post
Well Etch can have a way of assigning the ethernet interfaces different names on reboot... shuffling them back and forth or having the interface name increase in number on each reboot. I wonder if yours are switching back and forth as you reboot your machine.
Did you see this?
I don't understand how this can happen because it uses a persistent naming. Last time I was also surprised about the result of kushowall (dunno if you remember).
There is already a persistent net generator and it won't overwrite already defined interfaces. I'm still wondering if I understand the concept correctly.
What I'm sure is that I never got any renaming.

I don't see why having eth/firewire is so annoying. It gets assigned eth0. Well, then use eth1 for your real ethernet. Why do people absolutly want eth0? I don't get it
Maybe because using NetworkManager? I don't use it, it always bring me trouble and I am strongly opposed to GUI modifying my SYSTEM preferences. Also if you get an error in your video driver or xorg and you can't start Xwindow, you will need to access internet in CLI, and then you are a bit lost I guess.

Quote:
cat /var/log/messages | grep eth
Sep 9 18:01:10 debianetch kernel: e100: eth0: e100_probe: addr 0xfeafe000, irq 201, MAC addr 00:0C:F1:F5:1A:E2
Sep 9 18:01:10 debianetch kernel: eth1394: eth0: IEEE-1394 IPv4 over 1394 Ethernet (fw-host0)
Sep 9 18:01:10 debianetch kernel: e100: eth1: e100_watchdog: link up, 100Mbps, full-duplex
Now that's strange yes, there should be something "renaming eth0 to eth1". Sometimes it's done in the initrd and you don't always get a log.

For the OP, maybe do it manually?
Stop VMWARE
Switch to root
ifdown eth0
ifdown eth1
route -n should be empty.
It looks like eth1 is your real connection.
So be sure that your /etc/network/interfaces is consistent:
Quote:
auto eth1
iface eth1 inet dhcp
then
ifup eth1
and check
route -n
ifconfig -a
If you get an IP but no default route, then their dhcp server has a problem. Do not force it because yes, it could change if you get another block.
Then check /etc/resolv.conf
 
Old 09-12-2007, 07:48 AM   #19
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,231
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
Quote:
Originally Posted by nx5000 View Post
Did you see this?
I don't understand how this can happen because it uses a persistent naming. Last time I was also surprised about the result of kushowall (dunno if you remember).
There is already a persistent net generator and it won't overwrite already defined interfaces. I'm still wondering if I understand the concept correctly.
What I'm sure is that I never got any renaming.
Looks like you may be right.. the interfaces coming up different, eth0 and eth1 swapping places, seems to be a pre-etch issue when using udev.. http://www.debian-administration.org/articles/463

I stand corrected.. not the last time that's going to happen for sure


here's a post on the ever increasing eth(x) number. Looking at the solution one has to wonder what the BIOS manufacturer was thinking.
http://www.debianhelp.org/node/9481
 
Old 09-12-2007, 08:10 AM   #20
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 52
Quote:
here's a post on the ever increasing eth(x) number. Looking at the solution one has to wonder what the BIOS manufacturer was thinking.
http://www.debianhelp.org/node/9481
lol, really funny.
Good for crackers, they don't have to change their adress!
For privacy reasons. Hum yeah but what happens if two cards get the same. The address space is 2^(8*6) so very unlikely. Imagine if internet core routers were using nForce cards...

Yes udev should take care of this now.

If you blacklist the firewire module then I think you also need to:
rm /etc/udev/rules.d/z25_persistent-net.rules
&
reboot
 
Old 09-13-2007, 10:20 AM   #21
WolfCub
Member
 
Registered: Nov 2003
Location: Canada
Distribution: Debian
Posts: 175

Original Poster
Rep: Reputation: 30
Any ideas guys? I'm without internet still. Indienick, you live in London right? Are you a computer repair guy?
 
Old 09-13-2007, 11:32 AM   #22
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,231
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
So while it's non-working again.. is it the same error ? have you shutdown vmware ?

have you verified the settings it gave you ?
ifconfig -a - Check network addresses
cat /etc/resolv.conf - Check for DNS Server entries

Did you manually add a default gateway last time ? is there a default gateway assigned ?
route -n - Check routes and default gateway

Check for Errors, or interface name changes
cat /var/log/dmesg | grep eth
cat /var/log/messages | grep eth

what is the status of the network interface..
ethtool eth1

Did you shut down any and all other network interfaces you are not using ? (other Ethernet interfaces, wireless interfaces, etc.. )

if you get it working again. do all these things and Copy down the settings.
when it's not working do all these things and see what is different or missing.

Troubleshooting is a matter of eliminating what is not the problem until you locate what is causing the issue. that's why I'm saying to shut down all that stuff that is not necessary for your connection and could be part of the reason it's not working..
 
Old 09-13-2007, 04:26 PM   #23
indienick
Senior Member
 
Registered: Dec 2005
Location: London, ON, Canada
Distribution: Arch, Ubuntu, Slackware, OpenBSD, FreeBSD
Posts: 1,853

Rep: Reputation: 65
I do live in London, and for as long as I can remember I've been the family computer repair guy.
 
Old 09-14-2007, 09:22 AM   #24
WolfCub
Member
 
Registered: Nov 2003
Location: Canada
Distribution: Debian
Posts: 175

Original Poster
Rep: Reputation: 30
Ok farslayer, thanks for telling me what info you need. It seems to not work whether vmware runs or not. It is working again at the moment, so here's everything you asked for:

ifconfig -a

Code:
eth1      Link encap:Ethernet  HWaddr 00:1B:FC:B3:0C:6C
          inet addr:129.100.196.15  Bcast:129.100.196.255  Mask:255.255.255.0
          inet6 addr: fe80::21b:fcff:feb3:c6c/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:16012 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8093 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:18580520 (17.7 MiB)  TX bytes:665315 (649.7 KiB)
          Interrupt:16

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:16 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:800 (800.0 b)  TX bytes:800 (800.0 b)
cat /etc/resolv.conf

Code:
debian:~# cat /etc/resolv.conf
# generated by NetworkManager, do not edit!

search smh.reznet.uwo.ca


nameserver 129.100.74.79
nameserver 129.100.2.51


debian:~#
route -n

Code:
debian:~# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
129.100.196.0   0.0.0.0         255.255.255.0   U     0      0        0 eth1
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 eth1
0.0.0.0         129.100.196.1   0.0.0.0         UG    0      0        0 eth1
debian:~#
cat /var/log/dmesg | grep eth

Code:
debian:~# cat /var/log/dmesg | grep eth
sky2 eth0: addr 00:1b:fc:b3:0c:6c
udev: renamed network interface eth0 to eth1
sky2 eth1: enabling interface
sky2 eth1: ram buffer 0K
sky2 eth1: Link is up at 10 Mbps, full duplex, flow control rx
debian:~#
cat /var/log/dmesg | grep eth

Code:
debian:~# cat /var/log/dmesg | grep eth
sky2 eth0: addr 00:1b:fc:b3:0c:6c
udev: renamed network interface eth0 to eth1
sky2 eth1: enabling interface
sky2 eth1: ram buffer 0K
sky2 eth1: Link is up at 10 Mbps, full duplex, flow control rx
debian:~# cat /var/log/messages | grep eth
Sep 14 16:41:09 debian kernel: sky2 eth1: disabling interface
Sep 14 17:11:42 debian kernel: sky2 eth0: addr 00:1b:fc:b3:0c:6c
Sep 14 17:11:42 debian kernel: udev: renamed network interface eth0 to eth1
Sep 14 17:11:42 debian kernel: sky2 eth1: enabling interface
Sep 14 17:11:42 debian kernel: sky2 eth1: ram buffer 0K
Sep 14 17:11:42 debian kernel: sky2 eth1: Link is up at 10 Mbps, full duplex, flow control rx
Sep 14 17:11:54 debian dhcdbd: message_handler: message handler not found under /com/redhat/dhcp/eth1 for sub-path eth1.dbus.get.reason
Sep 14 17:11:54 debian kernel: bridge-eth1: already up
Sep 14 17:11:55 debian kernel: wlan0: ethernet device 00:13:e8:29:cc:f3 using NDIS driver: netw4x32, version: 0x56, NDIS version: 0x501, vendor: 'Intel(R) Wireless WiFi Link 4965AG Driver', 8086:4229.5.conf
Sep 14 17:12:08 debian dhcdbd: message_handler: message handler not found under /com/redhat/dhcp/eth1 for sub-path eth1.dbus.get.host_name
Sep 14 17:12:08 debian dhcdbd: message_handler: message handler not found under /com/redhat/dhcp/eth1 for sub-path eth1.dbus.get.nis_domain
Sep 14 17:12:08 debian dhcdbd: message_handler: message handler not found under /com/redhat/dhcp/eth1 for sub-path eth1.dbus.get.nis_servers
Sep 14 17:29:42 debian kernel: sky2 eth1: disabling interface
Sep 14 17:30:55 debian kernel: sky2 eth0: addr 00:1b:fc:b3:0c:6c
Sep 14 17:30:55 debian kernel: udev: renamed network interface eth0 to eth1
Sep 14 17:30:55 debian kernel: sky2 eth1: enabling interface
Sep 14 17:30:55 debian kernel: sky2 eth1: ram buffer 0K
Sep 14 17:30:55 debian kernel: sky2 eth1: Link is up at 10 Mbps, full duplex, flow control rx
Sep 14 17:31:09 debian dhcdbd: message_handler: message handler not found under /com/redhat/dhcp/eth1 for sub-path eth1.dbus.get.reason
Sep 14 17:31:09 debian kernel: bridge-eth1: already up
Sep 14 17:31:11 debian kernel: wlan0: ethernet device 00:13:e8:29:cc:f3 using NDIS driver: netw4x32, version: 0x56, NDIS version: 0x501, vendor: 'Intel(R) Wireless WiFi Link 4965AG Driver', 8086:4229.5.conf
Sep 14 17:31:24 debian dhcdbd: message_handler: message handler not found under /com/redhat/dhcp/eth1 for sub-path eth1.dbus.get.host_name
Sep 14 17:31:24 debian dhcdbd: message_handler: message handler not found under /com/redhat/dhcp/eth1 for sub-path eth1.dbus.get.nis_domain
Sep 14 17:31:24 debian dhcdbd: message_handler: message handler not found under /com/redhat/dhcp/eth1 for sub-path eth1.dbus.get.nis_servers
Sep 14 17:35:16 debian kernel: sky2 eth1: disabling interface
Sep 15 03:36:38 debian kernel: sky2 eth0: addr 00:1b:fc:b3:0c:6c
Sep 15 03:36:38 debian kernel: udev: renamed network interface eth0 to eth1
Sep 15 03:36:38 debian kernel: sky2 eth1: enabling interface
Sep 15 03:36:38 debian kernel: sky2 eth1: ram buffer 0K
Sep 15 03:36:38 debian kernel: sky2 eth1: Link is up at 10 Mbps, full duplex, flow control rx
Sep 15 03:36:49 debian dhcdbd: message_handler: message handler not found under /com/redhat/dhcp/eth1 for sub-path eth1.dbus.get.reason
Sep 15 03:36:50 debian kernel: bridge-eth1: already up
Sep 15 03:36:51 debian kernel: wlan0: ethernet device 00:13:e8:29:cc:f3 using NDIS driver: netw4x32, version: 0x56, NDIS version: 0x501, vendor: 'Intel(R) Wireless WiFi Link 4965AG Driver', 8086:4229.5.conf
Sep 15 03:37:06 debian dhcdbd: message_handler: message handler not found under /com/redhat/dhcp/eth1 for sub-path eth1.dbus.get.host_name
Sep 15 03:37:06 debian dhcdbd: message_handler: message handler not found under /com/redhat/dhcp/eth1 for sub-path eth1.dbus.get.nis_domain
Sep 15 03:37:06 debian dhcdbd: message_handler: message handler not found under /com/redhat/dhcp/eth1 for sub-path eth1.dbus.get.nis_servers
Sep 15 03:37:52 debian kernel: sky2 eth1: disabling interface
Sep 15 16:07:43 debian kernel: sky2 eth0: addr 00:1b:fc:b3:0c:6c
Sep 15 16:07:43 debian kernel: udev: renamed network interface eth0 to eth1
Sep 15 16:07:43 debian kernel: sky2 eth1: enabling interface
Sep 15 16:07:43 debian kernel: sky2 eth1: ram buffer 0K
Sep 15 16:07:43 debian kernel: sky2 eth1: Link is up at 10 Mbps, full duplex, flow control rx
Sep 15 16:07:53 debian kernel: bridge-eth1: already up
Sep 15 16:07:53 debian dhcdbd: message_handler: message handler not found under /com/redhat/dhcp/eth1 for sub-path eth1.dbus.get.reason
Sep 15 16:07:54 debian kernel: wlan0: ethernet device 00:13:e8:29:cc:f3 using NDIS driver: netw4x32, version: 0x56, NDIS version: 0x501, vendor: 'Intel(R) Wireless WiFi Link 4965AG Driver', 8086:4229.5.conf
Sep 15 16:07:58 debian dhcdbd: message_handler: message handler not found under /com/redhat/dhcp/eth1 for sub-path eth1.dbus.get.host_name
Sep 15 16:07:58 debian dhcdbd: message_handler: message handler not found under /com/redhat/dhcp/eth1 for sub-path eth1.dbus.get.nis_domain
Sep 15 16:07:58 debian dhcdbd: message_handler: message handler not found under /com/redhat/dhcp/eth1 for sub-path eth1.dbus.get.nis_servers
ethtool eth1

Code:
debian:~# ethtool eth1
Settings for eth1:
        Supported ports: [ TP ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Advertised auto-negotiation: Yes
        Speed: 10Mb/s
        Duplex: Full
        Port: Twisted Pair
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
        Supports Wake-on: pg
        Wake-on: d
        Current message level: 0x000000ff (255)
        Link detected: yes
debian:~#
I think I added a gateway last time, but I'm not sure if it worked or if it was the right one. What should the gateway be, or how do I find out what it should be? I've tried with the wireless removed from /etc/network/interfaces, but it makes no difference. Vmware is the same way, doesn't seem to be the problem. Thanks for the help so far.
 
Old 09-14-2007, 09:27 AM   #25
WolfCub
Member
 
Registered: Nov 2003
Location: Canada
Distribution: Debian
Posts: 175

Original Poster
Rep: Reputation: 30
nx5000: I tried doing what you said when it still wasn't working, but I didn't have any success. I'm new to all this stuff. Anyway, I don't think their DHCP server could be having a problem, because all the guys on my floor can get online fine with Windows Vista. I assume it uses DHCP in the same way as Debain does. Thanks for trying though!
 
Old 09-14-2007, 10:54 AM   #26
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,231
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
Well your default gateway is already set.. as shown in the output of the route command

Code:
debian:~# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
129.100.196.0   0.0.0.0         255.255.255.0   U     0      0        0 eth1
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 eth1
0.0.0.0         129.100.196.1   0.0.0.0         UG    0      0        0 eth1
To verify it is correct look at the settings on one of your friends vista machines..
ipconfig /all should display all the network settings on a Windows machine.. I think that should still work on Vista..


That's baffling because everything appears as though it should work...
the IP addressing, DNS, Gateway, and routing table all look good to me..



This is interesting.. those error messages that are showing up in your log, appear as a BUG in Ubuntu.. but you said you were running debian.. I'm not quite sure the effect the bug has though, look like something to do with DNS resolution, which if that doesn't work, then you would have no web access..
https://bugs.launchpad.net/ubuntu/+s...dbd/+bug/93360


Did you try browsing by IP address again ?
google.com http://64.233.167.104
 
Old 09-14-2007, 11:32 AM   #27
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,231
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
hmm this is interesting too..
http://lkml.org/lkml/2007/6/21/254


how about we shutdown the interface, unload and reload the sky2 module then bring the interface back up and see if it works ?
 
Old 09-14-2007, 01:44 PM   #28
WolfCub
Member
 
Registered: Nov 2003
Location: Canada
Distribution: Debian
Posts: 175

Original Poster
Rep: Reputation: 30
Hey man. Okay, I got the information from a Windows Vista machine, http://img413.imageshack.us/img413/8...config1hq5.jpg

I cannot connect to google.com via IP addresses, and when I ping it, it says "network is unreachable". Also, ifdown eth1 and then rmmod sky2 followed by modprobe sky2 and ifup eth1 made no difference. Thanks for the ideas though. Hopefully there will be something in that image that I'm missing and you can tell me how to add it. Thanks again!
 
Old 09-14-2007, 02:00 PM   #29
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 52
I don't know this sky module so maybe farslayer has found something; meanwhile;

You said it doesn't work.. but WHERE?

Can you redo this and give us the results in bold

Stop VMWARE
Switch to root
ifdown eth0
ifdown eth1
route -n should be empty.

It looks like eth1 is your real connection.
So be sure that your /etc/network/interfaces contains this:

auto eth1
iface eth1 inet dhcp

and nothing else concerning eth1 !!

then
ifup eth1
Here you should see

DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 7
blablah
..
bound to 20.30.40.50 -- renewal in 1375 seconds

and check
route -n

ifconfig -a

now
ping your own IP adress
does it work
then
ping your default gateway (the bold line in farslayer previous post, take the gateway IP)
does it work


Let's forget about dns first
 
Old 09-14-2007, 04:35 PM   #30
WolfCub
Member
 
Registered: Nov 2003
Location: Canada
Distribution: Debian
Posts: 175

Original Poster
Rep: Reputation: 30
Hey. My internet will occasionally work on bootup. Upon reboot, it stops working. It stopped working today without a reboot after a few hours. I've been down for the vast majority of this week.

route -n

Code:
debian:~# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
debian:~#
ifup eth1

Code:
debian:~# ifup eth1
Internet Systems Consortium DHCP Client V3.0.6
Copyright 2004-2007 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth1/00:1b:fc:b3:0c:6c
Sending on   LPF/eth1/00:1b:fc:b3:0c:6c
Sending on   Socket/fallback
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 6
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 14
DHCPOFFER from 129.100.192.1
DHCPREQUEST on eth1 to 255.255.255.255 port 67
DHCPNAK from 129.100.192.1
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 7
DHCPOFFER from 129.100.192.1
DHCPREQUEST on eth1 to 255.255.255.255 port 67
DHCPNAK from 129.100.192.1
DHCPACK from 129.100.192.1
SIOCADDRT: No such process
bound to 129.100.193.162 -- renewal in 802 seconds.
route -n

Code:
debian:~# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
129.100.193.0   0.0.0.0         255.255.255.0   U     0      0        0 eth1
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 eth1
debian:~#
ifconfig -a

Code:
debian:~# ifconfig -a
eth1      Link encap:Ethernet  HWaddr 00:1B:FC:B3:0C:6C
          inet addr:129.100.193.162  Bcast:129.100.193.255  Mask:255.255.255.0
          inet6 addr: fe80::21b:fcff:feb3:c6c/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2753 errors:0 dropped:0 overruns:0 frame:0
          TX packets:140 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:247925 (242.1 KiB)  TX bytes:23175 (22.6 KiB)
          Interrupt:16

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:16 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:800 (800.0 b)  TX bytes:800 (800.0 b)

debian:~#
ping 127.0.0.1

Code:
debian:~# ping 127.0.0.1
PING 127.0.0.1 (127.0.0.1) 56(84) bytes of data.
64 bytes from 127.0.0.1: icmp_seq=1 ttl=64 time=0.022 ms
64 bytes from 127.0.0.1: icmp_seq=2 ttl=64 time=0.016 ms
64 bytes from 127.0.0.1: icmp_seq=3 ttl=64 time=0.015 ms

--- 127.0.0.1 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 1999ms
rtt min/avg/max/mdev = 0.015/0.017/0.022/0.005 ms
debian:~#
ping 129.100.0.1

Code:
debian:~# ping 129.100.0.1
connect: Network is unreachable
debian:~#
Thanks in advance.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to connect to DHCP gateway Setya Suse/Novell 1 06-05-2007 10:16 PM
Connect laptop to desktop through network card and DHCP Phyrexicaid Linux - Networking 2 04-19-2007 01:51 PM
Realtek 8139 network not working - DHCP unable to get IP address duryodhan Slackware 18 02-03-2007 08:28 AM
Unable to connect to Website Once outside the network jc_neo Linux - Networking 17 10-28-2004 08:31 PM
Unable to connect to network vaber Linux - Newbie 4 09-08-2003 11:31 PM


All times are GMT -5. The time now is 09:18 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration