LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   Unable to connect to DHCP Network (http://www.linuxquestions.org/questions/debian-26/unable-to-connect-to-dhcp-network-583492/)

WolfCub 09-09-2007 08:23 PM

Unable to connect to DHCP Network
 
Hi everyone. I am trying to connect to RezNet at the University of Western Ontario using Debian Linux sid. When I run /etc/init.d/networking restart, it says SIOCADDRT: no process found. I am unable to get onto the Internet, and I cannot ping any local addresses. Is there a particular package I should install to make this work? My /etc/network/interfaces has:

auto lo
iface lo inet loopback

auto eth1
iface eth1 inet dhcp

Thanks in advance.

farslayer 09-10-2007 08:08 AM

Hrm your Ethernet interface is defined as eth1 rather than eth0. Typically the numbering would start at eth0..

What is the output of: cat /var/log/dmesg | grep eth

WolfCub 09-10-2007 03:29 PM

The output of cat /var/log/dmesg | grep eth is:

Code:

debian:~# cat /var/log/dmesg | grep eth
sky2 eth0: addr 00:1b:fc:b3:0c:6c
udev: renamed network interface eth0 to eth1
sky2 eth1: enabling interface
sky2 eth1: ram buffer 0K

ifconfig:

Code:

debian:~# ifconfig
eth1      Link encap:Ethernet  HWaddr 00:1B:FC:B3:0C:6C
          inet addr:129.100.193.203  Bcast:129.100.193.255  Mask:255.255.255.0
          inet6 addr: fe80::21b:fcff:feb3:c6c/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:18097 errors:0 dropped:0 overruns:0 frame:0
          TX packets:341 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2178649 (2.0 MiB)  TX bytes:56351 (55.0 KiB)
          Interrupt:16

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:20 errors:0 dropped:0 overruns:0 frame:0
          TX packets:20 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1000 (1000.0 b)  TX bytes:1000 (1000.0 b)

vmnet1    Link encap:Ethernet  HWaddr 00:50:56:C0:00:01
          inet addr:192.168.200.1  Bcast:192.168.200.255  Mask:255.255.255.0
          inet6 addr: fe80::250:56ff:fec0:1/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:71 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

vmnet8    Link encap:Ethernet  HWaddr 00:50:56:C0:00:08
          inet addr:192.168.78.1  Bcast:192.168.78.255  Mask:255.255.255.0
          inet6 addr: fe80::250:56ff:fec0:8/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:69 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

wlan0    Link encap:Ethernet  HWaddr 00:13:E8:29:CC:F3
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:17 Memory:f7ffe000-f8000000

debian:~#

/etc/init.d/networking restart

Code:

debian:~# /etc/init.d/networking restart
Reconfiguring network interfaces...There is already a pid file /var/run/dhclient.eth1.pid with pid 10151
killed old client process, removed PID file
Internet Systems Consortium DHCP Client V3.0.6
Copyright 2004-2007 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth1/00:1b:fc:b3:0c:6c
Sending on  LPF/eth1/00:1b:fc:b3:0c:6c
Sending on  Socket/fallback
DHCPRELEASE on eth1 to 129.100.2.12 port 67
send_packet: Network is unreachable
send_packet: please consult README file regarding broadcast address.
Internet Systems Consortium DHCP Client V3.0.6
Copyright 2004-2007 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth1/00:1b:fc:b3:0c:6c
Sending on  LPF/eth1/00:1b:fc:b3:0c:6c
Sending on  Socket/fallback
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 4
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 5
DHCPOFFER from 129.100.192.1
DHCPREQUEST on eth1 to 255.255.255.255 port 67
DHCPACK from 129.100.192.1
SIOCADDRT: No such process
bound to 129.100.193.203 -- renewal in 700 seconds.
done.
debian:~#

Please help. Thanks in Advance.

farslayer 09-10-2007 03:47 PM

Just out of curiosity, was the RezNet support team not able to assist you ? I would think there would be someone in their group at least familiar with Linux. Since that is a university network, there may be some special authentication system they have in place for your machine. I know Case Western in Cleveland registers the User PC's via their MAC address, so they can control access and track them. I'm not sure what systems your university may have in place. .


as for the error message

SIOCDELRT No such process - You have tried to delete a route that doesn’t exist. List the routes with route –n and check the destaddr and netmask that you entered

I wonder if this could be because of the other interfaces you have defined.. vmnet are those a vmware interfaces ? Since the error is about a route, what does your routing table look like ? I wonder if a route on your machine is conflicting with something in their DHCP network configuration. have you tried shutting down vmware so those interfaces are disabled and then trying to connect to reznet ?

That would be the next step I would try..

WolfCub 09-10-2007 05:09 PM

I didn't know I had to add a destaddr and netmask, or even how to do that. I figured since it was DHCP, it would just work, without any configuration. Also, they do require MAC addresses, I was able to get online and do that earlier, but then I had to change the network settings to static IP for a LAN, and then upon changing back, the internet does not work. Also, changing vmware makes no difference. I should point out that I am not all that experienced with Linux networking, but I appreciate the fact that you're trying to help me greatly. Thanks a lot man.

Here is the output of route -n:

Code:

debian:~# route -n
Kernel IP routing table
Destination    Gateway        Genmask        Flags Metric Ref    Use Iface
129.100.193.0  0.0.0.0        255.255.255.0  U    0      0        0 eth1
192.168.200.0  0.0.0.0        255.255.255.0  U    0      0        0 vmnet1
192.168.78.0    0.0.0.0        255.255.255.0  U    0      0        0 vmnet8
169.254.0.0    0.0.0.0        255.255.0.0    U    1000  0        0 eth1


indienick 09-10-2007 06:32 PM

You should definitely ask around the campus (try the Weldon library) to see if they can hook you up with a sysadmin, or technician. I know the systems in the Weldon library use Solaris 9 (I believe), so I'm more than sure one or two of the sysadmins would be able to help you out.

Is your version of Sid installed through a VM? The reason I ask is because of the "vmnetn" interfaces.

Netmasks can be set through ifconfig and route. Check manpages for specifics. You can set a DHCP target destination (destaddr) using dhcdbd: # dhcdbd --dest host.domain.net

Also, check out the dhcp-options(5) manpage.

farslayer 09-10-2007 07:19 PM

It looks more like the DHCP server is proposing a route that your system doesn't like.. I copied the wrong error message..
SIOCDELRT instead of SIOCADDRT One is delete route the second which you have is Add route.. my bad..
http://www.uit.co.uk/practical-tcpip/w-rterr-015.htm

It's Also odd that your eth1 ends up with 2 addresses in the routing table...
the 129 from the DHCP server and a 169. which is a typical autoconfig address seen on a windows machine.
any idea where that 169 address is coming from ?

Also there is no default gateway in your routing table, this is probably the part of the DHCP offer that is failing. possibly due to some of your other network configuration.. have you treid shutting down vmware yet ?

the default route in your table would look something like this..
Code:

Kernel IP routing table
Destination    Gateway        Genmask        Flags Metric Ref    Use Iface
129.100.193.0  0.0.0.0        255.255.255.0  U    0      0        0 eth1
192.168.200.0  0.0.0.0        255.255.255.0  U    0      0        0 vmnet1
192.168.78.0    0.0.0.0        255.255.255.0  U    0      0        0 vmnet8
0.0.0.0        129.100.193.1  0.0.0.0        UG    0      0        0 eth1


WolfCub 09-10-2007 08:28 PM

Hey. I have no idea where the 169 address is coming from. I shut down vmware. The resulting route -n is as follows:

Code:

debian:~# route -n
Kernel IP routing table
Destination    Gateway        Genmask        Flags Metric Ref    Use Iface
129.100.193.0  0.0.0.0        255.255.255.0  U    0      0        0 eth1
169.254.0.0    0.0.0.0        255.255.0.0    U    1000  0        0 eth1
debian:~#

Is there any way I can make this configure itself, like, reset DHCP and all that to defaults? The reason I ask is that I can't help thinking a configuration file somewhere got damaged by me modifying /etc/network/interfaces and /etc/resolv.conf when I changed networks. If not, what steps should I take next? I tried to delete that 169 route, but it gave the "SIOCDELRT no such process" error. This is all way over my head haha, I'm a med-sci student. I think we're almost there though, you seem to know your stuff pretty well farslayer. Thank you soooooo very much for your help so far, I'm sure the solution is just around the corner. Having no internet really sucks when assignments are posted online, and the RezNet people just gave me the "not officially supported" speech with Linux :S Thanks again man.

Edit to indienick: My version of Sid is native, I have XP installed in VMWare to run any miscellaneous programs that the university may require me to use which won't work on Linux.

indienick 09-10-2007 10:49 PM

Haha fair enough. :)

Could you please post your /etc/network/interfaces and your /etc/resolv.conf? If you've been mucking around with them, the problem may very well lie therein. Also, there's a comment as the first line of /etc/resolv.conf:
Code:

# generated by NetworkManager, do not edit!
...
...
...

Alternately, you could purge-uninstall the dhcp3-client package, and reinstall it, but I wouldn't recommend this - let's keep this option to a last-resort scenario.

farslayer 09-11-2007 08:51 AM

I was just thinking the same thing.. lets see that /etc/network/interfaces file. That address / route has got to be defined somewhere..

I have poked around the net a little bit and found other people with similar issues with connectivity. Each time the Default gateway is missing and that mysterious 169.254.0.0 route is in their table and none of them seem to know where it came from.. One workaround was to manually add the default gateway to your routing table.

Go to a friends PC and find out what your Default gateway is supposed to be, you can use the command netstat -nr on windows, Mac or Linux with equal success to get the routing table. (for example purposes we'll use 129.100.193.1 again)

Try and add a default route manually

route add default gw 129.100.193.1


Test internet connectivity, try to browse the internet.
http://www.google.com
http://64.233.167.99 - If You can't browse by URL try with the IP (just in case you didn't get DNS info )

If that work's you could edit your /etc/network/interfaces file and have it manually add the default gateway to your system each time.. an ugly hack, but if it works..
Quote:

auto lo
iface lo inet loopback

auto eth1
iface eth1 inet dhcp
post-up route add default gw 129.100.193.1

WolfCub 09-11-2007 08:51 AM

/etc/network/interfaces:
Code:

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback
address 127.0.0.1
netmask 255.0.0.0

auto eth1
iface eth1 inet dhcp

/etc/resolv.conf:
Code:

# generated by NetworkManager, do not edit!

search smh.reznet.uwo.ca


nameserver 129.100.74.79
nameserver 129.100.2.51


WolfCub 09-11-2007 08:23 PM

For whatever reason, my internet is now functional. Thank you both very much for your help, I'm sure something that either of you suggested has made the difference. I can now take care of all the online stuff that I've had to put off. Thanks again.

indienick 09-11-2007 10:08 PM

Hahaha! You're very welcome; most of that should go to farslayer, as I came in late on this situation.

Just a faint curiosity, do you have a firewire port on your desktop/laptop? The reason I ask is because of your ethernet card being referred to as eth1, and not eth0. I just finished setting up my friend's laptop with a Linux install on it, and his ethernet card was bumped to eth1 just because he had a firewire port.

farslayer 09-11-2007 10:19 PM

That firewire 'network interface' is so annoying.. does ANYONE actually use firewire for a network interface ?
I wish that feature was not enabled by default.

I also wish I knew which part got WolfCub straightened out.. but hey it's working, and that's what counts :)

WolfCub 09-11-2007 10:27 PM

Hey guys. I had to reboot my computer a few minutes ago, and for whatever reason, the internet stopped working with the same reason again. This must mean that it has never been right, since it worked initially, then stopped working (and thus I made this thread), and then it worked, and now it has stopped again. Maybe RezNet is putting me on a different IP block or something and my computer can't take that (don't know how to phrase it, just a guess). So I guess I'm back to square one, unless I randomly boot up and it works, and then I never disconnect it again... Any ideas? Thanks in advance.


All times are GMT -5. The time now is 11:14 AM.