LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices



Reply
 
Search this Thread
Old 08-04-2008, 09:18 AM   #1
TimoSchmid
LQ Newbie
 
Registered: Jun 2008
Posts: 2

Rep: Reputation: 0
udev, snd_hda_intel and udevtrigger


Hello,
I installed debian lenny on my Notebook.
I replaced devfs with udev.
Now the driver snd_hda_intel is not loaded automatically on startup.
As soon as I do
Code:
# udevtrigger
the module is loaded automatically.
What am I missing?
uname: 2.6.25-2-amd64 #1 SMP Mon Jul 14 11:05:23 UTC 2008 x86_64

Thanks for your help in advance
 
Old 08-04-2008, 02:50 PM   #2
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,037

Rep: Reputation: 372Reputation: 372Reputation: 372Reputation: 372
Quote:
I replaced devfs with udev.
I am surprised debian lenny offers the option of devfs which is, I think, deprecated now.

Sometimes I'm a "Just force it to work" sort of person. So I'd just put

udevtrigger

at the end of the file /etc/rc.local just before the final exit(0)
Then reboot.

Other people will probably offer more elegant solutions.
If you'd like to research a more elegant solution, you could start by reading up on hotplug, coldplug and udev

And "Welcome to LQ!"
 
Old 08-05-2008, 10:47 AM   #3
TimoSchmid
LQ Newbie
 
Registered: Jun 2008
Posts: 2

Original Poster
Rep: Reputation: 0
not tested yet, but probably solves it

Quote:
Originally Posted by tredegar View Post
I am surprised debian lenny offers the option of devfs which is, I think, deprecated now.
Probably that's because I updated from etch, and as soon as I realized it, I was to lazy to download the whole CD-Image and reinstall again.

Quote:
Originally Posted by tredegar View Post
Sometimes I'm a "Just force it to work" sort of person.
I see, I am too.

Quote:
Originally Posted by tredegar View Post
So I'd just put

udevtrigger

at the end of the file /etc/rc.local just before the final exit(0)
Then reboot.
That's even a better workaround than I did: I put it in KDE's autostart.


Quote:
Originally Posted by tredegar View Post
Other people will probably offer more elegant solutions.
If you'd like to research a more elegant solution, you could start by reading up on hotplug, coldplug and udev

And "Welcome to LQ!"
Always keep on reading. How true!


Anyway, if somebody knows an even more right way to fix this, I'd apreciate your hints!
 
  


Reply

Tags
sndhdaintel, sound, udev


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
boot hangs at udevtrigger retry-failed after attempt to set up wireless Greenfuse Slackware 3 06-23-2008 08:51 AM
udevtrigger --retry-failed takes ages on boot Chaves Slackware 0 05-28-2008 09:26 AM
headphones - debian dell inspiron snd_hda_intel secretlydead Linux - Hardware 1 05-13-2008 09:44 PM
Snd_hda_Intel ronlau9 Linux - Software 2 03-15-2008 04:05 PM
snd_hda_intel driving me insane TrevorBradley Linux - Hardware 1 02-11-2007 09:18 PM


All times are GMT -5. The time now is 02:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration