LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 11-18-2008, 01:19 PM   #1
dave247
Member
 
Registered: May 2004
Posts: 204

Rep: Reputation: 30
trying to fix xwindows or just run command line... changing run levels


hey I recently am having a problem with my gui. Im using Debian 4 and the default gui.

I log in as any user and I get the message: "I could not start your session and so I have started the failsafe xterm session. Windows now have focus only if you have your cursor above them...etc"

So what I am trying to do is figure out how to reconfigure my gui or just change run levels so that there is no gui. I kinda forgot how to do this and cant find anything that is working...

can someone tell me how to get out of the gui and just use command line please?

Thanks
 
Old 11-18-2008, 04:11 PM   #2
rjlee
Senior Member
 
Registered: Jul 2004
Distribution: Ubuntu 7.04
Posts: 1,990

Rep: Reputation: 66
To just switch to a command-line window, ctrl+alt+f1, which will switch to virtual terminal 1.
Your GUI session will still be running (usually on VT7, alt+f7 to switch back to it).

If you want to kill off X completely, then you need to change runlevel. In a terminal:
Code:
telinit 3
This will switch to runlevel 3, although the actual runlevel you want may vary depending on your configuration. Multi-user without X could be 2, 3 or 4 depending on your distribution.

The boot-up default is stored in the /etc/inittab file, (initdefault, I think it's called) but can be overridden in the kernel command-line: look in the .conf files in /boot, or else /etc/grub.conf or /etc/lilo.conf; again, it depends on your distribution. You may also have to run other commands if you change these for your settings to take effect.

There's also a quick-and-dirty hack you could use: Press ctrl+alt+delete to kill X. It will re-spawn, but if you kill it often enough then it will wait for about 15 minutes before trying to start it again.
 
Old 11-18-2008, 06:11 PM   #3
majrys1962
LQ Newbie
 
Registered: Nov 2008
Posts: 3

Rep: Reputation: 0
To disable all the X starting daemons:
insert "exit 0" at the start of all /etc/init.d/?dm files
After reboot to start X-session you have to type : startx
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to run Azureus from Command Line (Not Xwindows)? abcampa Linux - Software 7 10-01-2009 12:15 PM
LXer: Changing Solaris Run Levels And Clearing Up Some Common Misconceptions LXer Syndicated Linux News 0 08-11-2008 02:40 AM
Changing Run Levels in RHEL4 carlosinfl Red Hat 4 04-12-2006 01:42 PM
Changing run levels in the bootloader IceNineJon Linux - Newbie 5 06-06-2002 12:11 AM
Changing Run Levels unclebyron Linux - General 1 01-28-2002 04:43 PM


All times are GMT -5. The time now is 09:17 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration