LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   trying to fix xwindows or just run command line... changing run levels (http://www.linuxquestions.org/questions/debian-26/trying-to-fix-xwindows-or-just-run-command-line-changing-run-levels-684393/)

dave247 11-18-2008 01:19 PM

trying to fix xwindows or just run command line... changing run levels
 
hey I recently am having a problem with my gui. Im using Debian 4 and the default gui.

I log in as any user and I get the message: "I could not start your session and so I have started the failsafe xterm session. Windows now have focus only if you have your cursor above them...etc"

So what I am trying to do is figure out how to reconfigure my gui or just change run levels so that there is no gui. I kinda forgot how to do this and cant find anything that is working...

can someone tell me how to get out of the gui and just use command line please?

Thanks

rjlee 11-18-2008 04:11 PM

To just switch to a command-line window, ctrl+alt+f1, which will switch to virtual terminal 1.
Your GUI session will still be running (usually on VT7, alt+f7 to switch back to it).

If you want to kill off X completely, then you need to change runlevel. In a terminal:
Code:

telinit 3
This will switch to runlevel 3, although the actual runlevel you want may vary depending on your configuration. Multi-user without X could be 2, 3 or 4 depending on your distribution.

The boot-up default is stored in the /etc/inittab file, (initdefault, I think it's called) but can be overridden in the kernel command-line: look in the .conf files in /boot, or else /etc/grub.conf or /etc/lilo.conf; again, it depends on your distribution. You may also have to run other commands if you change these for your settings to take effect.

There's also a quick-and-dirty hack you could use: Press ctrl+alt+delete to kill X. It will re-spawn, but if you kill it often enough then it will wait for about 15 minutes before trying to start it again.

majrys1962 11-18-2008 06:11 PM

To disable all the X starting daemons:
insert "exit 0" at the start of all /etc/init.d/?dm files
After reboot to start X-session you have to type : startx


All times are GMT -5. The time now is 09:03 AM.