LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 06-18-2011, 06:04 PM   #1
Dopeeye
LQ Newbie
 
Registered: Jun 2011
Posts: 5

Rep: Reputation: Disabled
Trouble installing Compiz as windowmanager for debian


I saw the cool windows effects on the latest revision of Knoppix and wanted to make it a permanent install, since Knoppix is not recommended for a permanent install i went with Debian. I have been trying to install Compiz as the windowmanager. When I run Compiz --replace after i install it i get the following error:

Window manager error: Unable to open X display :0.0

any help or suggestions
Also how do i verify if i changed my default windowmanager from gnome to compiz?

Thanks
 
Old 06-18-2011, 06:08 PM   #2
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,581
Blog Entries: 1

Rep: Reputation: 1033Reputation: 1033Reputation: 1033Reputation: 1033Reputation: 1033Reputation: 1033Reputation: 1033Reputation: 1033
Quote:
When I run Compiz --replace after i install it i get the following error:

Window manager error: Unable to open X display :0.0
Do you run X when you issue 'compiz --replace'?


Have you followed the Debian Compiz wiki?
http://wiki.debian.org/Compiz
 
Old 06-18-2011, 06:27 PM   #3
Dopeeye
LQ Newbie
 
Registered: Jun 2011
Posts: 5

Original Poster
Rep: Reputation: Disabled
This shows how much of a noob i am... i start debian and go into the root terminal to execute these commands. So i think i am running X ?
 
Old 06-18-2011, 06:30 PM   #4
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,581
Blog Entries: 1

Rep: Reputation: 1033Reputation: 1033Reputation: 1033Reputation: 1033Reputation: 1033Reputation: 1033Reputation: 1033Reputation: 1033
If you're in the graphical environment then you're running X.

You're not supposed to run this command as root. What's the prompt on the terminal? $ or # ?
 
Old 06-18-2011, 06:49 PM   #5
Dopeeye
LQ Newbie
 
Registered: Jun 2011
Posts: 5

Original Poster
Rep: Reputation: Disabled
ok i ran it NOW as in a regular terminal (non root) window and the error did not show, only a few warnings:

screenoutput:

Backend : ini
Integration : true
Profile : default
Adding plugins
Initializing core options...done
Initializing move options...done
Initializing resize options...done
Initializing place options...done
Initializing decoration options...done
Initializing commands options...done
Initializing water options...done
Initializing gnomecompat options...done
Initializing put options...done
Initializing winrules options...done
Initializing staticswitcher options...done
Initializing screenshot options...done
Initializing resizeinfo options...done
compiz (cube) - Warn: Failed to load slide: /usr/share/images/desktop-base/debian-blueish-wallpaper-640x480.png
Initializing cube options...done
compiz (core) - Error: Plugin 'text' not loaded.

compiz (shift) - Warn: No compatible text plugin loaded.
Initializing shift options...done
compiz (core) - Error: Plugin 'text' not loaded.

compiz (ring) - Warn: No compatible text plugin found.
Initializing ring options...done
Initializing animation options...done
Initializing snap options...done
Initializing neg options...done
Initializing switcher options...done
Initializing scale options...done
Initializing rotate options...done
Setting Update "initiate_button"

end of screenoutput
Also the prompt does not return and if I try to close the window it gives me a prompt that the window is still running a process

Also how do i ensure that compiz loads instead of gnome?
 
Old 06-18-2011, 06:54 PM   #6
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,581
Blog Entries: 1

Rep: Reputation: 1033Reputation: 1033Reputation: 1033Reputation: 1033Reputation: 1033Reputation: 1033Reputation: 1033Reputation: 1033
Quote:
Also how do i ensure that compiz loads instead of gnome?
Code:
gconftool-2 --type string --set /desktop/gnome/session/required_components/windowmanager compiz
It will automatically replace the default wm when you boot the computer. Please read the compiz wiki I posted above.
 
Old 06-19-2011, 11:35 AM   #7
Dopeeye
LQ Newbie
 
Registered: Jun 2011
Posts: 5

Original Poster
Rep: Reputation: Disabled
Thanks, got it to work!
 
Old 06-19-2011, 11:58 AM   #8
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,581
Blog Entries: 1

Rep: Reputation: 1033Reputation: 1033Reputation: 1033Reputation: 1033Reputation: 1033Reputation: 1033Reputation: 1033Reputation: 1033
Glad to hear it. If you think the problem has been solved, you can mark the thread as solved in the thread tools menu.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help! Run into trouble installing debian jaslowe Linux - Newbie 2 04-27-2009 06:31 AM
Trouble installing debian packages anoraxis Slackware 30 12-01-2008 06:54 PM
trouble installing compiz Josh100 Linux - Newbie 1 02-01-2007 04:20 PM
Trouble installing Debian Sarge. duffmckagan Debian 15 10-20-2005 12:14 PM
Trouble installing Debian on new machine GAMMA_BLADE Debian 4 02-02-2005 01:30 PM


All times are GMT -5. The time now is 05:05 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration