LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices



Reply
 
Search this Thread
Old 11-26-2008, 11:57 AM   #1
stratotak
Member
 
Registered: Sep 2005
Distribution: Today Debian . Tomorrow ..??
Posts: 386

Rep: Reputation: 39
Torrent downloading,,Setting static IP or UPnP??


Im having problems with downloading torrents..Very low download rates.Under windows rather than use UPnP I assign a static IP and open port on router.Has always worked.Now problem is I cant figure how to set a static IP under Debian.Im using lenny and I tried to use Sysem>network to assign IP but It wont connect.As far as UPnP it dosent work either.Which is easier to get working?A static IP or getting UPnP working?And how?For UPnP do i need to install something or make sure a service is running?I have UPnP on on my router..
 
Old 11-26-2008, 03:12 PM   #2
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,232
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
assigning a static IP in Debian is easy..

man interfaces
man resolv.conf

Code:
user@it-etch:~$ cat /etc/network/interfaces

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
# allow-hotplug eth0
# iface eth0 inet dhcp
auto eth0
iface eth0 inet static
address 192.168.1.4
netmask 255.255.255.0
gateway 192.168.1.1
network 192.168.1.0
broadcast 192.168.1.255
Code:
user@it-etch:~$ cat /etc/resolv.conf 

search mydomain.com
nameserver 192.168.1.1

I don't use the GUI to manage static IP's, it's fairly straight forward in the configuration file.

You will probably need to toggle the interface after making the changes..

ifdown eth0
ifup eth0

Last edited by farslayer; 11-26-2008 at 03:13 PM.
 
Old 11-27-2008, 03:42 AM   #3
stratotak
Member
 
Registered: Sep 2005
Distribution: Today Debian . Tomorrow ..??
Posts: 386

Original Poster
Rep: Reputation: 39
Ok..I tried for about half hour trying to get it to work,but cant get it to connect.I basically copied code and pasted into interface file.I just changed the IP..

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
# allow-hotplug eth0
# iface eth0 inet dhcp
auto eth0
iface eth0 inet static
address 192.168.1.7
netmask 255.255.255.0
gateway 192.168.1.1
network 192.168.1.0
broadcast 192.168.1.255

I wasnt sure If i need to change broadcast,network??My resolv lookis like..

### BEGIN INFO
#
# Modified_by: NetworkManager
# Process: /usr/bin/NetworkManager
# Process_id: 2678
#
### END INFO





nameserver 192.168.1.1

Im not sure what Im missing.Ive tried different things in interface file..From changing network to 192.168.1.1 instead of 192.168.1.0..Ive remvoed the network and broadcast from file,because when I use GUI it dosent add that to file..I used GUI to set up static then added network,broadcast to it.I tried rebooting each time I edited interfaces file..but I sill cant get it to connect to internet.I can connect to router..so Im not sure what setting is wrong ..Is it the resolv??Should it be 192.168.1.7,,I treid that but it didnt work either..Not sure what Im doing wrong..
 
Old 11-27-2008, 10:51 PM   #4
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,232
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
if you can connect to your router then the NIC is working..

resolv.conf allows you to resolve DNS names. When you system is able to connect to the router see if you can put the following in your web browser and get to Google.

http://64.233.161.99

If googles web page loads then your problem is definitely with resolv.conf, because your system is not resolving DNS.
instead of 192.168.1.1 (the IP address of your Router) in resolv.conf you could enter the IP address of your ISP's DNS server(s)
 
Old 12-01-2008, 01:11 PM   #5
stratotak
Member
 
Registered: Sep 2005
Distribution: Today Debian . Tomorrow ..??
Posts: 386

Original Poster
Rep: Reputation: 39
Ok,I was mistaken.I thought it was connecting to router because router DD-WRT main page came up,,I use Epiphany as browser and it was just bringing page up because it had it in cache.when i tried to access setting it wouldnt connect.I basically just gave up and just use DHCP..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Downloading torrent files in Zenwalk Harshith.S Linux - Newbie 1 09-26-2008 07:07 AM
what is the best bit torrent to use for downloading on linux (ubunta) baltic47 Linux - Newbie 2 06-20-2008 02:46 PM
Setting Azueus as my default torrent program? agentaaron Linux - Software 1 11-08-2007 12:00 PM
setting up an old pc to be a dedicated torrent box saimike Ubuntu 7 05-27-2007 01:31 PM
Setting up Linux Firewall and UPnP on old computer. badmofo666 Linux - Networking 1 09-29-2006 01:46 PM


All times are GMT -5. The time now is 03:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration