LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 11-02-2007, 02:52 PM   #1
acummings
Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 615

Rep: Reputation: 49
Time is not using local time but uses UTC


Debian 4.0

My bios clock is set to local time of time zone America, Los_Angeles

When Deb 4 installed, I thought I told it to use local time.

Gnome it (displays the wrong time) displays exactly 7 hours earlier in the day.

UTC time is exactly 7 hours ahead of America, Los_Angeles time zone.

So, it appears that Deb is translating from UTC even though I thought I had told it not to do so.

Gnome (as user, ie /home/al) it shows using local time and using Los_Angeles time zone.

So, what/where are the underlying mechanisms/commands

What am I yet to learn?

Should I give up on local time and use UTC?

I also use Slackware 12 who, unlike Debian, does display the correct time when told to use local time.

Thanks.

--
Alan.
 
Old 11-02-2007, 03:57 PM   #2
acummings
Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 615

Original Poster
Rep: Reputation: 49
Somehow, (wasn't supposed to) but nonetheless did, was set as if the hwclock (bios clock) is using UTC

But my bios clock is not set to UTC; I have it set to local time.

hwclock is the relevant command.

man hwclock

AB60R:~# hwclock --localtime --hctosys

That fixed it. It now thinks my bios clock uses local time. Gnome now displays the correct time.

The above listed man page reports that it will keep using what it formerly had been set at (either UTC or local time) unless you call it with either the utc or the localtime option.

The above listed command calls it with the local time option which sets it to use local time. Works upon reboot too (I checked it).

--
Alan.
 
Old 11-03-2007, 01:58 PM   #3
Speek
Member
 
Registered: Sep 2003
Distribution: Slackware
Posts: 103

Rep: Reputation: 31
In /etc/default/rcS you can set UTC to yes or no.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Change UTC to LOCAL TIME in etch?? slackass Debian 4 08-03-2007 05:39 PM
Accessing UTC time yashwantpinge Programming 1 02-22-2006 05:32 AM
Cannot set time/date to other time zone than UTC (Kubuntu) jamangold Ubuntu 1 12-23-2005 05:42 PM
Wrong UTC time sundaraz Linux - Newbie 4 10-21-2005 10:45 PM
Re: UTC Time unixfreak Linux - Newbie 2 08-30-2004 02:09 PM


All times are GMT -5. The time now is 02:30 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration