LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 05-29-2005, 09:26 PM   #1
Nebetsu
Member
 
Registered: Feb 2005
Location: In the depths of the infinite pocket
Distribution: Gentoo
Posts: 67

Rep: Reputation: 15
The Debian install thinks my 60 gig drive is a 33 gig drive!


All the other distros seem to see it just fine, but I like Debian the best. Does anyone have a solution for this?
 
Old 05-30-2005, 03:15 AM   #2
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
You mean, it's set up as 60Gb in bios, but when you go to make partitions during the debian install, you have only 33Gb to play with?
 
Old 05-30-2005, 04:50 AM   #3
jkh
Member
 
Registered: Dec 2004
Location: Maidstone, Kent, England
Distribution: Ubuntu
Posts: 100

Rep: Reputation: 15
omg, I had a similar problem. I did have windows on my laptop which for some reason thought I only had a 2gig HD, the laptop was a gift and it wasn't until I installed linux did I find out I actually had a 12gig HD. I never did find out why windows did that, I just related it to the fact that windows is a piece of shit.
 
Old 05-30-2005, 12:22 PM   #4
Nebetsu
Member
 
Registered: Feb 2005
Location: In the depths of the infinite pocket
Distribution: Gentoo
Posts: 67

Original Poster
Rep: Reputation: 15
It's set up as a 33 gig drive in the BIOS because thats what my idiot bios sees it as... Most distros of Linux seem to have built-in overlays that will see it for what it really is. (When I had Windows, I had to put an overlay on the drive).
 
Old 05-31-2005, 11:50 AM   #5
Nebetsu
Member
 
Registered: Feb 2005
Location: In the depths of the infinite pocket
Distribution: Gentoo
Posts: 67

Original Poster
Rep: Reputation: 15
So... does anyone have a solution?
 
Old 05-31-2005, 11:53 AM   #6
vharishankar
Senior Member
 
Registered: Dec 2003
Posts: 3,142
Blog Entries: 4

Rep: Reputation: 121Reputation: 121
Your motherboard must be old if it cannot recognize large hard drives. There may be a couple of solutions to this.

One: less risky but more expensive: buy a new board.
Two: more risky, you can try updating the BIOS/firmware (if it can be updated)
 
Old 05-31-2005, 06:26 PM   #7
Nebetsu
Member
 
Registered: Feb 2005
Location: In the depths of the infinite pocket
Distribution: Gentoo
Posts: 67

Original Poster
Rep: Reputation: 15
Yeah. I'm kinda at a point where I have no money right now (one of the reasons why I switched to Linux in the first place). I wish I could buy a new motherboard, but I can't... >> I also don't want to risk ruining my only good motherboard, since I don't have the funds to replace it... >>

Anyways thanks for the tips.
 
Old 06-02-2005, 07:41 AM   #8
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
You could try hand installing the drive specs into the bios ... though you may need to reinstall your OS's afterwards.

There's a label on the drive (you'll have to take it out to see this) which has the manufacturers specs on it (heads, cylenders, et al.) Write them down, then put it back.

In the cmos setup, you get an option to enter the drive specs instead of auto-detecting them. Do so - from what you wrote down. Save and reboot and you will, fingers crossed, see your complete drive.

It's not uncommon for bios to mis-identify the drive specs.

Unfortunately, your drive partitions may be a tad out. I guess it can't be too far out since your bootloader ain't giving you errors. If you're luck holds - then it may just be a matter of formatting the excess space. Otherwise you won't have a bootable disk and you're looking at a reinstall. Well - you wanted to kick window$ didn't you?
 
Old 06-02-2005, 05:49 PM   #9
Nebetsu
Member
 
Registered: Feb 2005
Location: In the depths of the infinite pocket
Distribution: Gentoo
Posts: 67

Original Poster
Rep: Reputation: 15
Well manually entering specs of the drive didn't help. Linux will boot off of any other drive just fine. It just won't boot off my 60 because it's not recognised by the BIOS. What I'm going to try is to install Linux on a 4 gig drive and slave the 60 gig off of it. It sounds ludacris, but I think it will work well.
 
Old 06-02-2005, 10:14 PM   #10
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
That's the setup I have ... I stuck the boot and swap partitions on an old 4Gb drive as hda and used all of hdb as root. (Of course, if you anticipate doing a lot of fiddling and trying different things, you may want to have a seperate partition for /home as well.)
 
Old 06-03-2005, 03:18 AM   #11
paranoyakX
LQ Newbie
 
Registered: Jun 2005
Location: Turkey
Distribution: Debian
Posts: 7

Rep: Reputation: 0
hi, what about the jumper configuration??? maybe you have 2 jumper on hdd, because of that your hdd is 33 GB...
 
Old 06-03-2005, 04:07 AM   #12
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
paranoyakX: interesting point - however, the slave configuration is normally no jumpers at all ... and will fix the problem. (Aside: You should edit your profile - use the "user CP" hotlink at the top of the page - to reflect your distro and location. Thanks.)

Nebetsu: It strikes my though, that if the bios only sees 33Gb as a master, unless this is a jumper issue, it will only see 33Gb as slave.

What do you mean "Manually entering the specs didn't help"? In what way? Will BIOS see your drive with correct specs after the manual config or dosn't it see your drive at all afterwards? (Last time this happened to me I had a broken drive!)

Please understand, after reconfiguring your drive in BIOS, you do not expect linux to boot. (Only if your lucky!) After the correct drive specs are entered into the bios, reboot and check the bios entries - is the drive still there or did you get an "error reading the drive" sort of message somewhere?

If the BIOS can see thed rive with the newconfiguration, then you are free to reinstall linux with the full size of the drive available.

Otherwise, you may have to consider that the drive is stuffed, or that there are more complex jumper setting around. In the former case, check it in the bios of another machine. In the latter - reread the manufacturers instructions.

BTW: if this persists, print the manufacturers info here (including manufacturer and drive IDs) Also tell us your bios version and motherboard type. And we'll see.
 
Old 06-03-2005, 11:08 PM   #13
Nebetsu
Member
 
Registered: Feb 2005
Location: In the depths of the infinite pocket
Distribution: Gentoo
Posts: 67

Original Poster
Rep: Reputation: 15
It's fine now. I have linux on a 4 gig drive and my 60 gig as my home.
 
Old 06-04-2005, 01:41 AM   #14
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
Well done, suggests a jumper issue. Was this a 2 jumper drive?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
partition scheme for a 2 gig drive? mipia *BSD 12 01-11-2005 09:18 AM
Using 160 gig drive with Linux sofasurfer Linux - Hardware 1 01-14-2004 07:23 PM
Why my 80 gig hard drive only shows 70 gig? dsuratman Linux - Newbie 3 11-20-2003 12:54 AM
Debian cd Install not recognizing my scsi - wd 160 gig drive toadlilly Debian 7 10-16-2003 11:41 PM
1 gig disk drive big enough ? qwijibow Slackware 8 10-01-2003 12:30 PM


All times are GMT -5. The time now is 09:05 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration