LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   The Debian install thinks my 60 gig drive is a 33 gig drive! (http://www.linuxquestions.org/questions/debian-26/the-debian-install-thinks-my-60-gig-drive-is-a-33-gig-drive-328382/)

Nebetsu 05-29-2005 08:26 PM

The Debian install thinks my 60 gig drive is a 33 gig drive!
 
All the other distros seem to see it just fine, but I like Debian the best. Does anyone have a solution for this?

Simon Bridge 05-30-2005 02:15 AM

You mean, it's set up as 60Gb in bios, but when you go to make partitions during the debian install, you have only 33Gb to play with?

jkh 05-30-2005 03:50 AM

omg, I had a similar problem. I did have windows on my laptop which for some reason thought I only had a 2gig HD, the laptop was a gift and it wasn't until I installed linux did I find out I actually had a 12gig HD. I never did find out why windows did that, I just related it to the fact that windows is a piece of shit.

Nebetsu 05-30-2005 11:22 AM

It's set up as a 33 gig drive in the BIOS because thats what my idiot bios sees it as... Most distros of Linux seem to have built-in overlays that will see it for what it really is. (When I had Windows, I had to put an overlay on the drive).

Nebetsu 05-31-2005 10:50 AM

So... does anyone have a solution?

vharishankar 05-31-2005 10:53 AM

Your motherboard must be old if it cannot recognize large hard drives. There may be a couple of solutions to this.

One: less risky but more expensive: buy a new board.
Two: more risky, you can try updating the BIOS/firmware (if it can be updated)

Nebetsu 05-31-2005 05:26 PM

Yeah. I'm kinda at a point where I have no money right now (one of the reasons why I switched to Linux in the first place). I wish I could buy a new motherboard, but I can't... >> I also don't want to risk ruining my only good motherboard, since I don't have the funds to replace it... >>

Anyways thanks for the tips.

Simon Bridge 06-02-2005 06:41 AM

You could try hand installing the drive specs into the bios ... though you may need to reinstall your OS's afterwards.

There's a label on the drive (you'll have to take it out to see this) which has the manufacturers specs on it (heads, cylenders, et al.) Write them down, then put it back.

In the cmos setup, you get an option to enter the drive specs instead of auto-detecting them. Do so - from what you wrote down. Save and reboot and you will, fingers crossed, see your complete drive.

It's not uncommon for bios to mis-identify the drive specs.

Unfortunately, your drive partitions may be a tad out. I guess it can't be too far out since your bootloader ain't giving you errors. If you're luck holds - then it may just be a matter of formatting the excess space. Otherwise you won't have a bootable disk and you're looking at a reinstall. Well - you wanted to kick window$ didn't you?

Nebetsu 06-02-2005 04:49 PM

Well manually entering specs of the drive didn't help. Linux will boot off of any other drive just fine. It just won't boot off my 60 because it's not recognised by the BIOS. What I'm going to try is to install Linux on a 4 gig drive and slave the 60 gig off of it. It sounds ludacris, but I think it will work well.

Simon Bridge 06-02-2005 09:14 PM

That's the setup I have :) ... I stuck the boot and swap partitions on an old 4Gb drive as hda and used all of hdb as root. (Of course, if you anticipate doing a lot of fiddling and trying different things, you may want to have a seperate partition for /home as well.)

paranoyakX 06-03-2005 02:18 AM

hi, what about the jumper configuration??? maybe you have 2 jumper on hdd, because of that your hdd is 33 GB...

Simon Bridge 06-03-2005 03:07 AM

paranoyakX: interesting point - however, the slave configuration is normally no jumpers at all ... and will fix the problem. (Aside: You should edit your profile - use the "user CP" hotlink at the top of the page - to reflect your distro and location. Thanks.)

Nebetsu: It strikes my though, that if the bios only sees 33Gb as a master, unless this is a jumper issue, it will only see 33Gb as slave.

What do you mean "Manually entering the specs didn't help"? In what way? Will BIOS see your drive with correct specs after the manual config or dosn't it see your drive at all afterwards? (Last time this happened to me I had a broken drive!)

Please understand, after reconfiguring your drive in BIOS, you do not expect linux to boot. (Only if your lucky!) After the correct drive specs are entered into the bios, reboot and check the bios entries - is the drive still there or did you get an "error reading the drive" sort of message somewhere?

If the BIOS can see thed rive with the newconfiguration, then you are free to reinstall linux with the full size of the drive available.

Otherwise, you may have to consider that the drive is stuffed, or that there are more complex jumper setting around. In the former case, check it in the bios of another machine. In the latter - reread the manufacturers instructions.

BTW: if this persists, print the manufacturers info here (including manufacturer and drive IDs) Also tell us your bios version and motherboard type. And we'll see.

Nebetsu 06-03-2005 10:08 PM

It's fine now. I have linux on a 4 gig drive and my 60 gig as my home.

Simon Bridge 06-04-2005 12:41 AM

Well done, suggests a jumper issue. Was this a 2 jumper drive?


All times are GMT -5. The time now is 01:57 AM.