LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 09-30-2004, 11:23 AM   #1
frankmulder
Member
 
Registered: Jun 2004
Distribution: Kubuntu
Posts: 30

Rep: Reputation: 15
Question System works slower since kernel recompile


Hi,

I recompiled my kernel (2.6), but now my kernel works slower :S

This is my /proc/cpuinfo:

processor : 0
vendor_id : AuthenticAMD
cpu family : 6
model : 10
model name : AMD Athlon(tm) XP 2500+
stepping : 0
cpu MHz : 1826.443
cache size : 512 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 mmx fxsr sse syscall mmxext 3dnowext 3dnow
bogomips : 3579.90

In the kernel config, I set 'K7/Athlon' to Y.
Is that right?

Thanks,
Frank
 
Old 09-30-2004, 11:38 AM   #2
rjlee
Senior Member
 
Registered: Jul 2004
Distribution: Ubuntu 7.04
Posts: 1,990

Rep: Reputation: 67
Yes, you are right to select a K7 here.

There are several reasons why your kernel may be being slower. Usually, this means that either you have compiled-in support for hardware that you don't have or that you have left out support for something that you need to make the system run quickly, such as DMA or swapping.

Did you do a make cloneconfig before setting up the kernel? And did you go through all the other options apart from the processor type? Are you using the kernel source from Red Hat (which may have speed-up patches applied to it) or a vanilla source from kernel.org?

Edit: Most kernel settings have some sort of impact on either performance or memory usage, or both.
 
Old 09-30-2004, 12:16 PM   #3
frankmulder
Member
 
Registered: Jun 2004
Distribution: Kubuntu
Posts: 30

Original Poster
Rep: Reputation: 15
Thank you for replying.

I apt-get the 2.6.8 kernel source and started with the default configuration (many modules enabled). I left these modules enabled, and changed a few things:

* added support for ext3 (I thought I wouldn't need an initrd then, but I forgot to set IDE/ATAPI support to Y, so I still needed an initrd [otherwise I got kernel panic])
To be able to use Bootsplash, I included the following: (as recommended by http://www.desktop-linux.net/bootsplash.htm)
* cramfs, initrd
* vga, vesa, framebuffer support
and of course I turned on the bootsplash screen

I also checked all other options, but most of them were compiled as modules, so I decided to leave them so.

Should I turn off these modules? Should I change ext3 back to M instead of Y? What is a cloneconfig?

Btw I just checked dmesg, and the following was in the output:

parport0: FIFO is stuck
parport0: BUSY timeout (1) in compat_write_block_pio
DMA write timed out
parport0: FIFO is stuck
parport0: BUSY timeout (1) in compat_write_block_pio
DMA write timed out
parport0: FIFO is stuck
parport0: BUSY timeout (1) in compat_write_block_pio
DMA write timed out
parport0: FIFO is stuck
parport0: BUSY timeout (1) in compat_write_block_pio
DMA write timed out
parport0: FIFO is stuck
parport0: BUSY timeout (1) in compat_write_block_pio
DMA write timed out

I'm not sure this has something to do with my problem, but maybe it's informative to you...

I could also send my .config, if that helps (but maybe it's not a good idea to post it on this forum...).

Oh, and one last question: what is better - compiling things as modules or compiling it in the kernel (when I'm sure I will use these things)?

Thanks for you help,

Frank
 
Old 10-11-2004, 03:50 PM   #4
rjlee
Senior Member
 
Registered: Jul 2004
Distribution: Ubuntu 7.04
Posts: 1,990

Rep: Reputation: 67
The parport0 error is a problem relating to your parallel port. It's trying to write with DMA, which is timing out for some reason. This could certainly be causing speed problems; the best way to clear this it is to remove support for parport if you're not using a parallel printer, or other parallel devices if you are.

This could also be a conflict between parport and another module, such as plip, if you're trying to use both at the same time somehow.

The advantage of drivers as modules (to an end user) is that any resources used by the driver are freed when the module isn't being used. The only real advantage to compiled-in drivers are that you don't have any load/unload times if you keep switching between different drivers for the same resource.
 
Old 10-12-2004, 03:08 AM   #5
frankmulder
Member
 
Registered: Jun 2004
Distribution: Kubuntu
Posts: 30

Original Poster
Rep: Reputation: 15
Thank you for replying; I was thinking nobody would answer....
I don't use my parallel port; I will try removing parport. Thanks for your hint!

I will also compile everything as modules (if possible). Maybe I'll leave ext3 and ide_device compiled in, because I need to build an initrd otherwise.

Frank
 
Old 10-12-2004, 05:33 AM   #6
rjlee
Senior Member
 
Registered: Jul 2004
Distribution: Ubuntu 7.04
Posts: 1,990

Rep: Reputation: 67
I should also mention that driver modules are held on disk, so you need to make sure that your disk drivers and the drivers for the filesystems of your root (/), /etc and /lib/modules partitions are all compiled in, as they are required for module loading.
 
Old 10-12-2004, 07:12 AM   #7
frankmulder
Member
 
Registered: Jun 2004
Distribution: Kubuntu
Posts: 30

Original Poster
Rep: Reputation: 15
Yes, I compile in ext3 (the fs of my root) and ide_device, ide_generic and ide_disk.

Another question: does it matter how many things I compile as modules? For example, I don't have WiFi, so I don't need the modules. Does it matter if I leave them as M in the kernel config, or do I have to set them to N?
 
Old 10-12-2004, 09:36 AM   #8
rjlee
Senior Member
 
Registered: Jul 2004
Distribution: Ubuntu 7.04
Posts: 1,990

Rep: Reputation: 67
In general, setting something to M instead of N will slow down your compilation (and create a module file on the disk where there otherwise would be none).

It may also cause slight delays when detecting hardware, e.g. if you plug in a removable device (some distros also check for new hardware on start-up) but probably not so as you'd notice.

Otherwise, it doesn't make any real difference.
 
Old 10-14-2004, 03:02 AM   #9
frankmulder
Member
 
Registered: Jun 2004
Distribution: Kubuntu
Posts: 30

Original Poster
Rep: Reputation: 15
In my default configuration, almost everything was set as M. I'm now setting things that I'm sure I won't use to N.

Debian installs 'discover' (which detects hardware) by default. I'm not sure if I need it, but if deleting modules makes it faster, I will be glad. For the reason I'm recompiling my kernel is mainly because my system works so slow, although I have a relatively fast processor (see the first post). Startup takes about 2 minutes; that's a bit too long for me.

Other hints for a faster startup are welcome too

Frank
 
Old 10-14-2004, 04:23 AM   #10
rjlee
Senior Member
 
Registered: Jul 2004
Distribution: Ubuntu 7.04
Posts: 1,990

Rep: Reputation: 67
The best way to increase your start-up speed is to disable any services you aren't using in the runlevel that you use. Things like postgres (SQL database server) and squid (web proxy) tend to take quite a while to start up.

Debian probably provides a runlevel-editor (or similar) configuration tool for this.

Alternativly, boot up in verbose mode and see what takes the most time.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
upgrade to 10.2 -> system getting slower uselpa Slackware 3 09-24-2005 01:28 PM
Custom Kernel and now the system benchmarks slower! soulwatcher1974 Linux - General 2 03-19-2005 11:51 PM
Using Linux system, internet went bit slower? DMZeplin Linux - Networking 4 02-04-2005 10:33 PM
blank screen after new kernel recompile, but system works antken Linux - General 2 07-05-2004 10:01 AM
How P IV system work fast with Red Hat Linux 8, I recompile the kernel also. benoy4007 Red Hat 2 06-12-2004 04:49 AM


All times are GMT -5. The time now is 10:28 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration