LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices



Reply
 
Search this Thread
Old 07-16-2010, 10:43 AM   #1
donnied
Member
 
Registered: Oct 2006
Distribution: Debian x64
Posts: 198

Rep: Reputation: 30
sys not mounting in schroot


I can manually mount /sys on the /chroot/sys but within the chroot it's not showing up. I see from outside the chroot that it's mounted to a directory within the chroot, but within the chroot it's not visible. /tmp /proc and /dev are visible, just not /sys.
?
 
Old 07-16-2010, 12:00 PM   #2
j1alu
Member
 
Registered: Apr 2009
Distribution: debian gnu/linux
Posts: 798

Rep: Reputation: Disabled
Like that ?
Code:
# mount /dev/sda8 /media/disk
# chroot /media/disk
ROOT# ls /sys
ROOT# exit
exit
# mount -o bind /sys /media/disk/sys/
# chroot /media/disk
ROOT# ls /sys
block  bus  class  dev	devices  firmware  fs  kernel  module  power
ROOT#
perhaps.
 
Old 07-16-2010, 01:12 PM   #3
donnied
Member
 
Registered: Oct 2006
Distribution: Debian x64
Posts: 198

Original Poster
Rep: Reputation: 30
Maybe I should have specified I'm using schroot.


After
Code:
mount -t sysfs none /var/chroot/squeeze-32/sys
In the 'regular' shell I see:
Code:
# ls /sys/
block  bus  class  dev  devices  firmware  fs  hypervisor  kernel  module  power

# ls /var/chroot/squeeze-32/sys/
block  bus  class  dev  devices  firmware  fs  hypervisor  kernel  module  power
However, in the chroot I see:
Code:
# ls /sys/
(squeeze-32)#
(blank; no output).
 
Old 07-16-2010, 01:14 PM   #4
donnied
Member
 
Registered: Oct 2006
Distribution: Debian x64
Posts: 198

Original Poster
Rep: Reputation: 30
It may be a schroot issue.
# chroot /var/chroot/squeeze-32/
(squeeze-32)root# ls /sys/
block bus class dev devices firmware fs hypervisor kernel module power
 
  


Reply

Tags
chroot, sys


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
tell schroot to permit access to /dev/dsp ernst Debian 1 12-29-2008 06:24 AM
sound in schroot donnied Linux - Software 1 05-25-2008 09:43 AM
mainly schroot (also some nvidia) donnied Linux - Desktop 0 05-12-2008 06:50 PM
Is a Linux sys w/o any passwd's as secure as a microsoft windows sys w/no passwd? t3gah Linux - Security 4 04-22-2005 09:01 PM
/sys not mounting with Kernel 2.6.3-2.1.222 bluester Fedora 0 02-28-2004 04:37 PM


All times are GMT -5. The time now is 12:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration