LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 07-28-2004, 05:18 PM   #1
Oh Cisco
Member
 
Registered: Jul 2004
Location: Phoenix
Distribution: debian etch
Posts: 95

Rep: Reputation: 15
Synaptic will not start after restart!


Well, this is my first post using my new Debian (Sid) based 486 computer.

After I installed synaptic, I used it to install firefox and kdm and then I shut the computer down for a while. When I restarted the computer and tried to use synaptic to install more software I got this error-

(process:976): Gtk-WARNING **: Locale not supported by C library.
Using the fallback 'C' locale.
Xlib: connection to ":0.0" refused by server
Xlib: No protocal specified


(synaptic:976): Gtk-WARNING **: cannot open display:

I do not undrstand what any of this means, so if someone can help please go into a little bit of detail because I still do not know a whole lot of the steps yet.

Thanks
 
Old 07-28-2004, 05:53 PM   #2
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
From what you tell, I reconstruct that in xterm you typed "su" to become the root user and then you typed "synaptic", which gave you the error message. The error probably happened because you logged in as a normal user and tried to launch application as a different user (the root user). Debian's security settings forbid this. You can try (as normal user) the "gksu synaptic" command, which (hopefully) lets you launch Synaptic.
 
Old 07-28-2004, 06:04 PM   #3
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 63
Re: Synaptic will not start after restart!

Quote:
Originally posted by Oh Cisco
Well, this is my first post using my new Debian (Sid) based 486 computer.

After I installed synaptic, I used it to install firefox and kdm and then I shut the computer down for a while. When I restarted the computer and tried to use synaptic to install more software I got this error-

(process:976): Gtk-WARNING **: Locale not supported by C library.
Using the fallback 'C' locale.
Xlib: connection to ":0.0" refused by server
Xlib: No protocal specified


(synaptic:976): Gtk-WARNING **: cannot open display:

I do not undrstand what any of this means, so if someone can help please go into a little bit of detail because I still do not know a whole lot of the steps yet.

Thanks
Try export XAUTHORITY=/home/stephen/.Xauthority in the console window before running the program of course changing "stephen" for your user name. This will allow you to use your normal user connection to the X server as root.
 
Old 07-28-2004, 06:22 PM   #4
macondo
Senior Member
 
Registered: Jul 2003
Location: Panama
Distribution: Debian Sid
Posts: 1,014

Rep: Reputation: 49
APT-HOWTO
http://www.debian.org/doc/manuals/ap.../index.en.html

if you haven't installed a firewall, install guarddog
apt-get install guarddog
 
Old 07-28-2004, 06:45 PM   #5
Oh Cisco
Member
 
Registered: Jul 2004
Location: Phoenix
Distribution: debian etch
Posts: 95

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Dead Parrot
From what you tell, I reconstruct that in xterm you typed "su" to become the root user and then you typed "synaptic", which gave you the error message. The error probably happened because you logged in as a normal user and tried to launch application as a different user (the root user). Debian's security settings forbid this. You can try (as normal user) the "gksu synaptic" command, which (hopefully) lets you launch Synaptic.

You are correct about my login, when I logged out and relogged in as root user synaptic ran correctly.

Thanks
 
Old 07-28-2004, 07:12 PM   #6
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
Ah, but logging in as root user is considered bad practice because especially newbies can easily destroy important system settings without noticing when they have root user's rights (and also experienced users can make mistakes). As long as you're a normal user you cannot mess up your system. It is therefore recommended that you always log in as normal user and use "su" when you need root user's rights. You can do most things in Debian as normal user, so why take any unnecessary risks?

This, of course, means that your original problem is still unsolved. Luckily, there's a workaround for this -- run (as root) the command "ln -fs /home/user_name/.Xauthority /root/.Xauthority" (substitute "user_name" with your user name), then log out and log in again as normal user. Now you should be able to "su" to root in xterm and launch programs as root user without problems.
 
Old 07-29-2004, 01:25 AM   #7
Oh Cisco
Member
 
Registered: Jul 2004
Location: Phoenix
Distribution: debian etch
Posts: 95

Original Poster
Rep: Reputation: 15
Dead Parrot,

The command "ln -fs/home/my user name/.Xauthority/root/.Xauthority" gave me an invalid option error.

When I looked at the help file all of the options had one letter like "ln -f" not two.

Have any ideas?

Last edited by Oh Cisco; 07-29-2004 at 01:30 AM.
 
Old 07-29-2004, 04:32 AM   #8
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
Quote:
The command "ln -fs/home/my user name/.Xauthority/root/.Xauthority" gave me an invalid option error.
There are several parts in this command and you've kind of bundled them together although there should be space between different parts. The first part of the command is "ln", the second part is "-fs", the third part is "/home/user_name/.Xauthority", and the fourth part is "/root/.Xauthority". You must be always very careful when typing commands in the Linux command line, because smallest changes can make the commands do something that you didn't mean them to do.

Here's the command again as it should be:

ln -fs /home/user_name/.Xauthority /root/.Xauthority

Notice the spaces between the four different parts of the command?
 
Old 07-29-2004, 11:44 AM   #9
Oh Cisco
Member
 
Registered: Jul 2004
Location: Phoenix
Distribution: debian etch
Posts: 95

Original Poster
Rep: Reputation: 15
Thanks, Dead Parrot, synaptic is now loading in normal user mode (after I switch to root user)!

Now on to some reading,

Quote:
Originally posted by macondo
APT-HOWTO
http://www.debian.org/doc/manuals/ap.../index.en.html
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to start synaptic logged in as user... Bruce Hill Linux - Software 3 01-26-2006 11:45 PM
synaptic problems at start up roddyguk Linux - Software 7 10-12-2005 02:00 PM
Synaptic Fails to start lmanwarren Linux - Software 1 04-22-2005 11:17 PM
Synaptic will not start D_Linux Linux - Software 1 03-18-2005 01:55 PM
Samba - Start or Restart? Charlie Spencer Linux - Networking 5 11-22-2003 10:39 AM


All times are GMT -5. The time now is 07:12 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration