LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 02-25-2004, 10:06 PM   #1
Zaskar
Member
 
Registered: Feb 2004
Location: NY
Distribution: Debian (Testing)
Posts: 219

Rep: Reputation: 30
stopping xserver from starting up?


hello, i just installed xwindows via apt get and then compiled and installed fluxbox, they run great, but its ar run lvl 2 and x windows seems to start up automatically still, i get that Debian window against the default X backdrop asking for login and password.

and hitting crtl+alt+"backspace" and all it does is reload that screen. lol how do i compleatly exit X so i can install nvidia drivers?

thanks

-Krause
 
Old 02-25-2004, 10:11 PM   #2
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 58
other than the complete instructions
there is a couple different ways noted in the below link :
click here
 
Old 02-25-2004, 11:11 PM   #3
Zaskar
Member
 
Registered: Feb 2004
Location: NY
Distribution: Debian (Testing)
Posts: 219

Original Poster
Rep: Reputation: 30
oh cool man, ty ill go try that

-Zaskar
 
Old 02-25-2004, 11:29 PM   #4
Zaskar
Member
 
Registered: Feb 2004
Location: NY
Distribution: Debian (Testing)
Posts: 219

Original Poster
Rep: Reputation: 30
ok, same probem, it doesnt matter what i change the run lvl to, it still boots X. (and i know i did it right, because on redhat/fedora i changed the runlvl all the time)

i still boot to that Debian GNU/Linux (debian) graphical login :/

-Zaskar
 
Old 02-26-2004, 11:14 AM   #5
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 58
so your telling me that when you change the :
/etc/inittab
file to contain :
id:3:initdefault:
that it still boots X ?
 
Old 02-26-2004, 11:31 AM   #6
llamakc
Member
 
Registered: Nov 2003
Distribution: Debian & Ubuntu
Posts: 402

Rep: Reputation: 31
Yes, Debian uses runlevel 2 by default anyway. What you can do is remove the login manager via apt-get.

Code:
apt-get remove gdm
...or xdm, kdm, wdm. Whatever you have.
 
Old 02-26-2004, 04:16 PM   #7
liquigel
Newbie
 
Registered: Feb 2004
Location: CT, USA
Distribution: Debian stable
Posts: 29

Rep: Reputation: 15
llamakc, why not just "apt-get install rcconf", run it as root, and shut off xdm? (Well, for me it's xdm since I don't have Gnome or KDE installed.)

That way seems the simplest to me, though maybe there's some issue with doing it that way that I don't see. (?)

Also, Zaskar, instead of using rcconf, you could always just change that setting in inittab to 1 (rather than 2) to boot into single-user mode.
 
Old 02-26-2004, 04:37 PM   #8
llamakc
Member
 
Registered: Nov 2003
Distribution: Debian & Ubuntu
Posts: 402

Rep: Reputation: 31
I wasn't aware of that rcconf package. Thanks for that tip!
 
Old 03-06-2004, 01:38 PM   #9
rockee
Member
 
Registered: Feb 2004
Posts: 36

Rep: Reputation: 15
Quote:
Originally posted by llamakc
Yes, Debian uses runlevel 2 by default anyway. What you can do is remove the login manager via apt-get.

Code:
apt-get remove gdm
...or xdm, kdm, wdm. Whatever you have.
I also have the same problem.

What I'd like to be able to do is boot directly in Debian to shell and then be able to "StartX" and then go to my GUI.

Will I still be able to do this if I execute the code above?
 
Old 03-06-2004, 04:59 PM   #10
liquigel
Newbie
 
Registered: Feb 2004
Location: CT, USA
Distribution: Debian stable
Posts: 29

Rep: Reputation: 15
rockee wrote:
What I'd like to be able to do is boot directly in Debian to shell and then be able to "StartX" and then go to my GUI.

Will I still be able to do this if I execute the code above?


I believe so.

xdm/gdm/kdm are just programs that provide that gui login functionality. Removing them doesn't
remove X or anything like that.

Last edited by liquigel; 03-06-2004 at 05:04 PM.
 
Old 03-09-2004, 12:05 AM   #11
rockee
Member
 
Registered: Feb 2004
Posts: 36

Rep: Reputation: 15
Quote:
Originally posted by liquigel
llamakc, why not just "apt-get install rcconf", run it as root, and shut off xdm? (Well, for me it's xdm since I don't have Gnome or KDE installed.)

That way seems the simplest to me, though maybe there's some issue with doing it that way that I don't see. (?)

Also, Zaskar, instead of using rcconf, you could always just change that setting in inittab to 1 (rather than 2) to boot into single-user mode.
I tried it and had message "couldn't find package rcconf".
 
Old 03-09-2004, 01:24 AM   #12
kingka
Member
 
Registered: Aug 2003
Location: mechelen (belgium)
Distribution: debian gnu/linux (sid)
Posts: 99

Rep: Reputation: 15
Post

try:
>> apt-cache search rcconf

I could install it without a problem on debian Sid,
maybe it's a mirror problem (just try it again)

edit: I mean try again
>> apt-get install rcconf
apt-cache search just looks to see if the package is there (if you didn't know this already )

Last edited by kingka; 03-09-2004 at 01:26 AM.
 
Old 03-13-2004, 07:36 AM   #13
xtrim
LQ Newbie
 
Registered: Mar 2004
Distribution: Debian-woody
Posts: 1

Rep: Reputation: 0
Quote:
Originally posted by Zaskar
ok, same probem, it doesnt matter what i change the run lvl to, it still boots X. (and i know i did it right, because on redhat/fedora i changed the runlvl all the time)

i still boot to that Debian GNU/Linux (debian) graphical login :/

-Zaskar
I think this link will be useful
http://www.debian.org/doc/manuals/re...l#s-no-x-start
 
Old 03-13-2004, 11:16 AM   #14
johnMG
Member
 
Registered: Jul 2003
Location: CT, USA
Distribution: Debian Sarge (server), Etch (work/home)
Posts: 601

Rep: Reputation: 31
{Note: liquigel ==> johnMG}

I could install it [rcconf] without a problem on debian Sid,
maybe it's a mirror problem (just try it again)


I've got it installed here on Woody (stable) just fine.

I think this link will be useful
http://www.debian.org/doc/manuals/r...ml#s-no-x-start


Note that rcconf is a ncurses-style gui front-end to the update-rc.d command.
 
Old 03-19-2004, 08:41 AM   #15
rockee
Member
 
Registered: Feb 2004
Posts: 36

Rep: Reputation: 15
Kde 3.2 problem starting

I don't know where else to post this. I am doing it here since it a fresh thread and I have gotten good answers in teh past.

After some work I finally have Debian (Woody) installed on a reasonably fast machine with large disk and good dsiplay. I have seen some good performance once things work properly. My problem is I need to do a lot of tinkering anytime I want things to work properly.

I boot to an x-login screen and can choose among the various window managers. The only way I was able to get DHCP to run automatically was to insert a script in my rc.2 directory with a "pump" command. I needed to fool around with my /etc/host file.

I can bring up Gnome and my apps reasonabty quickly.

MY main problem now is starting up KDE 3.2. I login and choose KDE as my window manger. It says "starting system services" (or something close to that). It then goes to the desktop background and either never brings up my desktop or just sits there for 5 minutes and eventually brings it up. I have seen in other threads that this may be some kind of network conflict and that I should change some file so that they all are in sync with hostname the same.

Does anyone have any ideas?

This is kind of frustraing since when it works, it seem sto be pretty good.

Also, I tried installing printers using KUPS and tried to http:// to some port and was unable to communicate with the port. This will be next on my list.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Stopping X server from starting up Graham_UK Fedora 4 04-19-2005 02:39 PM
stopping and starting net Tinku Linux - Networking 1 08-04-2004 08:58 AM
Stopping X from starting KennyK Linux - Software 4 06-03-2003 08:12 PM
stopping and starting services nero64 Linux - Newbie 3 11-13-2002 01:10 AM
Starting/stopping httpd bughunter Linux - Newbie 3 10-20-2001 10:02 AM


All times are GMT -5. The time now is 04:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration