LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 07-02-2004, 06:37 PM   #1
devfreak
Member
 
Registered: Mar 2004
Location: Maine
Distribution: gentoo 2004.1, ubuntu 4.10, FC3
Posts: 97

Rep: Reputation: 15
Stop modules from loading?


So there's lots of verbage out there on how to start one's modules on boot, but for some reason I have a couple I want to stop from loading, and I can't find out how.

I am trying to get alsa working, and it does if I kill my oss module. I have turned off oss in my 2.6 kernel and recompiled it, but still, these modules are loading. They don't show up in /etc/modules or /etc/modules.conf

Is there a command I can run like gentoo's modules-update when I have my modules the way I want them that will update some file, or is it ok for me to delete these modules in order to stop them from loading? I'll never need them again...

Help?
-Aaron
 
Old 07-02-2004, 08:04 PM   #2
Moloko
Member
 
Registered: Mar 2004
Location: Netherlands
Distribution: Debian
Posts: 729

Rep: Reputation: 30
Do you have hotplug/discover installed? They tend to overdo their hardware detection job.
 
Old 07-02-2004, 08:09 PM   #3
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
Is there an 'oss' service running. If so, try using 'chkconfig --del oss' as root.
 
Old 07-02-2004, 08:13 PM   #4
devfreak
Member
 
Registered: Mar 2004
Location: Maine
Distribution: gentoo 2004.1, ubuntu 4.10, FC3
Posts: 97

Original Poster
Rep: Reputation: 15
chkconfig is not a command that I have, and I believe I have hotplugging enabled in my kernel. Sounded like a good thing.

Basically I just want to stop modules from loading. Is there a way to do this?
 
Old 07-02-2004, 08:20 PM   #5
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
I'm sorry, I was working off the zero-reply list and didn't notice that you were on a Debian machine. My general point is to remove or disable the oss service if it has one.

Sorry for my careless answer.
 
Old 07-02-2004, 08:29 PM   #6
mhiggins
Member
 
Registered: Feb 2004
Posts: 140

Rep: Reputation: 15
Not sure of your exact example but, modules can have dependencies on other modules so one may
"autoload" another.

-Matt
 
Old 07-02-2004, 08:44 PM   #7
devfreak
Member
 
Registered: Mar 2004
Location: Maine
Distribution: gentoo 2004.1, ubuntu 4.10, FC3
Posts: 97

Original Poster
Rep: Reputation: 15
I guess I'll just delete my oss soundcard module. Gentoo has a command that really solves this problem, and I'm sure there has to be one for debian also, but, as always, knowing the command is the problem.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to stop modules loading ionmich Suse/Novell 2 11-12-2005 10:02 PM
Stop loading the modules swmok Linux - Software 1 07-04-2005 04:36 AM
stop loading modules at startup..please help GSX Linux - Newbie 5 03-23-2005 10:19 AM
How do I stop modules from loading on boot? brandor Fedora 14 08-05-2004 08:16 AM
Loading modules error after loading compiled kernel td0l2 Linux - Newbie 12 07-28-2004 11:10 AM


All times are GMT -5. The time now is 09:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration