LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 02-27-2004, 12:27 PM   #1
seanb
LQ Newbie
 
Registered: Aug 2003
Location: New York City
Distribution: Debian SID, RH9, Slackware
Posts: 19

Rep: Reputation: 0
sound works in root - no sound in user - Debian


I installed Debian... after a few fits and starts it works great except for the sound. I can listen to MP3s in the WIndows partition without a problem - as root. When I operate as a user, there is no sound (except for the occasional beep) and I cant play music. I have apt-get removed alsa and then reinstalled it. I have been searching for an answer and cant find one. Help?

I operate the dual-boot, Dell Inspiron 5000 laptop
Debian Unstable (SID)
ESS soundcard

DEMSG says the following:
maestro: Configuring ESS Maestro 2E found at IO 0x1400 IRQ 5
maestro: subvendor id: 0x009f1028
maestro: PCI power management capability: 0x7622
maestro: AC97 Codec detected: v: 0x83847609 caps: 0x6940 pwr: 0xf
maestro: 1 channels configured.
maestro: version 0.15 time 10:28:46 Apr 14 2002

lsmod says the following:
maestro 27456 4
soundcore 3204 3 [maestro]

lscpi says the following:
pcilib: Cannot open /proc/bus/pci/02/00.0
pcilib: Cannot open /proc/bus/pci/02/00.1
lspci: Unable to read 64 bytes of configuration space.

alsamixer returns the following error:
alsamixer: function snd_ctl_open failed for default: No such device

alsactl
alsactl: save_state:1061: No soundcards found...

When I try to play xmms - the thing hangs as a user, works fine as root
When I go to Desktop Preferences-Sound everything looks fine
When I open volume control, nothing is muted, everything is "locked"

thanks guys
 
Old 02-27-2004, 12:31 PM   #2
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Check your /etc/group file. Debian likely has included a group "sound" or something along the lines. In addition, it may have chown'd the /dev/dsp to this group, and given the proper permissions (as this tends to be the accepted way of securely doing things of this nature) to this group. You will then simply need to add your user(s) to this group to enable them to listen to music/sounds.

Cool
 
Old 02-27-2004, 12:31 PM   #3
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
And of course

Moving to Debian Forum

So they can tell you for sure

Cool
 
Old 02-27-2004, 03:04 PM   #4
Strike
Member
 
Registered: Jun 2001
Location: Houston, TX, USA
Distribution: Debian
Posts: 569

Rep: Reputation: 31
You need to add yourself to the audio group. The permissions on the sound devices should already be set. Resist the temptation to chmod 666 anything in spite of the ill-informed advice you may get from some others.
 
Old 02-27-2004, 03:45 PM   #5
seanb
LQ Newbie
 
Registered: Aug 2003
Location: New York City
Distribution: Debian SID, RH9, Slackware
Posts: 19

Original Poster
Rep: Reputation: 0
thanks guys...

Thanks MasterC and Strike

I would have thrown this into Debian forum, except I thought it was more of an newbie thing than a distro issue. Sorry MasterC.

Been warned of chmod before, thanks Strike. After reading your posts:
I vi'ed /etc/group

and saw the following (:
cdrom:x:24:
floppy:x:25:
tape:x:26:
sudo:x:27:
audio:x:29:

root is:
root:x:0:

user is:
seanb:x:1000:

When I had Red Hat, there was a user management screen for prmissions and stuff, and I am still learning Debian... so....

Any suggestion on how I should edit this?

(diving into Debian forum now...)

thanks again guys.
 
Old 02-27-2004, 04:59 PM   #6
Strike
Member
 
Registered: Jun 2001
Location: Houston, TX, USA
Distribution: Debian
Posts: 569

Rep: Reputation: 31
Don't hand-edit files when you can just do addgroup username audio (note, if you don't have addgroup, install the adduser package, which you should have installed anyway)
 
Old 02-27-2004, 05:04 PM   #7
liquigel
Newbie
 
Registered: Feb 2004
Location: CT, USA
Distribution: Debian stable
Posts: 29

Rep: Reputation: 15
Code:
adduser your_username audio
also works.
 
Old 02-27-2004, 05:04 PM   #8
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 63
You should adduser seanb audio as root then logout and back in for the change to take effect. If you still have problems before you start xmms to play a song try lsof /dev/dsp to see if anything has the sound in use already most likely it will be the artsd. Then make sure that you have the xmms-arts plugin installed and in use in the output plugins in the xmms preferences. You are not using alsa at the moment the module loaded tells you that you are using the oss sound through the arts sound server at least that is what KDE defaults too if you are using that not sure about gnome I never use it. In order to use alsa you have to either upgrade to a 2.6 kernel or get the proper drivers built for your running kernel for a 2.4 series.
 
Old 02-27-2004, 11:46 PM   #9
seanb
LQ Newbie
 
Registered: Aug 2003
Location: New York City
Distribution: Debian SID, RH9, Slackware
Posts: 19

Original Poster
Rep: Reputation: 0
now sound doesnt work at all

i dont know what I did. Now sound doesnt work in either root or user.

Debian unstable (SID) on dual boot Dell Inspiron 5000, ESS soundcard

alsamixer:
alsamixer: function snd_ctl_open failed for default: No such device

# lscpi
bash: lscpi: command not found

lsmod unchanged from above

dmesg
unchanged

lsof /dev/dsp
COMMAND PID USER FD TYPE DEVICE SIZE NODE NAME
esd 739 seanb 5w CHR 14,3 247318 /dev/dsp0

/etc/group shows username is listed for sound

modinfo soundcore
filename: /lib/modules/2.4.18-bf2.4/kernel/drivers/sound/soundcore.odescription: "Core sound module"
author: "Alan Cox"
license: "GPL"

So what are my options... apt-get remove alsa? then apt-get install alsa? When I installed debian I selected the ESS driver (soundcard) during setup.

thanks again guys...
 
Old 02-28-2004, 12:42 AM   #10
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 63
Re: now sound doesnt work at all

Quote:
Originally posted by seanb
i dont know what I did. Now sound doesnt work in either root or user.

Debian unstable (SID) on dual boot Dell Inspiron 5000, ESS soundcard

alsamixer:
alsamixer: function snd_ctl_open failed for default: No such device


As I have already told you you are not using alsa the modules for it have a snd prefix like this.
Code:
>$ lsmod
Module                  Size  Used by
snd_pcm_oss            48580  0
snd_mixer_oss          15936  2 snd_pcm_oss
nvidia               2070376  12
apm                    15268  2
snd_emu10k1            63172  1
snd_rawmidi            19648  1 snd_emu10k1
snd_pcm                83520  2 snd_pcm_oss,snd_emu10k1
snd_timer              20928  1 snd_pcm
snd_seq_device          6596  2 snd_emu10k1,snd_rawmidi
snd_ac97_codec         54724  1 snd_emu10k1
snd_page_alloc          9540  2 snd_emu10k1,snd_pcm
snd_util_mem            3456  1 snd_emu10k1
snd_hwdep               7296  1 snd_emu10k1
snd                    46468  10 snd_pcm_oss,snd_mixer_oss,snd_emu10k1,snd_rawmidi,snd_pcm,snd_timer,snd_seq_device,snd_ac97_codec,snd_util_mem,snd_hwdep
uhci_hcd               28616  0
ohci_hcd               15936  0
ehci_hcd               21888  0
evdev                   8256  0
via686a                17028  0
i2c_sensor              2496  1 via686a
i2c_isa                 1984  0
i2c_core               18304  3 via686a,i2c_sensor,i2c_isa
nls_iso8859_15          4608  0
sidewinder             10496  0
emu10k1_gp              2496  0
joydev                  9152  0
gameport                3840  2 sidewinder,emu10k1_gp
sound                  75496  0
soundcore               7584  3 snd,sound
parport_pc             25740  1
lp                      8964  0
parport                36864  2 parport_pc,lp
tulip                  38368  0
crc32                   4096  1 tulip
Quote:
# lscpi
bash: lscpi: command not found
You need the pciutils package installed to do that.
Code:
>$ dpkg -S lspci
pciutils: /usr/bin/lspci
pciutils: /usr/share/man/man8/lspci.8.gz
pciutils: /bin/lspci
Quote:
lsof /dev/dsp
COMMAND PID USER FD TYPE DEVICE SIZE NODE NAME
esd 739 seanb 5w CHR 14,3 247318 /dev/dsp0
This show that you or an application you have started is using the /dev/dsp from the looks of it I am guessing enlightment sound daemon (esd) which IIRC is used by Gnome for sound. Are you using Gnome for the desktop? You should try to kill 739 or if the PID has changed then that new number and start a sound application again and see if there is an output plugin for using that sound daemon although I am not too sure of this never use Gnome.

Quote:
modinfo soundcore
filename: /lib/modules/2.4.18-bf2.4/kernel/drivers/sound/soundcore.odescription: "Core sound module"
author: "Alan Cox"
license: "GPL"
This is not a good sign you are still running the install kernel and there have been several security warnings about vulnerabilites in this kernel.

Quote:
So what are my options... apt-get remove alsa? then apt-get install alsa? When I installed debian I selected the ESS driver (soundcard) during setup.

thanks again guys...
You should upgrade to a new kernel you can still use a 2.4.18 kernel if you wish Debian kernels are patched when new exploits are found and the version number suffix is bumped up so apt will tell you to upgrade the kernel you now have installed. While you are at it get the proper alsa modules that can be installed at the same time for said new kernel if you install a 2.4 series, if a 2.6 there is no need for the alsa modules just the alsa-base and alsa-utils packages these same packages are needed for a 2.4 as well along with the already mentioned alsa kernel module package.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FC3 No Sound As User Works As Root AliasMrJones Fedora 2 01-22-2005 05:34 PM
Sound works as root but not as user? n0x Linux - Hardware 2 09-11-2004 07:27 AM
user sound is fine, Root sound just squeals Doug.Gentry Linux - Newbie 1 09-05-2004 03:27 PM
Sound works for root and first user created, no one else downinthemine Linux - Hardware 7 01-15-2004 08:44 PM
sound works with root not user shanenin Linux - Software 3 10-29-2003 06:05 PM


All times are GMT -5. The time now is 06:21 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration