LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 05-29-2009, 05:45 AM   #1
radiodee1
Member
 
Registered: Oct 2006
Location: New York
Distribution: Debian
Posts: 673
Blog Entries: 11

Rep: Reputation: 36
Sound notification when email is recieved (gnome)


I use sqeeze and a little bit of sid. I also use evolution and gnome. I was going through different preferences and I found that if you go to "System->Preferences->Sound" there is a tab that has options for different alerts and sound effects that you can have your system play when certain actions take place. I want to make it so that a sound plays whenever I receive a new email, BUT on my system everything in this tab of the "Sounds Preferences" dialog box is grayed out. I cannot figure out how to get those options un-grayed.

I can clearly see (in the grayed out material) that there is an option for getting notification when mail is received. How do I do this?

When I click the "help" button on the dialog I get a help window that tells me, among other things, that:

Quote:
You must select the Enable sound server startup option, and the Sounds for events option before you can access the Sound Events tabbed section.
How do I do that? They also mention a "General" tab, which I cannot even find. The only tabs I have are "Devices" and "Sounds". Has anyone else had this experience or anything like it? Thanks.

Last edited by radiodee1; 05-29-2009 at 05:47 AM.
 
Old 05-29-2009, 02:10 PM   #2
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,228
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
I think you need to install esound and gnome-audio to have desktop event sounds..

aptitude update
aptitude install esound gnome-audio


http://blogs.koolwal.net/2009/05/11/...sa-and-esound/

and

Quote:
*Select "Enable sound server startup" of the control board "Sound Preference" of Gnome.
Applications ––> Systeme ––> Configuration ––> Gnome ––> Sound Preference

Last edited by farslayer; 05-29-2009 at 02:11 PM.
 
Old 05-30-2009, 05:42 AM   #3
radiodee1
Member
 
Registered: Oct 2006
Location: New York
Distribution: Debian
Posts: 673
Blog Entries: 11

Original Poster
Rep: Reputation: 36
Quote:
Originally Posted by farslayer View Post
I think you need to install esound and gnome-audio to have desktop event sounds..

aptitude update
aptitude install esound gnome-audio


http://blogs.koolwal.net/2009/05/11/...sa-and-esound/
Unfortunately this didn't work, especially the part later in the post where it says "Applications > Systeme > Configuration > Gnome > Sound Preference". This just doesn't seem to exist on my system.

I googled a little and found someone tried to use gconf to change the keys directly. I went to the key at "/apps/evolution/eplugin/mail-notification" and entered a value in the spot marked "sound-file". I used "/usr/share/sounds/email.wav" but no sound played when I received an email. I find navigating around gconf to be difficult and so I might have missed something. Maybe my sound setup has the volume too low or something dumb like that. I'll try more stuff and post back later, but if anybody has any more suggestions I'd be pleased to hear them. Thanks anyway farslayer.
 
Old 05-30-2009, 06:45 PM   #4
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,228
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
was worth a shot. I've never bothered to work on enabling desktop notification sounds on my system, but I was pretty sure it's esd related.

When you find the solution, please come back and share. It would be greatly appreciated. (and archived for future searches)
 
Old 05-31-2009, 07:32 AM   #5
radiodee1
Member
 
Registered: Oct 2006
Location: New York
Distribution: Debian
Posts: 673
Blog Entries: 11

Original Poster
Rep: Reputation: 36
I'm using gnome 2.24. This is what my "System->Preferences->Sound" dialog box looks like:

http://library.gnome.org/misc/releas...rs.libcanberra

The only difference is that on my computer, under "Sound Theme", where it should say "default", there is nothing. Also, as I said before, the entire contents of that tab (the "Sounds" tab) is grayed out. This leads me to believe I don't have a sound theme installed, but I do have installed the packages gnome-audio and esound, and unfortunately I can't see any packages in the debian archives that have in them sound themes. I'm sort of stuck. If anyone has any ideas I'd love to hear them.
 
Old 06-01-2009, 02:59 PM   #6
radiodee1
Member
 
Registered: Oct 2006
Location: New York
Distribution: Debian
Posts: 673
Blog Entries: 11

Original Poster
Rep: Reputation: 36
I got it to work. I installed pulseaudio-esound-compat, as I use pulseaudio (I guess I didn't even know) and restarted and it worked. The sound plays that I specified in gconf. The "Sounds" tab of "System->Preferences->Sound" is still grayed out.
 
Old 06-01-2009, 03:48 PM   #7
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,228
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
Interesting. pulseaudio is not installed on my Lenny system, but then again this system is an upgrade from Etch, and previously Sarge.

I'll have to look at a Fresh Lenny install to see if they are now using pulseaudio by default.

Thanks for the update !!
 
Old 06-01-2009, 04:57 PM   #8
radiodee1
Member
 
Registered: Oct 2006
Location: New York
Distribution: Debian
Posts: 673
Blog Entries: 11

Original Poster
Rep: Reputation: 36
It's testing, and I'm not sure that it's part of the "official" testing at all. I may have installed pulseaudio somewhere along the way for some reason or another that I cannot remember.
 
Old 06-10-2009, 12:52 PM   #9
radiodee1
Member
 
Registered: Oct 2006
Location: New York
Distribution: Debian
Posts: 673
Blog Entries: 11

Original Poster
Rep: Reputation: 36
I revisited this thing with the sounds because I wanted to remove pulseaudio and have it still work. I removed all pulseaudio packages and the email notification sounds stopped. I was back where I started, so I googled more and found this on a Ubuntu launchpad site:
Quote:
Gnome 2.24 uses a different framework for playing sound events called libcanberra. Libcanberra will not play any sound themes unless it can find the freedesktop sound theme to fall back on, in the event that a sound for a particular event cannot be found.

Ubuntu currently doesn't have this theme in a stand-alone package in the archive. It has been packaged for Debian, however it has been rejected for licensing reasons.
This explains why the "sounds" tab on the gnome-sound-properties dialog box is greyed out. Reading further, someone explains how to get the sounds to work using a 'freedesktop.org' theme. First download the file from here:

http://0pointer.de/public/sound-them...desktop.tar.gz

Then the author did this:
Quote:
extract to /usr/share/sounds and then could get some of the sounds working.
I tried this and it worked for me. Now my sound notification works under alsa, and the "sounds" tab is no longer grayed out. This is the page that has all the original info on it:

https://bugs.edge.launchpad.net/ubuntu/+bug/281044

EDIT: I'm wrong again. In fact installing those files un-grays the "sounds" dialog, but it doesn't make the sounds audible. I'm gonna have to do more messing with these sounds.

Last edited by radiodee1; 06-10-2009 at 02:21 PM.
 
Old 06-10-2009, 02:56 PM   #10
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,228
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
Still interesting.. Thanks for the update. I'm curious now to see your final solution.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to play a sound with gmail notification when email arrives ? frenchn00b Linux - General 6 06-21-2010 12:09 AM
I lost email sound notification in Kmail Mandriva 2008 zebra90210 Linux - Software 0 10-13-2008 10:37 PM
New Email Notification lapthorn Linux - Software 0 02-04-2004 09:44 AM
email notification elainepearl Linux - General 1 01-14-2002 05:58 AM
POP3: I can send email but I can't recieved xtian500 Linux - Networking 1 11-20-2001 04:00 AM


All times are GMT -5. The time now is 05:40 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration