LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 05-03-2004, 04:40 PM   #1
buyer262000
LQ Newbie
 
Registered: May 2004
Posts: 5

Rep: Reputation: 0
Question Sound on Debian Sarge install w/VIA Technologies, Inc. VT8233/A/8235/8237 *more info*


In debian (I'm new) where do you configure sound? I guess it was not autodetected and I can't find the configuration utility.

I did find the infocenter which says:

Installed Drivers:
Type 10 Alsa Emulation

Card Config:
--no soundcards-
Audi, Synth, and Music devices NOT ENABLED IN CONFIG (3 lines actually)

Mixers NOT ENABLED IN CONFIG

running alsamixer at command line gives me:
alsamixer: function snd_ctl_open failed for default: No such device


When I run alsaconf something fails and it tells me to run alsactl restore which gives me:
alsactl: load_state:1134: No soundcards found...

However the sound card is operational in Suse and Windows XP (it is via onboard)

Thanks!

LSPCI is below
0000:00:00.0 Host bridge: VIA Technologies, Inc. VT8377 [KT400/KT600 AGP] Host Bridge
0000:00:01.0 PCI bridge: VIA Technologies, Inc. VT8235 PCI Bridge
0000:00:0f.0 Network controller: Harris Semiconductor Prism 2.5 Wavelan chipset (rev 01)
0000:00:10.0 USB Controller: VIA Technologies, Inc. VT6202 [USB 2.0 controller] (rev 80)
0000:00:10.1 USB Controller: VIA Technologies, Inc. VT6202 [USB 2.0 controller] (rev 80)
0000:00:10.2 USB Controller: VIA Technologies, Inc. VT6202 [USB 2.0 controller] (rev 80)
0000:00:10.3 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 82)
0000:00:11.0 ISA bridge: VIA Technologies, Inc. VT8235 ISA Bridge
0000:00:11.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C/VT8235 PIPC Bus Master IDE (rev 06)
0000:00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 50)
0000:00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 74)
0000:01:00.0 VGA compatible controller: nVidia Corporation NV20 [GeForce3 Ti 200] (rev a3)


Now LSMOD
Module Size Used by
snd_mixer_oss 16512 0
mousedev 9684 2
tsdev 7168 0
psmouse 17160 0
md5 3968 1
ipv6 221120 12
ds 15108 0
yenta_socket 15488 0
pcmcia_core 63840 2 ds,yenta_socket
af_packet 20360 2
snd_via82xx 23456 0
snd_pcm 87972 1 snd_via82xx
snd_timer 23300 1 snd_pcm
snd_ac97_codec 53764 1 snd_via82xx
gameport 4736 1 snd_via82xx
snd_page_alloc 11652 2 snd_via82xx,snd_pcm
snd_mpu401_uart 7168 1 snd_via82xx
snd_rawmidi 22816 1 snd_mpu401_uart
snd_seq_device 7816 1 snd_rawmidi
snd 49124 8 snd_mixer_oss,snd_via82xx,snd_pcm,snd_timer,snd_
ac97_codec,snd_mpu401_uart,snd_rawmidi,snd_seq_device
joydev 9792 0
hid 29376 0
uhci_hcd 29456 0
via_agp 7424 1
agpgart 29608 1 via_agp
evdev 9088 0
ehci_hcd 22532 0
usbcore 94044 5 hid,uhci_hcd,ehci_hcd
via82cxxx_audio 25864 2
uart401 11332 1 via82cxxx_audio
sound 75820 2 via82cxxx_audio,uart401
soundcore 9696 5 snd,via82cxxx_audio,sound
ac97_codec 16908 1 via82cxxx_audio
via_rhine 19720 0
mii 4864 1 via_rhine
crc32 4608 1 via_rhine
orinoco_pci 6656 0
orinoco 38412 1 orinoco_pci
hermes 7808 2 orinoco_pci,orinoco
via_ircc 21520 0
irda 171456 1 via_ircc
ide_cd 38020 0
cdrom 34720 1 ide_cd
rtc 11960 0
reiserfs 197488 1
vfat 14208 0
fat 41792 1 vfat
isofs 32184 0
ext3 103720 0
jbd 54168 1 ext3
ide_disk 15872 3
ide_generic 1408 0 [permanent]
ide_detect 1408 0
via82cxxx 12956 1
ide_core 141804 5 ide_cd,ide_disk,ide_generic,ide_detect,via82cxxx
unix 25520 306
font 8576 0
cfbcopyarea 3968 0
cfbimgblt 3328 0
cfbfillrect 3840 0



Last edited by buyer262000; 05-03-2004 at 08:12 PM.
 
Old 05-04-2004, 07:41 AM   #2
buyer262000
LQ Newbie
 
Registered: May 2004
Posts: 5

Original Poster
Rep: Reputation: 0
Noone?
 
Old 05-04-2004, 09:21 AM   #3
zuralin
Member
 
Registered: Sep 2003
Distribution: Debian testing/unstable
Posts: 225

Rep: Reputation: 30
it *looks* like your device module is loaded so maybe try "dpkg-reconfigure alsa-base"
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Who can use ADI AD1888 sound card on P4R800-V ASUS board on Linux?? vanhelsing Linux - Hardware 6 03-04-2005 06:03 PM
Installing ALSA Drivers on RH9 for Asus P4PE-X on-board sound tkorstanje Red Hat 4 08-20-2004 03:27 AM
Sound problem with ASUS A7V8X-X chipset KT400 mentallysilent Mandriva 30 06-24-2004 08:07 AM
ASUS P4P800 - on-board sound card nowindows Linux - Hardware 7 05-07-2004 04:25 PM
Asus A7v8x On board Lan Not Working. samoul Linux - Hardware 2 01-12-2003 04:25 PM


All times are GMT -5. The time now is 04:39 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration