LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 04-18-2011, 06:51 PM   #1
jlinkels
Senior Member
 
Registered: Oct 2003
Location: Bonaire
Distribution: Debian Lenny/Squeeze/Wheezy/Sid
Posts: 4,087

Rep: Reputation: 492Reputation: 492Reputation: 492Reputation: 492Reputation: 492
Sound in Squeeze, Lord have mercy!


Distro: Debian Squeeze
Sound card: HDA Intel
Sound chip: Realtek ALC 888
Kernel: 2.6.32-5
KDE: 4.4.5

This is the story:

My wife's computer has two microphones, one hardware mic with a 3.5mm plug and a USB camera with integrated mic. Since the camera stands on top of het screen, she prefers the hardware mic which she can hold close to her mouth. Skype is very important to her so she can talk with the kids which are overseas.

Debian installs pulseaudio server by default. This is what happens when pulseaudio is installed:
  • KDE mixer only shows one volume control for the output and one for each input, no other controls.
  • It is not possible to select which sound source to use as default
  • The input source is invariably put back after a reboot to line while this must be front mic
  • The only way I can get the sound setup working properly is using alsamixer
  • At reboot these settings are lost, despite of having them saved with alsactl store
  • Running alsactl restore does restore all settings, except setting the input source correctly
  • Once I set up everything in alsamixer, I can use the hardware mic with Skype.
  • In Skype I can only choose pulseaudio server as sound input. All other settings I have to do with alsamixer.
  • The problem is the settings are not retained and I can't ask my wife to open a terminal and check 17 settings in alsamixer.

So following a recommendation on the KDE forum I removed pulseaudio. Now this is what happens:
  • KMixer shows all my volume controls, and I can select the audio source that I want. Yeah!
  • I can tell Skype to use the USB microphone, and this actually works when all inputs are selected the correct way in alsamixer or KMix.
  • When I restart KDE, the previous settings are being lost, despite I told KMix to store my settings.
  • alsactl does store my settings correctly and restores them correctly at system boot.
  • But then KDE comes and adjusts everything to whatever it likes, not what I saved in KDE, not what alsactl tells.
  • The trick is that I have to setup the audio correctly in alsamixer, use alsactl store, and tell KMixer not to restore the settings when starting KDE (go figure...)
  • This would all be very nice if I could get the front mic actually working. It is selected all right, but I only hear static and buzzing sounds. Arecord records correctly, but Skype refuses to use this microphone. While it did when pulseaudio was still installed.

Sigh... so using the hardware microphone and have all adjustments being saved on startup is mutually exlusive.

jlinkels
 
Old 04-18-2011, 09:35 PM   #2
the dsc
Member
 
Registered: May 2009
Distribution: Debian
Posts: 136
Blog Entries: 71

Rep: Reputation: 33
I have no idea if it would really help, but when I was having issues with sound on Squeeze (I'm now on Wheezy) I've installed the liquorix kernel and they vanished away. Possibly unrelated, my card is some intel onboard, and there's no guarantee that the liquorix kernel will happen to have the module of your card. That is, if that's really a matter of kernel modules, I don't know.
 
Old 04-19-2011, 06:50 AM   #3
cynwulf
Senior Member
 
Registered: Apr 2005
Distribution: OpenBSD, FreeBSD
Posts: 1,293

Rep: Reputation: Disabled
A kernel update may/may not make a difference, but it's worth a try. Rather than liquorix, go with the 2.6.38 from the testing branch - if it doesn't fix it, boot into 2.6.32 and remove it again.
 
Old 04-19-2011, 10:25 AM   #4
the trooper
Senior Member
 
Registered: Jun 2006
Location: England
Distribution: Debian Testing/Unstable Amd64
Posts: 1,476

Rep: Reputation: Disabled
Could you use something other than Kde?.
 
Old 04-23-2011, 06:55 AM   #5
jlinkels
Senior Member
 
Registered: Oct 2003
Location: Bonaire
Distribution: Debian Lenny/Squeeze/Wheezy/Sid
Posts: 4,087

Original Poster
Rep: Reputation: 492Reputation: 492Reputation: 492Reputation: 492Reputation: 492
Quote:
Originally Posted by the trooper View Post
Could you use something other than Kde?.
I should. But I like the window effects. It is a high price to pay.
Since this problem I have been upgrading my T61 laptop which was another bad KDE experience. The sound problem is exactly the same as described in this post. For the rest KDE is like a mystery game. Settings change where you don't expect it, can't be adjusted where you do expect it, many things are hidden and has to be taken care of in the CLI and sometimes get adjusted by KDE -- or not, some settings are saved over KDE restarts, others are not, you never know which those are.... etc, etc.
Upgrading this laptop has taken me over 24 hours now, the most of them being taken by KDE oddities.

jlinkels
 
Old 04-23-2011, 07:00 AM   #6
jlinkels
Senior Member
 
Registered: Oct 2003
Location: Bonaire
Distribution: Debian Lenny/Squeeze/Wheezy/Sid
Posts: 4,087

Original Poster
Rep: Reputation: 492Reputation: 492Reputation: 492Reputation: 492Reputation: 492
Quote:
Originally Posted by Caravel View Post
A kernel update may/may not make a difference, but it's worth a try. Rather than liquorix, go with the 2.6.38 from the testing branch - if it doesn't fix it, boot into 2.6.32 and remove it again.
I have no idea whether this is a kernel problem. Last week I upgraded this Lenovo T61 laptop and I have exactly the same problem with selection of the internal mic. I didn't even bother to try the pulseaudio thing etc. Since this is my own laptop I can use Alsamixer when I start Skype.

When I select internal mic as input I do a alsactl store. When I restart KDE, the input setting is back to mic, and alsactl restore does not restore it. Now is this a alsactl problem (not restoring all settings) or is it a KDE problem (screwing up what was set correctly)

If I knew I could file a bug report.

jlinkels
 
  


Reply

Tags
alsa, pulseaudio, sound


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Sound problems with new squeeze install? lugoteehalt Debian 5 06-10-2011 05:46 AM
[SOLVED] more squeeze problems - no sound now jamesac Debian 13 02-13-2011 06:49 PM
no sound in squeeze/ lenny chroot donnied Debian 1 07-28-2010 01:18 AM
I am at Qt's mercy. Elomis Linux - Software 9 01-06-2005 06:40 AM
Have Mercy! Swatson Linux - Newbie 8 10-22-2003 12:55 PM


All times are GMT -5. The time now is 07:12 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration