LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 10-03-2005, 10:25 PM   #1
zero79
Member
 
Registered: Nov 2003
Location: Ohio
Distribution: Debian Unstable
Posts: 460

Rep: Reputation: 30
sound in qemu guest os on debian?


has anyone had any luck getting sound working in a guest OS running within the QEMU emulator on a Debian 3.1 (sarge) host OS? if so, your advise and expertise would be greatly appreciated :-)

i've tried a lot of things like adding --enable-adlib to ./configure during compilation. i am of course using "qemu -enable-audio". i've tried "QEMU_AUDIO_DRV=alsa qemu -enable-audio" as well. none of this works for me. thanks in advance for any thoughts.

Last edited by zero79; 10-03-2005 at 10:34 PM.
 
Old 10-04-2005, 04:19 AM   #2
frankmulder
Member
 
Registered: Jun 2004
Distribution: Kubuntu
Posts: 30

Rep: Reputation: 15
I just want to let you know that it works for me
-enable-audio was enough.

Frank
 
Old 10-16-2005, 06:42 PM   #3
zero79
Member
 
Registered: Nov 2003
Location: Ohio
Distribution: Debian Unstable
Posts: 460

Original Poster
Rep: Reputation: 30
i found out that the qemu sound card is a non-PnP (Plug and Play) device. so i needed to run the "add new hardware" wizard in the "control panel" in my windows guest os in order for the sound card to be detected. i think that this is automatically done during a normal install, and most people won't run into this if they use -enable-audio when the first install windows.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
QEmu mtecknology Linux - Software 5 09-14-2007 05:30 AM
win2000 server with VMware workstation and Debian woody as guest OS xstation Debian 1 07-14-2005 05:01 PM
Qemu BarfBag Linux - Software 3 06-03-2005 01:06 PM
Qemu on Debian not working? alpha_foobar Linux - Software 4 05-16-2005 03:11 AM
qemu: qemu stopped right after command exec bitpicker Linux - Software 1 03-04-2005 11:25 PM


All times are GMT -5. The time now is 02:56 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration