LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 04-16-2004, 05:32 AM   #1
davidas
Member
 
Registered: Mar 2004
Distribution: Debian 'Sarge'
Posts: 168

Rep: Reputation: 30
Sound error (permission denied in /dev directory)


I've install LICQ, but as recommend by the package, I also install SOX. Then I start LICQ as a normal user. Whenever there is incoming message (a sound accompanies it), I have the following error on the terminal:

sox: Can't open output file '/dev/dsp': Permission denied
playing /usr/share/licq/sounds/icq/Message.wav
sox: Can't open output file '/dev/dsp': Permission denied
playing /usr/share/licq/sounds/icq/Message.wav

Is this the correct permission for the dsp file in /dev?

david:/dev# ls -l dsp
crw-rw---- 1 root audio 14, 3 Mar 15 2002 dsp

All the files in /dev seems to be owned by root though. Does that mean I can only run LICQ as root to have the sound properly played?

Thanks !
 
Old 04-16-2004, 06:37 AM   #2
portux
Member
 
Registered: Apr 2003
Location: Portugal
Distribution: Slackware 10.1
Posts: 42

Rep: Reputation: 15
You should have the file writable (and readble) by others.

"crw-rw-rw- 1 root audio 14, 3 Mar 15 2002 dsp"
 
Old 04-16-2004, 08:11 AM   #3
davidas
Member
 
Registered: Mar 2004
Distribution: Debian 'Sarge'
Posts: 168

Original Poster
Rep: Reputation: 30
What command can I use to list those in 'Audio' group?

Thanks
 
Old 04-16-2004, 08:18 AM   #4
sterrenkijker
Member
 
Registered: Mar 2004
Location: the Netherlands
Distribution: Debian Sarge
Posts: 302

Rep: Reputation: 30
that's a way to do it, the more proper way is adding your user to the group audio:

adduser username audio

choose for username your own username.

I've had the same problem. Quite stupid the user isn't added to the audio group automatically...

Last edited by sterrenkijker; 04-16-2004 at 08:19 AM.
 
Old 04-16-2004, 10:43 AM   #5
davidas
Member
 
Registered: Mar 2004
Distribution: Debian 'Sarge'
Posts: 168

Original Poster
Rep: Reputation: 30
I've added the user into the audio group. However, the same error persists:

david@xdavid:~$
** WARNING **: oss_open(): Failed to open audio device (/dev/dsp): Permission denied

Is there any command to list the users in 'Audio' group for me to verify?

PS. Running Xmms as root works perfectly.

Thanks !

Quote:
Originally posted by sterrenkijker
that's a way to do it, the more proper way is adding your user to the group audio:

adduser username audio

choose for username your own username.

I've had the same problem. Quite stupid the user isn't added to the audio group automatically...
 
Old 04-16-2004, 01:29 PM   #6
mrcheeks
Senior Member
 
Registered: Mar 2004
Location: far enough
Distribution: OS X 10.6.7
Posts: 1,690

Rep: Reputation: 50
su
chmod a+rwx /dev/dsp* /dev/mixer*

ps: avoid X usage as root
 
Old 05-05-2009, 04:51 PM   #7
chika.tambun
LQ Newbie
 
Registered: Mar 2009
Posts: 3

Rep: Reputation: 0
the finest solution for "Failed to open audio device (/dev/dsp): Permission denied"

@mrcheeks
that way too much

just

chika:/etc $ sudo chmod o+rw dsp

[then make sure that it show like this]
chika:/etc $ ls -la dsp
....
crw-rw-rw- 1 root audio 14, 3 2009-05-06 02:40 dsp
....
 
Old 05-05-2009, 05:01 PM   #8
the trooper
Senior Member
 
Registered: Jun 2006
Location: England
Distribution: Debian Testing/Unstable Amd64
Posts: 1,476

Rep: Reputation: Disabled
Have you seen the date on this thread?
 
Old 05-06-2009, 08:54 AM   #9
chika.tambun
LQ Newbie
 
Registered: Mar 2009
Posts: 3

Rep: Reputation: 0
nope

but, i come with the same problem
n the solution is there... i just send the conclusion

btw, thanks 4 reply


add me ym: chika.tambun
 
Old 05-06-2009, 01:29 PM   #10
oʌǝɹ
LQ Newbie
 
Registered: May 2009
Posts: 12

Rep: Reputation: 1
First user created is automatically added to video and audio group. Next ones need to be added manually.
I've never found a command to list users present in a group but
grep audio /etc/group will give you the list of users minus the user that has the same name, if any:
user:x:1000:
audio:x:29:user
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound Server (Permission Denied error) rapont Slackware 8 10-29-2007 03:49 AM
ln: creating symbolic link `/dev/dvd' to `/dev/hdc': Permission denied qazwsx27 Fedora 3 06-14-2005 03:09 PM
/dev/null: Permission denied LavaDevil94 Linux - Software 2 09-15-2004 12:44 AM
/dev/dsp: Permission denied jtX Slackware 1 02-06-2004 06:39 PM
Sound problem - /dev/dsp: Permission denied Oooska Linux - Newbie 4 02-21-2002 02:31 PM


All times are GMT -5. The time now is 05:03 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration