LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices



Reply
 
Search this Thread
Old 04-28-2005, 08:14 AM   #1
Artik
Member
 
Registered: Apr 2005
Location: Israel
Distribution: Debian 3.1 Sarge, Ubuntu Breezy
Posts: 223

Rep: Reputation: 30
Small fonts in Gnome application when running KDE


Hello,

I have some problems with "Gnome/GTK" based application when I run KDE (Like Synaptic or Firefox)

The fonts in menus are very small. It is very hard to read them and I can't adjust them.

KDE applications fonts look normally.
When running Gnome desktop all fonts are normal.

System: Debian Sarge 3.1
Desktop: KDE 3.3, Gnome 2.8,
Kernel:2.6.8
Login manager: GDM

Thanks
 
Old 04-28-2005, 08:23 AM   #2
m_yates
Senior Member
 
Registered: Aug 2003
Location: Upstate
Distribution: Debian, Mint, Mythbuntu
Posts: 1,176

Rep: Reputation: 54
You have to adjust font sizes in gnome. Try running:
Code:
gnome-control-center
If you don't have it, you will have to install it. The gnome control center has an option for adjusting fonts. The default is 10 point, but 11 point is easier to read.
 
Old 04-28-2005, 08:27 AM   #3
Artik
Member
 
Registered: Apr 2005
Location: Israel
Distribution: Debian 3.1 Sarge, Ubuntu Breezy
Posts: 223

Original Poster
Rep: Reputation: 30
But this will affect on fonts for both KDE and Gnome. I do not have problems when running Gnome Desktop the fonts have normal sizes. But when I run KDE Desktop and start some kind of GTK based application it shows small fonts in KDE.

Does font size change will affect only in KDE environment?
Or I missunderstood something
 
Old 04-28-2005, 09:39 AM   #4
m_yates
Senior Member
 
Registered: Aug 2003
Location: Upstate
Distribution: Debian, Mint, Mythbuntu
Posts: 1,176

Rep: Reputation: 54
I guess I misunderstood. Sorry. I do not know how you can do it only in KDE. I use KDE only and do not switch back and forth between Gnome. You can of course adjust font size depending on what desktop manager you use, but that isn't a great solution.
 
Old 04-28-2005, 09:59 AM   #5
Artik
Member
 
Registered: Apr 2005
Location: Israel
Distribution: Debian 3.1 Sarge, Ubuntu Breezy
Posts: 223

Original Poster
Rep: Reputation: 30
Actually that the main thing that prevents me from using KDE.

All GTK applications look....... Not so good. And because Gnome is also very good desktop (more robust) I use it now. However I'd like to use KDE also but the issue of fonts is little bit annoying.

Has anybody had this problem too?
 
Old 04-28-2005, 10:28 AM   #6
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
Open a terminal window and type this command:
Code:
echo "Xft.dpi: 96" > $HOME/.Xresources
Then logout and login again. This should set the default font size to 96 for all applications.

Last edited by Dead Parrot; 04-28-2005 at 05:19 PM.
 
Old 04-28-2005, 10:48 AM   #7
m_yates
Senior Member
 
Registered: Aug 2003
Location: Upstate
Distribution: Debian, Mint, Mythbuntu
Posts: 1,176

Rep: Reputation: 54
I found an interesting package called gtk2-engines-gtk-qt. I just installed it and it makes my gnome applications look pretty uniform with the other applications in KDE. I'm not sure how it affects things in gnome. From the synaptic descruiption of the package:
Quote:
theme engine using Qt for GTK+ 2.x
The GTK-Qt Theme Engine (also known as gtk-qt-engine) is a GTK 2 theme engine
that calls Qt to do the actual drawing. This makes your GTK 2 applications
look almost like real Qt applications and gives you a more unified desktop
experience.

Please note that this package is targeted at KDE users and therefore provides
a way to configure it from within KControl.
 
Old 04-28-2005, 03:46 PM   #8
yotamk
Member
 
Registered: Nov 2004
Location: ~
Distribution: Debian
Posts: 145

Rep: Reputation: 15
I've had similar experience, and this is what made me switch from KDE to Gnome.
Still interested in a solution though
If you find one please post it here.
 
Old 04-28-2005, 04:06 PM   #9
Artik
Member
 
Registered: Apr 2005
Location: Israel
Distribution: Debian 3.1 Sarge, Ubuntu Breezy
Posts: 223

Original Poster
Rep: Reputation: 30
Some additional observations:
  • After I run gnome-control-center in KDE and just enter section of fonts without any changes the fonts become normal and all work fine. Thanks to m_yates. Thus even not applying any changes this load correct defaults for GTK applications
  • If I logout/login I have to run the fonts become small once more and I need to run gnome-control center one more time.
  • It seems to me that when you log into KDE it somehow doesn't load correct GTK libraries settings.

Have anybody find normal solution of the problem?
 
Old 04-29-2005, 08:58 AM   #10
Artik
Member
 
Registered: Apr 2005
Location: Israel
Distribution: Debian 3.1 Sarge, Ubuntu Breezy
Posts: 223

Original Poster
Rep: Reputation: 30
OK I've found the problem:
gnome-settings-daemon should be run on start-up in KDE in order to give correct settings for all GTK applications.

If I run it maually after start-up - all GTK apps work well Gimp, gedit, synaptic etc...

But how do I make gnome-settings-daemon run automatically on start-up?

In gnome I have option like Save session... What can I do in KDE. Can't find anything similar.

Thanks.
 
Old 04-29-2005, 01:40 PM   #11
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 64
Quote:
Originally posted by Artik
OK I've found the problem:
gnome-settings-daemon should be run on start-up in KDE in order to give correct settings for all GTK applications.

If I run it maually after start-up - all GTK apps work well Gimp, gedit, synaptic etc...

But how do I make gnome-settings-daemon run automatically on start-up?

In gnome I have option like Save session... What can I do in KDE. Can't find anything similar.

Thanks.
Put a script in the .kde/env/ directory and it should be executed on startup.
 
Old 04-30-2005, 02:34 AM   #12
Artik
Member
 
Registered: Apr 2005
Location: Israel
Distribution: Debian 3.1 Sarge, Ubuntu Breezy
Posts: 223

Original Poster
Rep: Reputation: 30
Thanks HappyTux!!!

Worked!!!
I've put small script that starts gnome-settings-daem on in .kde/Autostart

That worked fine...
Now let's see what is better for me KDE or Gnome...
 
Old 04-30-2005, 05:12 AM   #13
yotamk
Member
 
Registered: Nov 2004
Location: ~
Distribution: Debian
Posts: 145

Rep: Reputation: 15
Could you write here exactly how you did it?

What did you write in the script?
Under what name did you save it?
etc...

Thanks.
 
Old 04-30-2005, 05:19 AM   #14
Artik
Member
 
Registered: Apr 2005
Location: Israel
Distribution: Debian 3.1 Sarge, Ubuntu Breezy
Posts: 223

Original Poster
Rep: Reputation: 30
I've created following script in vim
vim gsd
Code:
#!/bin/bash
gnome-settings-daemon &
then make it executable:
Code:
chmod +x gsd
then move it to .kde/Autostart
Code:
mv gsd .kde/Autostart/
That's it
then you relog to KDE start gedit to see if fonts look ok.
I've tested afterwards gimp. synaptic all had worked fine.
 
Old 04-30-2005, 05:23 AM   #15
yotamk
Member
 
Registered: Nov 2004
Location: ~
Distribution: Debian
Posts: 145

Rep: Reputation: 15
Quote:
gnome-settings-daemon &
What does the "&" stand for?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Eclipse fonts small in gnome & huge in kde juby Linux - Software 1 05-04-2004 04:56 AM
Fonts in KDE are too small. MadEyeTed Mandriva 5 04-16-2004 09:12 AM
KDE Fonts Occasionally Very Small ErikJohnson Linux - Software 1 03-13-2004 03:08 PM
compiling small KDE application drenal Linux - Newbie 9 01-21-2004 05:44 PM
mozilla interface fonts too small in KDE NOT Gnome m_yates Debian 4 12-16-2003 01:50 PM


All times are GMT -5. The time now is 01:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration