LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 12-18-2006, 06:16 AM   #1
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 52
Sid users - lsymbol getxattr, version Sid : ATTR_1.0 not defined in file libattr.so.1


For those who updated today libattr1, there is a regression, see:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=403590

The problem is visible for example if you do a ls -l, you will get an error:
Quote:
ls: relocation error: /lib/libacl.so.1: symbol getxattr, version
ATTR_1.0 not defined in file libattr.so.1 with link time reference
If you have already updated to version 2.4.35-1, you have to revert to previous version 2.4.32-1

Code:
wget http://ftp.us.debian.org/debian/pool/main/a/attr/libattr1_2.4.32-1_i386.deb
dpkg -i libattr1_2.4.32-1_i386.deb
 
Old 12-18-2006, 11:30 PM   #2
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,732
Blog Entries: 12

Rep: Reputation: 456Reputation: 456Reputation: 456Reputation: 456Reputation: 456
Actually a newer version came in from incoming earlier today that fixed the problem
libattr1:
Installed: 2.4.32-1
Candidate: 1:2.4.32-1.1
 
Old 12-19-2006, 03:54 AM   #3
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Original Poster
Rep: Reputation: 52
Yeah, its fixed - kind of useless post

Quote:
attr (1:2.4.32-1.1) unstable; urgency=emergency

* Non-maintainer upload.
* Reupload previous version and fix breackage of ls -la, cp -a and other
essential utilities.
Closes: #403601, #403592, #403585, #403590, #403599 and probably more.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
will the ltmodem drivers work in debian sid (knoppix sid) maximalred Debian 5 05-29-2009 10:44 AM
Debian SID users: help me by running an nmap on localhost introuble Debian 12 12-19-2006 07:23 AM
LXer: Howto: ATI fglrx driver+Xgl+compiz on Debian Sid for KDE users LXer Syndicated Linux News 0 10-22-2006 06:33 AM
Ok, when one runs apt-get on knoppix does it update it to the full debian sid version maximalred Debian 1 06-24-2004 06:45 AM
What our the differences between debian (Sid) and knoppix 3.4 (Sid)? maximalred Debian 6 06-06-2004 08:39 PM


All times are GMT -5. The time now is 11:40 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration