LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices



Reply
 
Search this Thread
Old 07-15-2007, 01:33 PM   #1
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Rep: Reputation: 48
Sid apt-get error


I'm losing my mind! I have solved problems like this in the past, and somehow whatever I did in the past is completely escaping me at present.

I tried doing a dist-upgrade a few days ago on one of my Sid systems, and it borked over libc6. Here's the output -

Code:
jim@JimsBeastie:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
  libc6-dev: Depends: linux-libc-dev but it is not installed
  libc6-i386: Depends: libc6 (= 2.5-11) but 2.6-2 is installed
E: Unmet dependencies. Try using -f.
Code:
jim@JimsBeastie:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libc6-i386 linux-libc-dev
The following packages will be REMOVED:
  linux-kernel-headers
The following NEW packages will be installed:
  linux-libc-dev
The following packages will be upgraded:
  libc6-i386
1 upgraded, 1 newly installed, 1 to remove and 144 not upgraded.
3 not fully installed or removed.
Need to get 0B/4392kB of archives.
After unpacking 7115kB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 143207 files and directories currently installed.)
Preparing to replace libc6-i386 2.5-11 (using .../libc6-i386_2.6-2_amd64.deb) ...
Unpacking replacement libc6-i386 ...
dpkg: error processing /var/cache/apt/archives/libc6-i386_2.6-2_amd64.deb (--unpack):
 trying to overwrite `/usr/lib32', which is also in package lib32z1
Errors were encountered while processing:
 /var/cache/apt/archives/libc6-i386_2.6-2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
I'm thinking that in the past I'd just yank out all the programs that were causing the complaints from apt, but removing any part of libc looks like it would take out 90% of my system with it. What should I do from here?

Peace,
JimBass
 
Old 07-15-2007, 01:54 PM   #2
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 60
Did you try removing lib32z1, then rerunning apt-get -f install
 
Old 07-15-2007, 02:12 PM   #3
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Original Poster
Rep: Reputation: 48
Yes, I had tried that, and unfortunately it didn't work. Here's the output -
Code:
jim@JimsBeastie:~$ sudo apt-get remove lib32z1
Password:
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  ia32-libs: Depends: lib32z1 but it is not going to be installed
  libc6-dev: Depends: linux-libc-dev but it is not going to be installed
  libc6-i386: Depends: libc6 (= 2.5-11) but 2.6-2 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
jim@JimsBeastie:~$ sudo apt-get remove ia32-libs
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  ia32-libs-gtk: Depends: ia32-libs (>= 1.20) but it is not going to be installed
  libc6-dev: Depends: linux-libc-dev but it is not going to be installed
  libc6-i386: Depends: libc6 (= 2.5-11) but 2.6-2 is to be installed
  nspluginwrapper: Depends: ia32-libs (>= 1.6) but it is not going to be installed
                   Depends: ia32-libs but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
Peace,
JimBass
 
Old 07-15-2007, 03:54 PM   #4
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 60
Strange, I just did a Sid dist-upgrade this morning, and everything installed easily. On my (mostly) Lenny machine, I had to pull in libc6 from Sid to get the latest ffmpeg from debian-multimedia and that installed problem free as well.

I use aptitude exclusively, but I hardly think that would be the answer. ... and I'm sure you've run apt-get update a few times.
 
Old 07-15-2007, 07:17 PM   #5
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Original Poster
Rep: Reputation: 48
Yes Rick, at first I thought it was just unstable being unstable, and assumed somebody would fix it in a day or so. This happened maybe 4 days ago, and seeing that nothing was posted here or on the net at large about it, I realized it was just something that was screwed up on my machine in particular. I have been running apt-get updates almost daily.

At this point I think the best solution would be to use dpkg to list every installed program to a file, then wholesale remove libc6 and everything that has to go with it, then reinstall everything from the file.

I remember us point/counterpointing apt-get vs aptitude in the past. I do understand that aptitude is officially preferred by the Debian team, but I'm very comfortable with apt-get, as it is what I learned on. I do fully agree that it isn't actually the fault of apt-get vs aptitude, as the error is coming from dpkg.

Peace,
JimBass
 
Old 07-15-2007, 07:31 PM   #6
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 64
dpkg -i --force-overwrite /var/cache/apt/archives/libc6-i386_2.6-2_amd64.deb then dpkg --configure -a to get the unconfigured packages what you are seeing is a packaging error only one package at a time can have the same file in it.
 
Old 07-15-2007, 09:30 PM   #7
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Original Poster
Rep: Reputation: 48
Happy Tux thanks so much! I've been tinkering with it nonstop for the past 2 hours, and just saw your post now. I would have done much better to have just checked my email. Those commands cleared it right up.

It looks like somebody caught and tried to fix this error, as I found a buglist about it for version 2.6.1. I'm guessing 2.6.2 was the attempt at the fix, but it didn't work for me obviously.

http://article.gmane.org/gmane.linux...general/277358

Thanks again to both of you and anyone else that read here!

Peace,
JimBass
 
Old 07-17-2007, 08:03 PM   #8
Andersonian
LQ Newbie
 
Registered: Oct 2006
Location: California / Moldova
Distribution: bunch of Ubuntu flavors
Posts: 29

Rep: Reputation: 15
I had the exact same problem (2.6.21 amd64), Happy Tux's suggestion solved almost all problems.
 
Old 07-17-2007, 08:59 PM   #9
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Original Poster
Rep: Reputation: 48
Quote:
Happy Tux's suggestion solved almost all problems.
The mighty Tux's suggestion would have cleared up all your problems, if that was the only one you were having. If anything wasn't resolved, either you didn't follow his instructions or you had another independent problem at the same time.

Peace,
JimBass
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
apt-get upgrade error in sid zakkeyboorock Debian 7 05-03-2006 05:59 AM
gpg errors after apt upgrade (sid) darkleaf Debian 2 06-28-2005 10:22 AM
[Debian Sid] apt problem goRen Linux - Newbie 1 09-26-2004 01:16 AM
SID / apt: How to downgrade a package? sylvain_gnu Debian 6 04-21-2004 07:25 PM
Sid, apt-get install flashplugin-nonfree Outabux Debian 10 04-15-2004 07:21 PM


All times are GMT -5. The time now is 05:49 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration