LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 05-29-2008, 12:37 AM   #1
Raynus
Member
 
Registered: Apr 2007
Location: BKK, Thailand
Distribution: Gentoo 10.1
Posts: 112
Blog Entries: 2

Rep: Reputation: 15
SHMconfig in debian ?


I'm trying to disable my Synaptic touchpad
by install gsynaptic
still, its cannot startup due to "SHMconfig disable"

after adding Synaptic section(my xorg.conf has no synaptic section) & SHMconfig Enable in xorg
(from the guide in Google)
*with NO EFFECT*

somes said that SHMonfig has to disable in debian due to security reason

well the problem is

How can i disable this clumsy touchpad ?

thx in advance.
 
Old 01-24-2010, 11:01 AM   #2
wolsonjr
LQ Newbie
 
Registered: Aug 2007
Distribution: Deb, Mint, Slack, LFS, Fedora, Ubuntu(LXDE)
Posts: 20

Rep: Reputation: 2
shmconfig not enabled

I don't know if you are still looking for an answer, but this has been a real pain.
1. This is still an issue with Deb Lenny
2. HAL fdi/policy settings have been useless
3. The only solution I have found is using /etc/X11/xorg.conf as follows:

Section "InputDevice"
Identifier "AlpsPS/2"
Driver "synaptics"
Option "CorePointer" "true"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "SHMConfig" "true"
Option "Protocol" "auto-dev"
# Option "HorizScrollDelta" "0"
EndSection

Key issue: place this section as the 1st mouse entry ahead of any other mouse sections in your xorg.conf file

Key issue: having the correct identifier, Synaptics Touchpad or as in my case AlpsPS/2

Key issue: the CorePointer option is necessary

With this in place and X11 restarted by rebooting or CTRL-ALT-BKSP, you should now find SHMConfig is recognized as enabled and shared memory is enabled for whatever touchpad utility you wish to use.

In my case I use a simple shell script I got somewhere (thanks!) to turn off my pad when I have my USB mouse attached...

#!/bin/bash
# script to turn off touchpad if mouse present at login
# synclient is the synaptic utility to manage the touchpad
# grep the "lsusb" output and do a wordcount on number of lines with "Logitech" which should = 1 if a Logitech mouse is present
#
# Obviously the "Logitech" should be replaced with your brand of mouse, and perhaps be more exact in case you have other USB devices that have similar names
/usr/bin/synclient touchpadoff=`lsusb | grep Logitech | wc -l`

This works very nicely for me running from my bashrc or just manually.
 
1 members found this post helpful.
Old 02-17-2010, 06:43 PM   #3
fenwar
LQ Newbie
 
Registered: Feb 2010
Posts: 2

Rep: Reputation: 0
Thumbs up

Quote:
Originally Posted by wolsonjr View Post
3. The only solution I have found is using /etc/X11/xorg.conf as follows:

Section "InputDevice"
Identifier "AlpsPS/2"
Driver "synaptics"
Option "CorePointer" "true"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "SHMConfig" "true"
Option "Protocol" "auto-dev"
# Option "HorizScrollDelta" "0"
EndSection

Key issue: place this section as the 1st mouse entry ahead of any other mouse sections in your xorg.conf file

Key issue: having the correct identifier, Synaptics Touchpad or as in my case AlpsPS/2

Key issue: the CorePointer option is necessary
Just had the same problem after installing Lenny on an Acer Extensa 5510, and this (with the "Synaptics Touchpad" identifier) has fixed it. In my case I still had the default mouse section in xorg.conf - commenting it out did the trick.

Thanks!

Last edited by fenwar; 02-17-2010 at 06:45 PM. Reason: added more detail
 
Old 02-17-2010, 09:37 PM   #4
evo2
Senior Member
 
Registered: Jan 2009
Location: Japan
Distribution: Debian
Posts: 4,822

Rep: Reputation: 1022Reputation: 1022Reputation: 1022Reputation: 1022Reputation: 1022Reputation: 1022Reputation: 1022Reputation: 1022
Since you are running Sid, you should probably do this configuration with hal, not xorg.conf.
For example I have /etc/hal/fdi/policy/99-x11-synaptics.fdi

You could put the following in there to disable it.
Code:
<?xml version="1.0" encoding="ISO-8859-1"?>
<deviceinfo version="0.2">
  <device>
    <match key="info.capabilities" contains="input.touchpad">
      <merge key="input.x11_driver" type="string">synaptics</merge>
      <merge key="input.x11_options.SHMConfig" type="string">true</merge>
    </match>
  </device>
</deviceinfo>
Then you probably need to restart hal.

Evo2.
 
  


Reply

Tags
debian, touchpad


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
touchpad problem SHMConfig interm Linux - Newbie 1 05-10-2008 05:17 PM
grub issues: dual boot Debian i386 & Debian amd64 ErrorBound Debian 1 03-09-2007 07:41 PM
Can't seem to disable SHMConfig lmcilwain Linux - Software 2 03-22-2006 02:13 PM


All times are GMT -5. The time now is 05:51 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration